ilch Forum » Ilch CMS 2.X » Fehlersuche und Probleme » Fehlermeldung nach Update Version 2.1.44

Geschlossen
  1. #1
    User Pic
    sauger003 Mitglied
    Registriert seit
    22.11.2018
    Beitrge
    19
    Beitragswertungen
    0 Beitragspunkte
    Was ist das für eine Fehlermeldung nach Update Version 2.1.44 ???


    Warnung: Ungültiges Argument für foreach() in /home/sites/site100024370/web/application/libraries/Ilch/Functions.php in Zeile 199 angegeben


    Functions.php Zeile 199 foreach ($needle as $stack) {


    genervtgenervtgenervtgenervtgenervtgenervt


    verwendete ilch Version: 2.1.x

    betroffene Homepage: externer Link


    Zuletzt modifiziert von sauger003 am 13.12.2022 - 22:49:01
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    330
    Beitragswertungen
    57 Beitragspunkte
    Das Artike-Modul wurde bei dem Update geändert und es scheint so das dein verwendetes Layout diese Änderung noch nicht hat zwinker

    Ist wahrscheinlich ein geändertes Layout auf basis von den "esportlayout"?
    Dann folgende Datei Änderung machen:
    github.com/Slipi85/Ilch-E-Sport-Layout/commit/1f435f47a0e4bf7dec9a486f33fc6b8df7d2d17f

    oder auf das Update von dem Layout warten
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    sauger003 Mitglied
    Registriert seit
    22.11.2018
    Beitrge
    19
    Beitragswertungen
    0 Beitragspunkte
    Was muss ich ändern um die Fehlermeldung zu beseitigen???

    In die Functions.php Zeile 199 oder in die index.php ???


    Danke im Voraus


    Fehlermeldung:

    Warning: Invalid argument supplied for foreach() in /home/sites/site100024370/web/application/libraries/Ilch/Functions.php on line 199


    Zuletzt modifiziert von sauger003 am 14.12.2022 - 00:53:52
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    330
    Beitragswertungen
    57 Beitragspunkte
    Wie gesagt es muss im Layout eine Datei (Siehe Link) geändert werden.
    Die URL zur Datei müsste so lauten : "*root*/application/layouts/*namedeslayouts*/views/modules/article/index/index.php"
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    WeLo Mitglied
    Registriert seit
    22.05.2012
    Beitrge
    36
    Beitragswertungen
    2 Beitragspunkte
    Nach dem Update auf 2.1.44, taucht der Fehler in Einstellungen, Profil auf

    Fatal error: Uncaught TypeError: Argument 1 passed to Ilch\Date::__construct() must be of the type string, null given, called in /var/www/vhosts/hosting181348.ae8be.netcup.net/radio-clubbers.de/httpdocs/application/modules/user/views/panel/profile.php on line 6 and defined in /var/www/vhosts/hosting181348.ae8be.netcup.net/radio-clubbers.de/httpdocs/application/libraries/Ilch/Date.php:48 Stack trace: #0 /var/www/vhosts/hosting181348.ae8be.netcup.net/radio-clubbers.de/httpdocs/application/modules/user/views/panel/profile.php(6): Ilch\Date->__construct() #1 /var/www/vhosts/hosting181348.ae8be.netcup.net/radio-clubbers.de/httpdocs/application/libraries/Ilch/View.php(22): include('/var/www/vhosts...') #2 /var/www/vhosts/hosting181348.ae8be.netcup.net/radio-clubbers.de/httpdocs/application/libraries/Ilch/Page.php(154): Ilch\View->loadScript() #3 /var/www/vhosts/hosting181348.ae8be.netcup.net/radio-clubbers.de/httpdocs/index.php(66): Ilch\Page->loadPage() #4 {main} thrown in /var/www/vhosts/hosting181348.ae8be.netcup.net/radio-clubbers.de/httpdocs/application/libraries/Ilch/Date.php on line 48
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    2.009
    Beitragswertungen
    320 Beitragspunkte
    Kann den Fehler nachvollziehen und schaue es mir gerade an.

    //Edit:
    Ist mit dem nächsten Update behoben.


    Zuletzt modifiziert von blackcoder am 14.12.2022 - 17:06:22
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    sauger003 Mitglied
    Registriert seit
    22.11.2018
    Beitrge
    19
    Beitragswertungen
    0 Beitragspunkte
    Das war die Ursache

    In die Datei:application/layouts/*namedeslayouts*/views/modules/article/index/index.php"

    In die Zeile 17-19 muß der befehl gelöscht werden...


    if (!is_in_array($this->get('readAccess'), explode(',', $article->getReadAccess())) && $adminAccess == false) {
    continue;
    }


    Der Fehler wurde behoben Danke für die schnelle Hilfe... Nex4T
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    xRebellx Mitglied
    Registriert seit
    07.08.2012
    Beitrge
    503
    Beitragswertungen
    27 Beitragspunkte
    Moin ,

    Bei der Spieleliste und dem War Modul kann ich anklicken was ich will es dreht sich kurz was aber Aktualisieren tut er nichts.

    gesperrtes Bild

    Ps. Fehler zeigt er mir auch nicht an
    0 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    M.vittel Mitglied
    Registriert seit
    16.11.2018
    Beitrge
    319
    Beitragswertungen
    24 Beitragspunkte
    Hatte ich auch, nach dem gefühlt Hundertsten mal ging es dann doch :-) also einfach hart bleiben.
    Warum das so ist, weiß ich nicht. Solange keine Fehlermeldung erscheint, ist die Welt ok.
    RealLife ... das ist doch das Game mit der geilen Grafik und der scheiss Story
    1 Mitglieder finden den Beitrag gut.
  10. #10
    User Pic
    xRebellx Mitglied
    Registriert seit
    07.08.2012
    Beitrge
    503
    Beitragswertungen
    27 Beitragspunkte
    ZitatZitat geschrieben von M.vittel
    Hatte ich auch, nach dem gefühlt Hundertsten mal ging es dann doch :-) also einfach hart bleiben.
    Warum das so ist, weiß ich nicht. Solange keine Fehlermeldung erscheint, ist die Welt ok.


    Moin,moin

    Okay dann warte ich mal und eventuell geht es dann :-)

    PS. es kommt nur die Meldung Modul konnte nicht aktualisiert werden.

    gesperrtes Bild


    Zuletzt modifiziert von xRebellx am 17.12.2022 - 10:22:28
    0 Mitglieder finden den Beitrag gut.
  11. #11
    User Pic
    M.vittel Mitglied
    Registriert seit
    16.11.2018
    Beitrge
    319
    Beitragswertungen
    24 Beitragspunkte
    Jetzt habe ich gesehen es geht um das Modul War, dass nutze ich selber nicht. Was passiert, wenn du auf herunterladen kickst? Geht es dann?
    RealLife ... das ist doch das Game mit der geilen Grafik und der scheiss Story
    0 Mitglieder finden den Beitrag gut.
  12. #12
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    2.009
    Beitragswertungen
    320 Beitragspunkte
    @xRebellx
    Ist das noch lokal unter Windows oder auf einem Linux-Server?
    Geh mal ins Admincenter unter Informationen und dort den Punkt "Ordner Rechte". Unten bitte den Link "Rechte aller Dateien prüfen" klicken und dann vor allem gucken ob beim War-Modul und den Modulen wo du die Meldung "Modul konnte nicht aktualisiert werden" alles passt.
    0 Mitglieder finden den Beitrag gut.
  13. #13
    User Pic
    xRebellx Mitglied
    Registriert seit
    07.08.2012
    Beitrge
    503
    Beitragswertungen
    27 Beitragspunkte
    ZitatZitat geschrieben von blackcoder
    @xRebellx
    Ist das noch lokal unter Windows oder auf einem Linux-Server?
    Geh mal ins Admincenter unter Informationen und dort den Punkt "Ordner Rechte". Unten bitte den Link "Rechte aller Dateien prüfen" klicken und dann vor allem gucken ob beim War-Modul und den Modulen wo du die Meldung "Modul konnte nicht aktualisiert werden" alles passt.


    Ist ein Linux Server, habe alles so gemacht wie du geschrieben hast es steht überall Beschreibbar auch zum Beispiel bei application\modules\war\ steht auch Beschreibbar.


    Zuletzt modifiziert von xRebellx am 18.12.2022 - 08:35:05
    0 Mitglieder finden den Beitrag gut.
  14. #14
    User Pic
    WeLo Mitglied
    Registriert seit
    22.05.2012
    Beitrge
    36
    Beitragswertungen
    2 Beitragspunkte
    Eben habe ich versucht das aktuelle Update 2.1.45 zu installieren. Runtergeladen wurde es, aber bei der Installation kommt folgende Error Meldung:

    An unexpected error occurred:
    MySQL Error: Table 'ilch_articles_access' already exists
    in Query[SubQuery 1]: CREATE TABLE `ilch_articles_access` (
    `article_id` INT(11) NOT NULL,
    `group_id` INT(11) NOT NULL,
    PRIMARY KEY (`article_id`, `group_id`) USING BTREE,
    INDEX `FK_ilch_articles_access_[prefix]_groups` (`group_id`) USING BTREE,
    CONSTRAINT `FK_ilch_articles_access_[prefix]_articles` FOREIGN KEY (`article_id`) REFERENCES `ilch_articles` (`id`) ON UPDATE NO ACTION ON DELETE CASCADE,
    CONSTRAINT `FK_ilch_articles_access_[prefix]_groups` FOREIGN KEY (`group_id`) REFERENCES `ilch_groups` (`id`) ON UPDATE NO ACTION ON DELETE CASCADE
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;
    0 Mitglieder finden den Beitrag gut.
  15. #15
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    330
    Beitragswertungen
    57 Beitragspunkte
    Dies wurde in der V44 eingeführt, es ist möglich das er dieses update noch nicht abgeschlossen hatte.
    0 Mitglieder finden den Beitrag gut.
  16. #16
    User Pic
    WeLo Mitglied
    Registriert seit
    22.05.2012
    Beitrge
    36
    Beitragswertungen
    2 Beitragspunkte
    gesperrtes Bild

    Das sieht wohl in der Tat so aus. Jedoch besteht keine Möglichkeit, die V44 erneut zu installieren. Es wird nur die V45 zur Aktualisierung angeboten.
    0 Mitglieder finden den Beitrag gut.
  17. #17
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    330
    Beitragswertungen
    57 Beitragspunkte
    Um dies möglich zu machen, würde ich vorschlagen die Änderungen von der 44 händisch zu kontrollieren/zu machen.
    Also alle DB Änderungen kontrollieren :
    github.com/IlchCMS/Ilch-2.0/blob/master/application/modules/admin/config/config.php#L773
    github.com/IlchCMS/Ilch-2.0/blob/master/application/modules/calendar/config/config.php#L136
    github.com/IlchCMS/Ilch-2.0/blob/master/application/modules/war/config/config.php#L215

    Gegenbefalls alle Dateien kontrollieren oder ersetzten
    github.com/IlchCMS/Ilch-2.0/releases/tag/v2.1.44

    Wenn alles up to Date ist kann die Version in der Datenbank in der Tabelle '_config' Key 'version' auf '2.1.44' ändern.

    Dann das Update 45 anstoßen
    0 Mitglieder finden den Beitrag gut.
  18. #18
    User Pic
    WeLo Mitglied
    Registriert seit
    22.05.2012
    Beitrge
    36
    Beitragswertungen
    2 Beitragspunkte
    Besten Dank für deine Anleitung hhunderter. Update war erfolgreich. Ich musste nur die Versions Nr in der DB ändern, alles andere war identisch. Danach funktionierte das Update.

    Besten Dank
    0 Mitglieder finden den Beitrag gut.
  19. #19
    User Pic
    WeLo Mitglied
    Registriert seit
    22.05.2012
    Beitrge
    36
    Beitragswertungen
    2 Beitragspunkte
    Also irgendwie hat das Update V44 ein Problem. Auf meiner zweiten Webseite wollte ich nun die Updates auch ausführen, doch bei der Installation von V44 kommt folgende Meldung:

    An unexpected error occurred:
    MySQL Error: Can't create table `web6`.`ilch_users_notifications` (errno: 150 "Foreign key constraint is incorrectly formed")
    in Query[SubQuery 1]: CREATE TABLE IF NOT EXISTS `ilch_users_notifications` (
    `id` INT(11) UNSIGNED NOT NULL AUTO_INCREMENT,
    `user_id` INT(11) UNSIGNED NOT NULL,
    `timestamp` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP,
    `module` VARCHAR(255) NOT NULL,
    `message` VARCHAR(255) NOT NULL,
    `url` VARCHAR(255) NOT NULL,
    `type` VARCHAR(255) NOT NULL,
    PRIMARY KEY (`id`) USING BTREE,
    INDEX `FK_ilch_users_notifications_[prefix]_users` (`user_id`) USING BTREE,
    INDEX `FK_ilch_users_notifications_[prefix]_modules` (`module`) USING BTREE,
    CONSTRAINT `FK_ilch_users_notifications_[prefix]_modules` FOREIGN KEY (`module`) REFERENCES `ilch_modules` (`key`) ON UPDATE NO ACTION ON DELETE CASCADE,
    CONSTRAINT `FK_ilch_users_notifications_[prefix]_users` FOREIGN KEY (`user_id`) REFERENCES `ilch_users` (`id`) ON UPDATE NO ACTION ON DELETE CASCADE
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci AUTO_INCREMENT=1;

    CREATE TABLE IF NOT EXISTS `ilch_users_notifications_permission` (
    `id` INT(11) NOT NULL AUTO_INCREMENT,
    `user_id` INT(11) UNSIGNED NOT NULL,
    `module` VARCHAR(255) NOT NULL,
    `type` VARCHAR(255) NOT NULL,
    `granted` TINYINT(1) NOT NULL DEFAULT 1,
    PRIMARY KEY (`id`) USING BTREE,
    INDEX `FK_ilch_users_notifications_permission_[prefix]_users` (`user_id`) USING BTREE,
    INDEX `FK_ilch_users_notifications_permission_[prefix]_modules` (`module`) USING BTREE,
    CONSTRAINT `FK_ilch_users_notifications_permission_[prefix]_modules` FOREIGN KEY (`module`) REFERENCES `ilch_modules` (`key`) ON UPDATE NO ACTION ON DELETE CASCADE,
    CONSTRAINT `FK_ilch_users_notifications_permission_[prefix]_users` FOREIGN KEY (`user_id`) REFERENCES `ilch_users` (`id`) ON UPDATE NO ACTION ON DELETE CASCADE
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;
    0 Mitglieder finden den Beitrag gut.
  20. #20
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    330
    Beitragswertungen
    57 Beitragspunkte
    ich konnte das Problem herausfinden arbeite schon an einer lösung
    0 Mitglieder finden den Beitrag gut.
  21. #21
    User Pic
    WinterKA Mitglied
    Registriert seit
    16.04.2010
    Beitrge
    60
    Beitragswertungen
    2 Beitragspunkte
    Servus

    wollte heute updaten und erhalte folgende Fehlermeldung:

    MySQL-Fehler: Tabelle ilch_articles_access existiert bereits
    in Query[SubQuery 1]: CREATE TABLE `ilch_articles_access` (
    `article_id` INT(11) NICHT NULL,
    `group_id` INT(11) NICHT NULL,
    PRIMARY KEY (`article_id`, `group_id`) MIT BTREE,
    INDEX `FK_ilch_articles_access_[prefix]_groups` (`group_id`) USING BTREE,
    CONSTRAINT `FK_ilch_articles_access_[prefix]_articles` FOREIGN KEY (`article_id`) REFERENCES `ilch_articles` (`id`) ON UPDATE NO ACTION ON DELETE CASCADE,
    EINSCHRÄNKUNG `FK_ilch_articles_access_[prefix]_groups` FOREIGN KEY (`group_id`) REFERENCES `ilch_groups` (`id`) ON UPDATE KEINE AKTION BEI KASKADE LÖSCHEN
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_ci;

    Was muss ich in meiner Datenbank ändern bzw. wer kann mir helfen? Ich wollte auf Version 2.1.44 updaten.

    Homepage: www.wintermini.de


    Zuletzt modifiziert von WinterKA am 18.12.2022 - 23:55:33
    externer Link Technik im Modellsport
    0 Mitglieder finden den Beitrag gut.
  22. #22
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    330
    Beitragswertungen
    57 Beitragspunkte
    Dann einmal ab hier alles kontrollieren: www.ilch.de/index.php?forum-showposts-58507-p1#406718
    0 Mitglieder finden den Beitrag gut.
  23. #23
    User Pic
    WinterKA Mitglied
    Registriert seit
    16.04.2010
    Beitrge
    60
    Beitragswertungen
    2 Beitragspunkte
    ZitatZitat geschrieben von hhunderter
    Dann einmal ab hier alles kontrollieren: externer Link
    Danke hat funktioniert.

    Problem jetzt, Version 2.1.45 wird nicht angezeigt. Jetzt steht 2.1.44 ist aktuell, was kann ich jetzt machen?
    externer Link Technik im Modellsport
    0 Mitglieder finden den Beitrag gut.
  24. #24
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    2.009
    Beitragswertungen
    320 Beitragspunkte
    Ist der richtige Updateserver ausgewählt?

    Im Admincenter unter Einstellungen sollte der Updateserver mit folgender Adresse ausgewählt sein:
    www.ilch.de/ilch2_updates/stable/

    Vielleicht den nochmal auswählen und Einstellung speichern.
    0 Mitglieder finden den Beitrag gut.
  25. #25
    User Pic
    WinterKA Mitglied
    Registriert seit
    16.04.2010
    Beitrge
    60
    Beitragswertungen
    2 Beitragspunkte
    Das steht bei mir drin:

    ilch2.de/development/updateserver/stable/

    habe es jetzt geändert passt super. Vielen Dank für die Hilfe


    Zuletzt modifiziert von WinterKA am 22.12.2022 - 09:59:00
    externer Link Technik im Modellsport
    0 Mitglieder finden den Beitrag gut.
  26. #26
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    2.009
    Beitragswertungen
    320 Beitragspunkte
    Schön zu hören, dass es jetzt klappt.

    Der "ilch2.de"-Server ist der alte Server, welcher normalerweise automatisch beim Update gelöscht wird. Dieser wird wohl auch bald abgeschaltet.

    Diesen könnten Sie auch aus der Datenbank löschen, wenn Sie möchten.
    Er ist in der Tabelle "[prefix]_admin_updateservers" zu finden.
    0 Mitglieder finden den Beitrag gut.
  27. #27
    User Pic
    M.vittel Mitglied
    Registriert seit
    16.11.2018
    Beitrge
    319
    Beitragswertungen
    24 Beitragspunkte
    Mal eine Frage, wird der Bug noch behoben beim nächsten Update, sodass man auf eine PN wieder antworten kann?
    RealLife ... das ist doch das Game mit der geilen Grafik und der scheiss Story
    0 Mitglieder finden den Beitrag gut.
  28. #28
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    2.009
    Beitragswertungen
    320 Beitragspunkte
    Wenn du von diesem Problem redest, dann heißt die Antwort erstmal nein:
    www.ilch.de/forum-showposts-58504-p1.html#406663

    Du kannst diese Issues auf GitHub beobachten, wenn du über den Fortschritt informiert bleiben möchtest:
    github.com/IlchCMS/Ilch-2.0/issues/490
    github.com/IlchCMS/Ilch-2.0/issues/451
    github.com/IlchCMS/Ilch-2.0/issues/445

    github.com/IlchCMS/Ilch-2.0/pull/494

    Daran weiter zu arbeiten ist allerdings auf meiner ToDo-Liste auf Platz 2.
    0 Mitglieder finden den Beitrag gut.
  29. #29
    User Pic
    M.vittel Mitglied
    Registriert seit
    16.11.2018
    Beitrge
    319
    Beitragswertungen
    24 Beitragspunkte
    Ok, dann weiß ich erstmal Bescheid.


    Zuletzt modifiziert von M.vittel am 28.12.2022 - 16:37:26
    RealLife ... das ist doch das Game mit der geilen Grafik und der scheiss Story
    1 Mitglieder finden den Beitrag gut.
  30. #30
    User Pic
    WinterKA Mitglied
    Registriert seit
    16.04.2010
    Beitrge
    60
    Beitragswertungen
    2 Beitragspunkte
    Also seit dem Update habe ich nur noch Fehler. Das ist wirklich ärgerlich. Weiß nicht ob das schon bekannt ist beim Profil anschauen kommt der Fehler:

    An unexpected error occurred:
    MySQL Error: Table 'wintermini.ilch_users_notifications' doesn't exist
    in Query: SELECT * FROM `ilch_users_notifications` WHERE `user_id` = "1" ORDER BY `type` ASC,`id` DESC


    Wenn ich ein neuen Untermenüpunkt setzen will im Menü, funktioniert das nicht sondern er schiebt ihn als Hauptmenüpunkt und im Hintergrund kommt dann so ein Fehler:

    Notice: Undefined property: stdClass::$item_id in /var/www/vhosts/wintermini.de/wintermini/application/modules/admin/controllers/admin/Menu.php on line 76

    Version 2.1.45
    externer Link Technik im Modellsport
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Fehlersuche und Probleme

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten