ilch Forum » Ilch CMS 2.X » Allgemein » hilfe ich komm in meine seite nicht mehr

Geschlossen
  1. #1
    User Pic
    Linn Mitglied
    Registriert seit
    24.10.2022
    Beitrge
    16
    Beitragswertungen
    6 Beitragspunkte
    Heute wollte ich mal wieder in das Forum schauen aber das ging nicht ich habe Fehlermeldun erhalten .. und auch die Galerie machte Fehlermeldung ... so habe ich versucht über Lima city eoin Backup zu machen und nun komme ich gar nicht mehr rein
    Fehlermeldung lautet :

    Forbidden
    You don't have permission to access this resource.

    Apache/2.4 Server at www.chat-welt.de Port 443

    was kann ich jetzt tun damit das wieder in Ordnung kommt ? ich kann so auch nicht in meinen chat traurig....

    Nach einem restore kam ich wieder auf die seite und in meinen chat nur ist immernoch das problem wenn ich in das Forum möchte ... es kommt
    Warnung : Undefinierter Array-Schlüssel read_access in /home/webpages/lima-city/linn/default-website/ilch/application/modules/forum/mappers/Forum.php in Zeile 45

    Warnung : Undefinierter Array-Schlüssel replay_access in / home/webpages/lima-city/linn/default-website/ilch/application/modules/forum/mappers/Forum.php in Zeile 46

    Warnung : Undefinierter Array-Schlüssel create_access in /home/webpages/lima-city/linn/ default-website/ilch/application/modules/forum/mappers/Forum.php in Zeile 47

    Warnung : Undefinierter Array-Schlüssel read_access in /home/webpages/lima-city/linn/default-website/ilch/application/modules/ forum/mappers/Forum.php in Zeile 45

    Warnung : Undefinierter Array-Schlüssel replay_access in /home/webpages/lima-city/linn/default-website/ilch/application/modules/forum/mappers/Forum.php in Zeile 46

    Warnung : Undefinierter Array-Schlüssel create_access in /home/webpages/lima-city/linn/default-website/ilch/application/modules/forum/mappers/Forum.php in Zeile 47.
    Ein unerwarteter Fehler ist aufgetreten:
    MySQL-Fehler: Unbekannte Spalte topic_id in Feldliste
    in der Abfrage: SELECT COUNT(topic_id) FROM `ich_forum_topics` WHERE `topic_id` = "3"

    bei der galerie die zwar noch nicht genutzt wird kommt diese fehlermeldung :

    Ein unerwarteter Fehler ist aufgetreten:
    MySQL-Fehler: Unbekannte Spalte gallery_id in where-Klausel
    in der Abfrage: SELECT * FROM `ich_gallery_items` WHERE (`gallery_id` = "1" AND `parent_id` = "0") ORDER BY `sort` ASC

    Gästebuch, Kalender und Auszeichnungen funktioniern ... Kann mir bitte jemand helfen ? L.G.Linn


    verwendete ilch Version: 2.1.x

    betroffene Homepage: chat-welt.de


    Zuletzt modifiziert von Linn am 14.12.2023 - 13:42:23
    Wenn die Kraft zum weinen Fehlt,.... dann lach!:)
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    2.255
    Beitragswertungen
    353 Beitragspunkte
    Moin,

    was das Forum betrifft, sieht es aus wie dieses Problem:
    www.ilch.de/forum-showposts-58637-p1.html#407931

    Der Link für die aktuelle Version vom Forum ist aber nun dieser:
    www.ilch.de/ilch2_updates/stable/modules/forum-v1.34.4.zip

    Gruß
    blackcoder
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    Linn Mitglied
    Registriert seit
    24.10.2022
    Beitrge
    16
    Beitragswertungen
    6 Beitragspunkte
    Vielen lieben Dank für die Antwort . Nun bin ich aber leider nicht so Erfahren wie viele andere Schreiber hier traurig. Ich hätt aber schon gerne wieder mein Forum ... könnten sie mir bitte genau erklären wie ich jetzt vorzugehen habe ? Ich währe ihnen sehr dankbar L.G.Linn

    Ich glaube auch dass ich den neuen link eigentlich schon habe gesperrtes Bild


    Zuletzt modifiziert von Linn am 14.12.2023 - 16:36:48
    Wenn die Kraft zum weinen Fehlt,.... dann lach!:)
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    422
    Beitragswertungen
    65 Beitragspunkte
    Blackcoder meinte eher das das Modul aktualisiert werden sollte:
    -> Backend (Admincenter)
    -> Module
    -> Übersicht
    -> Updates
    -> Forum Aktualisieren
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    Linn Mitglied
    Registriert seit
    24.10.2022
    Beitrge
    16
    Beitragswertungen
    6 Beitragspunkte
    Guten Morgen
    Danke für die Antwort . Leider bin ich eine absolute Niete was das Programmieren und so weiter angeht . Jetzt bin ich deinem Weg gefolgt hhunderter und komm nicht weiter weil ich jetzt nicht weiss wo ich das jetzt aktualisieren kann .. oder wie ich ansonnsten vorgehen kann und ehe ich das was kaputt mache .. ( was auch schon war;( ) frage ich lieber in meiner art und weise ... ich weiss das kann schonmal nerfen ... Bitte helft mir

    gesperrtes Bild

    L.G.Linn
    Wenn die Kraft zum weinen Fehlt,.... dann lach!:)
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    2.255
    Beitragswertungen
    353 Beitragspunkte
    Moin,

    wie man jetzt auch auf deinen Screenshot sieht, ist das Forum auf Version 1.34.4 (laut Datenbank-Einträge), aber anhand der Fehlermeldungen sieht man, dass das Forum noch versucht auf die alten Spalten usw. zuzugreifen. Das heißt, dass die Dateien vom Forum vermutlich nicht aktualisiert wurden. Die Idee bei meinem verlinkten Beitrag ist, dass die Dateien vom Forum manuell aktualisiert werden, indem die aktuelle Version vom Forum vom Server geladen wird und diese Dateien dann hochgeladen werden. Die alten Dateien vom Forum müssen überschrieben werden (daher vorher eine Sicherheitskopie erstellen).

    Hier sind die einzelnen Schritte:
    www.ilch.de/forum-showposts-58637-p1.html#407931

    Wichtig ist, aber auch den Link mit der Version 1.34.4 zu nutzen und nicht den veralteten im anderen Beitrag.

    Wie auch in dem verlinkten Beitrag erwähnt, sollte anschließend überprüft werden, ob die Rechte passen. Es ist jedenfalls nicht der Normalfall, dass Ilch die Dateien nicht aktualisieren kann.

    Gruß
    blackcoder


    Zuletzt modifiziert von blackcoder am 15.12.2023 - 14:32:45
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    Linn Mitglied
    Registriert seit
    24.10.2022
    Beitrge
    16
    Beitragswertungen
    6 Beitragspunkte
    Vielen dank für die hilfe ! Ich habe versucht diese ratschläge umzusetzen aber leider funktioniert nix wenn ich das Forum jetzt aufrufe dann ist das jetzt angezeigt :

    gesperrtes Bild

    aber nicht nur beim Forum ist dieses problem , sondern auch bei der Galerie kommt nur eine fehlermeldung

    Ein unerwarteter Fehler ist aufgetreten:
    Unbekannte Spalte gallery_id in der Where-Klausel

    auch bei FAQ steht oben drüber fehlermeldung aber zumindest erscheint es noch

    Warning: Undefined array key "read_access" in /home/webpages/lima-city/linn/default-website/ilch/application/modules/faq/mappers/Category.php on line 38

    Warning: Undefined array key "read_access" in /home/webpages/lima-city/linn/default-website/ilch/application/modules/faq/mappers/Category.php on line 38


    es ist zum verzweifeln traurig die backups von früher werden zum teil gefunden können aber nicht geöffnet werden weinen L.G.Linn
    Wenn die Kraft zum weinen Fehlt,.... dann lach!:)
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    2.255
    Beitragswertungen
    353 Beitragspunkte
    Moin,

    ich kann anbieten, dass ich mir das direkt angucke. Dafür bräuchte ich aber Zugriff auf die Datenbank (z.B. über phpMyAdmin), die Möglichkeit Dateien auf den Webspace/Server hochzuladen und soweit Zugriff auf die Seite, dass ich sehen kann ob die Fehler behoben sind. Die Zugangsdaten aber bitte per PN und nicht hier öffentlich.

    Ich würde dann kontrollieren, ob die Tabellen in der Datenbank entsprechend aktualisiert wurden und dies zur Not von Hand erledigen. Außerdem würde ich prüfen, ob die Dateien der Module zum Stand der Datenbank passen. Falls nicht würde ich dann die Dateien der Module in der passenden Version hochladen.

    In deinem Screenshot sehe ich z.B. das beim Forum versucht wird auf eine Spalte "replay_access" zuzugreifen. Die Spalte gibt es seit dem Forum in Version 1.34.0 gar nicht mehr. Dies gilt ebenso für die Spalten "create_access" und "read_access".

    Gruß
    blackcoder


    Zuletzt modifiziert von blackcoder am 16.12.2023 - 06:57:55
    1 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    Linn Mitglied
    Registriert seit
    24.10.2022
    Beitrge
    16
    Beitragswertungen
    6 Beitragspunkte
    Ich möchte es hier auch noch einmal ganz offen schreiben . Vielen lieben Dank den Leuten, die sich hier so um mich und mein Problem gekümmert haben ! Einfach nur klasse ich hab sowas auch schon ganz anders erlebt. (in anderen Foren) . Hier ist man als vollkommener Laie und noch dazu Blond wirklich gut aufgehoben.:) Alles funktioniert wieder bestens und ich bin sehr erleichtert. DANKE! lachen L.G.Linn


    Zuletzt modifiziert von Linn am 16.12.2023 - 13:52:05
    Wenn die Kraft zum weinen Fehlt,.... dann lach!:)
    2 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Allgemein

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten