ilch Forum » Ilch CMS 2.X » Installation und Upgrades » Forum zerschossen

Geschlossen
  1. #1
    User Pic
    Shorty2710 Mitglied
    Registriert seit
    25.03.2019
    Beitrge
    12
    Beitragswertungen
    0 Beitragspunkte
    Hallo zusammen,

    ich habe gestern abend die Serversion geupdatet. Hat alles wunderbar funktioniert.
    Heute wollte ich mich an die Module machen, und habe mir dabei irgendwie einen Fehler eingehandelt. schockiert
    Ich bitte um Hilfe verletztweinen

    Notice: Undefined index: read_access in /var/www/vhosts/dok-clan.de/httpdocs/application/modules/forum/mappers/Forum.php on line 45

    Notice: Undefined index: replay_access in /var/www/vhosts/dok-clan.de/httpdocs/application/modules/forum/mappers/Forum.php on line 46

    Notice: Undefined index: create_access in /var/www/vhosts/dok-clan.de/httpdocs/application/modules/forum/mappers/Forum.php on line 47

    Notice: Undefined index: read_access in /var/www/vhosts/dok-clan.de/httpdocs/application/modules/forum/mappers/Forum.php on line 45

    Notice: Undefined index: replay_access in /var/www/vhosts/dok-clan.de/httpdocs/application/modules/forum/mappers/Forum.php on line 46

    Notice: Undefined index: create_access in /var/www/vhosts/dok-clan.de/httpdocs/application/modules/forum/mappers/Forum.php on line 47
    An unexpected error occurred:

    MySQL Error: Unknown column 'topic_id' in 'field list'
    in Query: SELECT COUNT(topic_id) FROM `DoK_forum_topics` WHERE `topic_id` = "2"

    Ich werde mal versuchen, die Backup Dati über die Datenbanl einzuspielen. grumml
    Hoffe ich bekomme es so repariert
    Danke schonmal im Voraus für Eure Bemühungen


    verwendete ilch Version: 2.1.x

    betroffene Homepage: dok-clan.de


    Zuletzt modifiziert von Shorty2710 am 10.11.2023 - 13:53:49
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    Shorty2710 Mitglied
    Registriert seit
    25.03.2019
    Beitrge
    12
    Beitragswertungen
    0 Beitragspunkte
    KLeines Feedback.

    Hatte das Backup eingespielt, und alles war wieder wie vor dem Update.
    Also habe ich Interessehalber nochmals versucht, über Module, das Forum zu aktualisieren, und promt war der Fehler wieder da....

    Könnt Ihr mir da weiter helfen?
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    Slipi ilch.de Design
    Registriert seit
    19.01.2018
    Beitrge
    927
    Beitragswertungen
    115 Beitragspunkte
    Hallo

    Ich kann dir leider nicht helfen, da ich nur vermuttungen habe und möchte daher schlimmeres vermeiden, jedoch denke ich das ein Entwickler sich melden wird.

    Slipi
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    BlackRomeo Moderator
    Registriert seit
    31.01.2014
    Beitrge
    266
    Beitragswertungen
    27 Beitragspunkte
    ZitatZitat geschrieben von Shorty2710
    KLeines Feedback.

    Hatte das Backup eingespielt, und alles war wieder wie vor dem Update.
    Also habe ich Interessehalber nochmals versucht, über Module, das Forum zu aktualisieren, und promt war der Fehler wieder da....

    Könnt Ihr mir da weiter helfen?


    Konnte den Fehler Local nicht Nachvollziehen.
    Game-Haven Community | SchlueppaTv Twitch Streamer |
    www.game-haven.de | www.schlueppatv.de

    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    392
    Beitragswertungen
    61 Beitragspunkte
    Konnte den Fehler bis jetzt noch nicht nachstellen, habe aber feststellen können, dass diese Zeilen von der Forum Version 1.33.0 kommen.
    ist das Richtig dass du von der Version auf die 1.34.3 updaten wolltest?
    Gibt er nach dem Update Fehler aus? (evt. auch mal nach oben scrollen)
    Schreibrechte mal auf dem Server kontrolliert?
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    Shorty2710 Mitglied
    Registriert seit
    25.03.2019
    Beitrge
    12
    Beitragswertungen
    0 Beitragspunkte
    Momentan habe ich die Forum Version 1.31.0.


    Name:Forum
    Version:1.34.3
    Autor:Stantin, Thomas
    Aufrufe:6
    Downloads:12
    Bewertung:

    Anforderungen:
    Ilch-Kern Version:
    2.1.53
    PHP Version:
    7.3

    Auf diese Version wollte ich updaten. Spielt die PHP Version dabei eine Rolle? Ich habe momentan die 8.2.12 aktiv.
    Beim Installieren selber erhalte ich keine Fehlerangaben.

    Auf den ersten Blick sieht dann auf der HP alles ok aus....aber wenn man dann ins Forum geht, erscheint die oben angegebene Fehlermeldung.

    Schreibrechte sind vorhanden.

    Habe die HP daher jetzt erstmals wieder per Backup in den Urzustand gesetzt.


    Zuletzt modifiziert von Shorty2710 am 11.11.2023 - 13:31:13
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    BlackRomeo Moderator
    Registriert seit
    31.01.2014
    Beitrge
    266
    Beitragswertungen
    27 Beitragspunkte
    ZitatZitat geschrieben von Shorty2710
    Momentan habe ich die Forum Version 1.31.0.


    Name:Forum
    Version:1.34.3
    Autor:Stantin, Thomas
    Aufrufe:6
    Downloads:12
    Bewertung:

    Anforderungen:
    Ilch-Kern Version:
    2.1.53
    PHP Version:
    7.3

    Auf diese Version wollte ich updaten. Spielt die PHP Version dabei eine Rolle? Ich habe momentan die 8.2.12 aktiv.
    Beim Installieren selber erhalte ich keine Fehlerangaben.

    Auf den ersten Blick sieht dann auf der HP alles ok aus....aber wenn man dann ins Forum geht, erscheint die oben angegebene Fehlermeldung.

    Schreibrechte sind vorhanden.

    Habe die HP daher jetzt erstmals wieder per Backup in den Urzustand gesetzt.


    Zuletzt modifiziert von Shorty2710 am 11.11.2023 - 13:31:13


    Bitte einmal umstellen auf 8.1 und nochmal Testen.
    Sollte dann Funktionieren in der Regel.
    Game-Haven Community | SchlueppaTv Twitch Streamer |
    www.game-haven.de | www.schlueppatv.de

    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    Shorty2710 Mitglied
    Registriert seit
    25.03.2019
    Beitrge
    12
    Beitragswertungen
    0 Beitragspunkte
    Ich habe die PHP zurück gestellt. Hat leider nichts gebracht.
    Es kam wieder das gleich Phänomen wie zu Beginn des Themas.

    Mir ist auch aufgefallen, das, wenn ich auf aktualisieren gehe, bei allen die Download/Update "Wolke" verschwunden ist nach dem aktualkisieren, aber beim Forum kann ich so oft auf die Cloud drücken wie ich möchte, sie aktualisiert zwar die HP (fehlerhaft), aber unter Modulen verschwindet das Aktualisierungslogo nicht.
    0 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    BlackRomeo Moderator
    Registriert seit
    31.01.2014
    Beitrge
    266
    Beitragswertungen
    27 Beitragspunkte
    Notice: Undefined index: read_access in /var/www/vhosts/dok-clan.de/httpdocs/application/modules/forum/mappers/Forum.php on line 45
    
    Notice: Undefined index: replay_access in /var/www/vhosts/dok-clan.de/httpdocs/application/modules/forum/mappers/Forum.php on line 46
    
    Notice: Undefined index: create_access in /var/www/vhosts/dok-clan.de/httpdocs/application/modules/forum/mappers/Forum.php on line 47
    
    Notice: Undefined index: read_access in /var/www/vhosts/dok-clan.de/httpdocs/application/modules/forum/mappers/Forum.php on line 45
    
    Notice: Undefined index: replay_access in /var/www/vhosts/dok-clan.de/httpdocs/application/modules/forum/mappers/Forum.php on line 46
    
    Notice: Undefined index: create_access in /var/www/vhosts/dok-clan.de/httpdocs/application/modules/forum/mappers/Forum.php on line 47
    An unexpected error occurred:



    Ok habe mir das von dir jetzt nochmal durchgelesen.

    Schaue mal bitte Admincenter>Fragezeichen Tropdown>Information>Ordnerrechte>Rechte aller Dateien prüfen Drücken und schauen ob da alles in Ordnung ist.


    Sollte so Aussehen.


    Zuletzt modifiziert von BlackRomeo am 12.11.2023 - 19:42:28
    Game-Haven Community | SchlueppaTv Twitch Streamer |
    www.game-haven.de | www.schlueppatv.de

    0 Mitglieder finden den Beitrag gut.
  10. #10
    User Pic
    Shorty2710 Mitglied
    Registriert seit
    25.03.2019
    Beitrge
    12
    Beitragswertungen
    0 Beitragspunkte
    Ordner Rechte
    Ordner Erforderlich Vorhanden
    "/" Beschreibbar Beschreibbar
    "/.htaccess" Beschreibbar Beschreibbar
    "/updates/" Beschreibbar Beschreibbar
    "/certificate/" Beschreibbar Beschreibbar
    "/backups/" Beschreibbar Beschreibbar
    "/application/" Beschreibbar Beschreibbar
    "/application/modules/media/static/upload/" Beschreibbar Beschreibbar
    "/application/modules/user/static/upload/avatar/" Beschreibbar Beschreibbar
    "/application/modules/user/static/upload/gallery/" Beschreibbar Beschreibbar
    "/application/modules/teams/static/upload/image/" Beschreibbar nicht beschreibbar
    "/application/modules/events/static/upload/image/" Beschreibbar Beschreibbar

    Das Prüfen der Rechte aller Dateien nimmt mehrere Sekunden in Anspruch.
    Rechte aller Dateien prüfen

    der vorletzte Punkt ist bei mir Rot

    wenn ich dann nochmals rechte aller dateien prüfen sage, ist alles grün und beschreibbar
    ./application/modules/forum/ gamed-1xxxxx0 psacln 755 Beschreibbar


    Zuletzt modifiziert von Shorty2710 am 17.11.2023 - 17:26:43
    0 Mitglieder finden den Beitrag gut.
  11. #11
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    392
    Beitragswertungen
    61 Beitragspunkte
    Ok, also ich hatte gerade bei mir nochmal versucht, von deiner Version (1.31.0) aus das Update einzuspielen.
    Lief bei mir Problemlos durch.

    Welche Core Version benutzt du?
    Hast du bei anderen Modulen auch Probleme mit Updates?
    Wurde das Forum von dir mal geändert (In der Datenbank)?
    0 Mitglieder finden den Beitrag gut.
  12. #12
    User Pic
    Shorty2710 Mitglied
    Registriert seit
    25.03.2019
    Beitrge
    12
    Beitragswertungen
    0 Beitragspunkte
    Bei den anderen Modulen hatte ich keine Probleme.
    Die habe ich ohne Weiteres aktualisieren können. Nur das Forum macht irgendwie Mucken.

    Also ehrlich gesagt habe ich nicht also viel Ahnung von Datenbank und so, daher kann ich definitiv sagen, das ich am Forum in der Datenbank nichts geändert habe.

    Blöde Frage, aber was bedeutet Core Verion und wo finde ich eine solche Information?

    Gab es nach der Forum Version 1.31.0 noch ein anderes Update vor der Version 1.34.3 ?
    Dann könnte ich vielleicht mal versuchen, diese einzuspielen.

    Vorab schonmal vielen Dank, für all Eure Mühen....
    0 Mitglieder finden den Beitrag gut.
  13. #13
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    2.217
    Beitragswertungen
    347 Beitragspunkte
    Ja, nach der Version 1.31.0 gab es noch sechs neuere Versionen (1.32.0, 1.33.0, 1.34.0, 1.34.1, 1.34.2 und 1.34.3).

    Rein von den Fehlermeldungen oben würde ich vermuten, dass die Dateien nicht aktualisiert werden konnten.

    Du könntest folgendes versuchen:

    1. Sicherheitskopien von application\modules\forum und der Datenbank anlegen.
    2. www.ilch.de/ilch2_updates/stable/modules/forum-v1.34.3.zip herunterladen.
    3. application\modules\forum aus der Zip-Datei auf deinem Server hochladen und vorhandene Dateien ersetzen.
    4. Im Admincenter die neue Version vom Forum aus lokaler Quelle aktualisieren.

    Du hast dann Version 1.34.3 installiert. Jetzt müsstest du herausbekommen wieso die Update-Funktion die Dateien nicht aktualisieren kann, damit du in Zukunft Updates normal aus dem Admincenter heraus installieren kannst.

    Es kann z.B. sein, dass die Ordner und Dateien, die du manuell hochlädst jetzt den Eigentümer "gamed-1xxxxx0" haben, aber Ilch selber (bzw. der Webserver/PHP) unter einem Benutzer läuft, der die Dateien dann nicht überschreiben kann. Steht denn bei allen Ordnern/Dateien der Eigentümer "gamed-1xxxxx0" und die Gruppe "psacln" oder wechselt das?

    Gruß
    blackcoder


    Zuletzt modifiziert von blackcoder am 19.11.2023 - 07:39:40
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Installation und Upgrades

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten