ilch Forum » Allgemein » HTML, PHP, SQL,... » profile.php Fehler

Geschlossen
  1. #1
    User Pic
    Hans1985 Mitglied
    Registriert seit
    28.08.2021
    Beitrge
    10
    Beitragswertungen
    0 Beitragspunkte
    Guten Tag,

    ich habe folgendes Problem. Bei Profil Panel bekomme ich folgenden Fehler angezeigt
    Ich hoffe mir kann geholfen werden. Ilch Version ist die 2.1.5



    Deprecated: Unparenthesized `a ? b : c ? d : e` is deprecated. Use either `(a ? b : c) ? d : e` or `a ? b : (c ? d : e)` in /srv/www/htdocs/application/modules/user/views/panel/profile.php on line 63

    Deprecated: Unparenthesized `a ? b : c ? d : e` is deprecated. Use either `(a ? b : c) ? d : e` or `a ? b : (c ? d : e)` in /srv/www/htdocs/application/modules/user/views/panel/profile.php on line 64


    verwendete ilch Version: 2.1.x

    betroffene Homepage: www.meinkleinergartenhalle.de
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    blackcoder Hall Of Fame
    Registriert seit
    22.05.2014
    Beitrge
    1.917
    Beitragswertungen
    303 Beitragspunkte
    Sie scheinen Ilch 2.1.15 und nicht 2.1.5 installiert zu haben. Das ändert aber natürlich nichts daran, dass die Version sehr alt ist (2.1.15 wurde im Oktober 2018 veröffentlicht).

    Die Fehler wurden mit Ilch 2.1.29 behoben (aktuell ist 2.1.43). Gibt es Probleme mit der Update-Funktion?


    Zuletzt modifiziert von blackcoder am 28.08.2021 - 13:31:45
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    Hans1985 Mitglied
    Registriert seit
    28.08.2021
    Beitrge
    10
    Beitragswertungen
    0 Beitragspunkte
    Ja, leider kann ich auch keine Updates mehr machen, da mir immer nur die Version als 2.1.1.5 aktuelle angezeigt wird. Danke für schnelle Antwort.
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    Hans1985 Mitglied
    Registriert seit
    28.08.2021
    Beitrge
    10
    Beitragswertungen
    0 Beitragspunkte
    Um zu Ihrem gewünschten Ziel zu kommen, benutzen Sie entweder die Navigation oben oder die umfangreiche Suche auf der rechten oberen Seite.


    System aktuell
    Version
    Installierte Version 2.1.15
    Server Version 2.1.15
    ilch Neuigkeiten
    Datum Titel
    30.07.2021 Version 2.1.43
    10.02.2021 Version 2.1.42 ACHTUNG WICHTIG
    01.11.2020 Version 2.1.41
    18.09.2020 Version 2.1.40
    05.09.2020 Version 2.1.39
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    blackcoder Hall Of Fame
    Registriert seit
    22.05.2014
    Beitrge
    1.917
    Beitragswertungen
    303 Beitragspunkte
    Wird denn eine Fehlermeldung auf der Admincenter Startseite angezeigt?

    Bitte einmal prüfen ob der Updateserver von Corian ausgewählt ist:
    github.com/IlchCMS/Ilch-2.0/wiki/Doku-Benutzer-Update-Server

    Den zweiten Updateserver gibt es nicht mehr.
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    Hans1985 Mitglied
    Registriert seit
    28.08.2021
    Beitrge
    10
    Beitragswertungen
    0 Beitragspunkte
    Nein er zeigt keine Fehler an. Er zeigt halt an das ich auf dem neusten Stand bin und meine Version aktuell ist. Uptate Server ist nicht der richtige.


    Zuletzt modifiziert von Hans1985 am 28.08.2021 - 14:06:06
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    Hans1985 Mitglied
    Registriert seit
    28.08.2021
    Beitrge
    10
    Beitragswertungen
    0 Beitragspunkte
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    Hans1985 Mitglied
    Registriert seit
    28.08.2021
    Beitrge
    10
    Beitragswertungen
    0 Beitragspunkte
    Ich kann keine weiteren Server nehmen da kein anderer angezeigt wird.
    0 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    blackcoder Hall Of Fame
    Registriert seit
    22.05.2014
    Beitrge
    1.917
    Beitragswertungen
    303 Beitragspunkte
    Ja, ilch2.de/development/updateserver/stable wäre der richtige Server. Der mit blackcoder.de steht nicht mehr zur Verfügung.

    Haben Sie Zugriff auf die Dateien auf dem Server/Webspace?

    Es wäre einen Versuch Wert einmal den Inhalt vom "cache"-Ordner zu löschen und zwei Dateien im "certificate"-Ordner zu aktualisieren.

    Die aktuellen Dateien können Sie aus der aktuellen Version kopieren.

    1. Sicherheitskopie der cacert.pem und Certificate.crt erstellen.
    2. github.com/IlchCMS/Ilch-2.0/releases/download/v2.1.43/Ilch-v2.1.43.zip herunterladen
    3. Die cacert.pem und Certificate.crt aus dem Archiv (sind im certificate-Ordner) in den certificate-Ordner hochladen und die alten Dateien überschreiben.
    4. Den Inhalt des cache-Ordners auf den Server löschen.

    Wird jetzt eine neuere Version auf der Admincenter Startseite angezeigt? Wenn ja zuerst ein Backup aller Dateien und der Datenbank erstellen (ein Backup der Datenbank kann im Admincenter erstellt werden, Admincenter -> Einstellungen -> Backup), bevor ein Update versucht wird. Beim Update installieren bisschen Geduld haben - also einmal auf "Jetzt installieren" klicken und dann warten bis eine Erfolgsmeldung ausgegeben wird.
    0 Mitglieder finden den Beitrag gut.
  10. #10
    User Pic
    Hans1985 Mitglied
    Registriert seit
    28.08.2021
    Beitrge
    10
    Beitragswertungen
    0 Beitragspunkte
    Ja habe einen Rootserver wo ich vollen Rootzugang habe auch zu php-my-admin. Wo find ich die Cashordner wenn ich fragen darf ?
    0 Mitglieder finden den Beitrag gut.
  11. #11
    User Pic
    blackcoder Hall Of Fame
    Registriert seit
    22.05.2014
    Beitrge
    1.917
    Beitragswertungen
    303 Beitragspunkte
    Das kommt auf Ihren Server an. Der "cache"-Ordner, sowie der "certificate"-Ordner sind im Rootverzeichnis der Ilch-Installation.
    0 Mitglieder finden den Beitrag gut.
  12. #12
    User Pic
    Hans1985 Mitglied
    Registriert seit
    28.08.2021
    Beitrge
    10
    Beitragswertungen
    0 Beitragspunkte
    Ok dankeschön erst mal, werde mich bei Erfolg melden und schreiben was rausgekommen ist.
    0 Mitglieder finden den Beitrag gut.
  13. #13
    User Pic
    Hans1985 Mitglied
    Registriert seit
    28.08.2021
    Beitrge
    10
    Beitragswertungen
    0 Beitragspunkte
    Den Zertifikat Ordner habe ich gefunden nur wo befindet sich der cach Ordner bei ilch das meinte ich eigentlich.
    0 Mitglieder finden den Beitrag gut.
  14. #14
    User Pic
    Hans1985 Mitglied
    Registriert seit
    28.08.2021
    Beitrge
    10
    Beitragswertungen
    0 Beitragspunkte
    Habe ihn gefunden aber es hat keine änderung gegeben.
    0 Mitglieder finden den Beitrag gut.
  15. #15
    User Pic
    blackcoder Hall Of Fame
    Registriert seit
    22.05.2014
    Beitrge
    1.917
    Beitragswertungen
    303 Beitragspunkte
    Wird bei Ihnen auch dieser "Fingerabdruck" angezeigt? Das Zertifikat sollte bis 03.04.2023 gültig sein.
    Wenn der Fingerabdruck stimmt, haben Sie das richtige Zertifikat. Das hätte dann geklappt.

    Fingerabdruck (SHA-1): ad1a52da3d129eb74c21ae42c17499f209373a9f
    www.meinkleinergartenhalle.de/index.php/admin/admin/infos/certificate

    Ich gehe mal davon aus, dass hier auch kein Update angezeigt wird, aber man kann ja mal gucken:
    www.meinkleinergartenhalle.de/index.php/admin/admin/settings/update

    Wenn Sie diese beiden Dateien vom Server herunterladen und mit einem Texteditor öffnen. Steht dort updates.php oder updates2.php? Dies soll ausschließen, dass Ilch in der falschen Datei nach Updates guckt.

    application/modules/admin/controllers/admin/Index.php
    github.com/IlchCMS/Ilch-2.0/blob/v2.1.16/application/modules/admin/controllers/admin/Index.php#L42

    application/modules/admin/controllers/admin/Settings.php
    github.com/IlchCMS/Ilch-2.0/blob/v2.1.16/application/modules/admin/controllers/admin/Settings.php#L281
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu HTML, PHP, SQL,...

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten