ilch Forum » Ilch CMS 2.X » Fehlersuche und Probleme » Update von 2.1.42 auf 2.1.43 geht nicht

Geschlossen
  1. #1
    User Pic
    xSteveUrkelx Mitglied
    Registriert seit
    06.06.2018
    Beitrge
    45
    Beitragswertungen
    1 Beitragspunkte
    Ich wollte gerade das Update von Version 2.1.42 auf 2.1.43 durchführen. Dies ist allerdings nicht möglich. Im Anhang habe ich die Fehler Codes die Ausgegeben werden mal in ein Textdokument gepackt.

    Ich habe zuvor alle Module soweit es ging geupdatet. Bis auf Downloads und Forum nicht, da man dafür 2.1.43 benötigt zwinker

    Datei von filehorst.de laden

    verwendete ilch Version: 2.1.x

    betroffene Homepage: chillgamerz.net


    Zuletzt modifiziert von xSteveUrkelx am 09.09.2021 - 10:34:45
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    blackcoder Hall Of Fame
    Registriert seit
    22.05.2014
    Beitrge
    1.917
    Beitragswertungen
    303 Beitragspunkte
    Hast du mal geguckt ob nicht vielleicht 2.1.43 installiert wurde?

    Das sind nur "deprecated"-Meldungen mit PHP 8, die du je nach Konfiguration von PHP nicht einmal sehen würdest.
    Ist im aktuellen Entwicklungsstand schon behoben. [1]

    [1] github.com/IlchCMS/Ilch-2.0/pull/539


    Zuletzt modifiziert von blackcoder am 27.08.2021 - 16:32:18
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    xSteveUrkelx Mitglied
    Registriert seit
    06.06.2018
    Beitrge
    45
    Beitragswertungen
    1 Beitragspunkte
    Ja es wurde nicht installiert. Sonst würde ich mich ja nicht melden.
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    blackcoder Hall Of Fame
    Registriert seit
    22.05.2014
    Beitrge
    1.917
    Beitragswertungen
    303 Beitragspunkte
    In deiner Textdatei sehe ich nicht wieso das Update fehlgeschlagen sein könnte.

    Du könntest error_reporting (eventuell nur vorübergehend) wie folgt ändern und die Installation noch einmal versuchen. Siehe hier:
    www.php.net/manual/de/errorfunc.configuration.php#ini.error-reporting

    error_reporting=E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED


    Wenn das jetzt wegen Änderungen an der Datenbank fehlschlägt und du kein Backup hast, müsste man die Dateien manuell hochladen und Anpassungen an der Datenbank vornehmen.


    Zuletzt modifiziert von blackcoder am 27.08.2021 - 17:04:59
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    xSteveUrkelx Mitglied
    Registriert seit
    06.06.2018
    Beitrge
    45
    Beitragswertungen
    1 Beitragspunkte
    Gibt es keinen Fix für mein Problem ? Oder kann ich bis zum nächsten Update warten und dann direkt auf 2.1.44 updaten ?
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    blackcoder Hall Of Fame
    Registriert seit
    22.05.2014
    Beitrge
    1.917
    Beitragswertungen
    303 Beitragspunkte
    Es kamen von dir auch keine weiteren Informationen.

    Nein, direkt auf 2.1.44 aktualisieren geht nicht. Die Updates bauen aufeinander auf.
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    xSteveUrkelx Mitglied
    Registriert seit
    06.06.2018
    Beitrge
    45
    Beitragswertungen
    1 Beitragspunkte
    Ja weil ich keinerlei Ahnung davon habe.
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    xSteveUrkelx Mitglied
    Registriert seit
    06.06.2018
    Beitrge
    45
    Beitragswertungen
    1 Beitragspunkte
    Kann ich das Update denn irgendwie machen ?
    0 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    M.vittel Mitglied
    Registriert seit
    16.11.2018
    Beitrge
    246
    Beitragswertungen
    13 Beitragspunkte
    Fange doch erstmal an zu beschreiben welcher Fehler auftaucht...
    Welche Version ist installiert?
    Welche Version hat die SQL-Datenbank:
    Kopiere den Fehler mal hier hinein welchen du bekommst beim Updaten.
    RealLife ... das ist doch das Game mit der geilen Grafik und der scheiss Story
    0 Mitglieder finden den Beitrag gut.
  10. #10
    User Pic
    xSteveUrkelx Mitglied
    Registriert seit
    06.06.2018
    Beitrge
    45
    Beitragswertungen
    1 Beitragspunkte
    Ich wollte gerade das Update von Version 2.1.42 auf 2.1.43 durchführen. Dies ist allerdings nicht möglich. Im Anhang habe ich die Fehler Codes die Ausgegeben werden mal in ein Textdokument gepackt.

    Ich habe zuvor alle Module soweit es ging geupdatet. Bis auf Downloads und Forum nicht, da man dafür 2.1.43 benötigt zwinker

    Datei von filehorst.de laden

    verwendete ilch Version: 2.1.x

    betroffene Homepage: chillgamerz.net
    0 Mitglieder finden den Beitrag gut.
  11. #11
    User Pic
    BlackRomeo Moderator
    Registriert seit
    31.01.2014
    Beitrge
    141
    Beitragswertungen
    10 Beitragspunkte
    ZitatZitat geschrieben von xSteveUrkelx
    Ich wollte gerade das Update von Version 2.1.42 auf 2.1.43 durchführen. Dies ist allerdings nicht möglich. Im Anhang habe ich die Fehler Codes die Ausgegeben werden mal in ein Textdokument gepackt.

    Ich habe zuvor alle Module soweit es ging geupdatet. Bis auf Downloads und Forum nicht, da man dafür 2.1.43 benötigt zwinker

    Datei von filehorst.de laden

    verwendete ilch Version: 2.1.x

    betroffene Homepage: chillgamerz.net



    Schick mir mal Privat Zugangsdaten Mit Admin Rechten ich schaue mir das mal an .
    Frag nicht  Du knntest eine Antwort erhalten

    0 Mitglieder finden den Beitrag gut.
  12. #12
    User Pic
    BlackRomeo Moderator
    Registriert seit
    31.01.2014
    Beitrge
    141
    Beitragswertungen
    10 Beitragspunkte
    Problem ist Behoben.

    Lag an der PHP Version er Hatte die Version 8.0

    Erforderlich ist die Php7.x.x
    Frag nicht  Du knntest eine Antwort erhalten

    2 Mitglieder finden den Beitrag gut.
  13. #13
    User Pic
    xSteveUrkelx Mitglied
    Registriert seit
    06.06.2018
    Beitrge
    45
    Beitragswertungen
    1 Beitragspunkte
    Danke dir BlackRomeo. Super freundlich und super hilfe.
    1 Mitglieder finden den Beitrag gut.
  14. #14
    User Pic
    MonkeyOnKeyboard Moderator
    Registriert seit
    10.02.2014
    Beitrge
    395
    Beitragswertungen
    16 Beitragspunkte
    Moin, ja zip_error ist leider so ein Thema bei PHP 8.0
    sorry habs gerade erst alles gelesen.
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Fehlersuche und Probleme

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten