ilch Forum » Ilch CMS 2.X » Installation und Upgrades » Update Fehler SOCIALBAR ?

Geschlossen
  1. #1
    User Pic
    xRebellx Mitglied
    Registriert seit
    07.08.2012
    Beitrge
    318
    Beitragswertungen
    11 Beitragspunkte
    Nabend,

    Habe gerade die SOCIALBAR Aktualisiert und nun werden überall dobelte Icons angezeigt,
    habe dann zum Beispiel Discord noch mal neu eingefügt aber werden auch 2 icons angezeigt , wie kann ich das beheben ?


    verwendete ilch Version: 2.1.x

    betroffene Homepage: freiezocker.de/

    Habe das Modul auf meiner Testseite auch gerade aktualisiert und dort der selbe Fehler.


    Zuletzt modifiziert von xRebellx am 04.02.2020 - 23:02:23
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    Nex4T Hall Of Fame
    Registriert seit
    28.02.2007
    Beitrge
    3.215
    Beitragswertungen
    177 Beitragspunkte
    application/modules/socialbar/boxes/views/socialbar.php

    ändern in

    <link href="<?=$this->getBoxUrl('static/css/socialbar.css') ?>" rel="stylesheet">
    <?php
    $socials = $this->get('socials');
    ?>
    
    <?php if (!empty($socials)): ?>
      <div id="social">
        <ul class="list-unstyled">
            <?php foreach ($socials as $social): ?>
                <li>
                  <a href="<?=$this->escape($social->getLink()) ?>" target="_blank" rel="noopener"><?=$this->escape($social->getText()) ?>
            		     <div class="btn-social-icon"><i class="<?=$this->escape($social->getIcon()) ?>"></i></div>
                  </a>
                </li>
            <?php endforeach; ?>
        </ul>
      </div>
    <?php else: ?>
        <?=$this->getTrans('noSocial') ?>
    <?php endif; ?>
    while(!asleep()) sheep++;
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    xRebellx Mitglied
    Registriert seit
    07.08.2012
    Beitrge
    318
    Beitragswertungen
    11 Beitragspunkte
    @Nex4T Perfekt es wird wieder Normal angezeigt besten dank für die Schnelle Hilfe , Super Team hier .
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    Hansa Mitglied
    Registriert seit
    07.05.2010
    Beitrge
    58
    Beitragswertungen
    2 Beitragspunkte
    komisch, bei mir funktioniert es nicht...

    www.codev3.de
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    Slipi ilch.de Design
    Registriert seit
    19.01.2018
    Beitrge
    555
    Beitragswertungen
    54 Beitragspunkte
    Hallo

    Leider hatte ich vergessen die bearbeitete ausgabe zu löschen (verzeiht mir), daher wurden 2 Icons ausgegeben.

    Ich habe das Modul aktualisiert und wird demnächst auf dem Update Server liegen.

    Slipi
    Grafiken | Layouts | OnePage
    www.sd-sdesign.at
    1 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Installation und Upgrades

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten