ilch Forum » Allgemein » HTML, PHP, SQL,... » Admin keine rechte mehr ?

Geschlossen
  1. #1
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    Hay Leute,

    Habe keine Rechte mehr als Admin es kommt folgender Fehler

    Forbidden
    You do not have permission to access this document.
    Web Server at acdcfunclan.de

    Server läuft auf Apache und wenn ich auf ngix stelle kann ich kein Avatar mehr laden.


    verwendete ilch Version: 1.1 P

    betroffene Homepage: acdcfunclan.de
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    Baujahr73 Mitglied
    Registriert seit
    05.09.2013
    Beitrge
    206
    Beitragswertungen
    22 Beitragspunkte
    Einloggen geht noch?

    Auf was ist bei dir unter Konfiguration "Zugriff auf nicht im Menü verlinkte Module für alle?" gestellt, auf ja oder auf nein?

    Diese Option muss auf Ja stehen!


    Zuletzt modifiziert von Baujahr73 am 16.08.2018 - 16:38:14
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    einloggen geht noch, bei ngix ging bis gestern noch alles
    ist auf ja gestellt
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    Baujahr73 Mitglied
    Registriert seit
    05.09.2013
    Beitrge
    206
    Beitragswertungen
    22 Beitragspunkte
    Mit ngix kenne ich mich leider nicht aus, würde Dir da gerne weiter helfen, aber da muss ich passen!
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    ich stelle den auf apache kannste da weiter helfen
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    ich hab ihn wieder auf ngix gestellt sonst hab ich gar kein zugriff mehr
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    Baujahr73 Mitglied
    Registriert seit
    05.09.2013
    Beitrge
    206
    Beitragswertungen
    22 Beitragspunkte
    Hast Du denn etwas an deiner Seite geändert das Plötzlich dieser Fehler auftritt?
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    1.028
    Beitragswertungen
    151 Beitragspunkte
    Überprüfe mal die Datei- und Ordnerrechte.
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    0 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    Ne ausser von Apache mal auf ngix gestellt aber der Fehler ich habe keine rechte muß ja zu lösen sein .


    Hoffe hier kann noch jemand helfen.
    0 Mitglieder finden den Beitrag gut.
  10. #10
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    Da habe ich das stehen

    Dateisystem Rechte
    include/backup Richtig
    include/contents/selfbp/selfb Richtig
    include/contents/selfbp/selfp Richtig
    include/downs/downloads Richtig
    include/downs/downloads/user_upload Richtig
    include/images/avatars Richtig
    include/images/gallery Richtig
    include/images/smiles Richtig
    include/images/usergallery Richtig
    include/images/wars Richtig
    0 Mitglieder finden den Beitrag gut.
  11. #11
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    Und die Ordner haben alle 755 mit ftp geschaut
    0 Mitglieder finden den Beitrag gut.
  12. #12
    User Pic
    Slipi Mitglied
    Registriert seit
    19.01.2018
    Beitrge
    214
    Beitragswertungen
    16 Beitragspunkte
    Hast du in der Datenbank unter _users ein Backup importiert ?

    Denn fehler hatte ich heute früh gemacht.


    Zuletzt modifiziert von Slipi am 16.08.2018 - 17:43:05
    Grafik | Layouts | OnePage S-Design
    0 Mitglieder finden den Beitrag gut.
  13. #13
    User Pic
    Baujahr73 Mitglied
    Registriert seit
    05.09.2013
    Beitrge
    206
    Beitragswertungen
    22 Beitragspunkte
    Legt nginx denn keine .log an, vielleicht steht da was drin?!
    0 Mitglieder finden den Beitrag gut.
  14. #14
    User Pic
    Baujahr73 Mitglied
    Registriert seit
    05.09.2013
    Beitrge
    206
    Beitragswertungen
    22 Beitragspunkte
    @Slipi

    application/config.php

    <?php
    $config = [
        "dbEngine" => "Mysql",
        "dbHost" => "localhost",
        "dbUser" => "username",
        "dbPassword" => "passwort",
        "dbName" => "Datenbankname",
        "dbPrefix" => "Tabellen Prefix"
    ];
    0 Mitglieder finden den Beitrag gut.
  15. #15
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    ein Backup importiert ? Hatte ich Importiert aber da ging hier noch alles der Fehler kam einfach so ??
    0 Mitglieder finden den Beitrag gut.
  16. #16
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    <?php
    define ( 'DBHOST', 'localhost' ); # sql host
    define ( 'DBUSER', 'kdxxxx'); # sql user
    define ( 'DBPASS', '@xxxxx); # sql pass
    define ( 'DBDATE', 'kdxxxxx_acdcfun'); # sql datenbank
    define ( 'DBPREF', 'ic1_'); # sql prefix
    ?>
    0 Mitglieder finden den Beitrag gut.
  17. #17
    User Pic
    Baujahr73 Mitglied
    Registriert seit
    05.09.2013
    Beitrge
    206
    Beitragswertungen
    22 Beitragspunkte
    leberwurst, versuche mal per ssh

    sudo nginx -t

    das sollte Dir die Fehler auflisten wenn nginx welche hat
    0 Mitglieder finden den Beitrag gut.
  18. #18
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    habe nachtschich melde mich moijen nochmal danke erstmal
    0 Mitglieder finden den Beitrag gut.
  19. #19
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    so den fehler konnte ich bis jetzt nicht finden und beheben
    hat noch jemand eine idee
    bei alphahosting funktioniert die alte homepage total fehlerfrei
    obwohl alles mit rüber zu gamerzhost genommen haben geht das mit den avatar setzen nicht
    egal ob ich das angegebene format nehme oder nicht gif geht auch nicht
    0 Mitglieder finden den Beitrag gut.
  20. #20
    User Pic
    Baujahr73 Mitglied
    Registriert seit
    05.09.2013
    Beitrge
    206
    Beitragswertungen
    22 Beitragspunkte
    Guten Morgen,

    welche .php Version läuft denn bei dir?

    Und bitte mal überprüfen welche Dateirechte dein html Ordner hat, der muss chmod 750 haben!

    Überprüfe die Rechte derjenigen Ordner in die Du über Domain automatisch weiterleitest. Diese sollten die Rechte 755 haben. Damit sind die Ordner nach html in deiner Ordner Struktur gemeint, wenn du im html Ordner noch einen Ordner hast in dem dein Ilch liegt, muss dieser chmod 755 haben.

    Wenn das nichts bringt, dann fehlt dir irgendwo ne Datei, index.php oder index.html

    Anders kann ich mir das nicht erklären!

    Zuletzt modifiziert von Baujahr73 am 17.08.2018 - 09:55:33
    0 Mitglieder finden den Beitrag gut.
  21. #21
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    also ich habe mich jetzt mal neu regestriert mit apache kann in mein profiel als neuer member ein bild laden geh ich als admin mit meinen account rein zeigt er mir ich hab keine rechte sehr kurios
    0 Mitglieder finden den Beitrag gut.
  22. #22
    User Pic
    Baujahr73 Mitglied
    Registriert seit
    05.09.2013
    Beitrge
    206
    Beitragswertungen
    22 Beitragspunkte
    Könntest eventuell noch in deiner Datenbank unter ic1_user gucken ob da das Recht -9 bei dir vorhanden ist.

    Aber der Fehler spricht dafür dass deine Dateiberechtigungen irgendwo nicht stimmen (Serverseitig), oder etwas fehlt.
    0 Mitglieder finden den Beitrag gut.
  23. #23
    User Pic
    Slipi Mitglied
    Registriert seit
    19.01.2018
    Beitrge
    214
    Beitragswertungen
    16 Beitragspunkte
    Bei mir war der Fehler in der Datenbank.
    Meine ilch_groups war leer.
    In ilch_groups werden die Gruppen angegeben die jeder Member hat zb. User , Admin, trial-member usw.
    Grafik | Layouts | OnePage S-Design
    0 Mitglieder finden den Beitrag gut.
  24. #24
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    Hallo Slipi,

    Ja da scheint was nicht zu stimmen , da ich Anfänger bin wäre es echt klasse wenn Du mal Zeit hast im Ts3

    Bin erreichbar bei www.acdcfunclan.de/index.php?news

    0 Mitglieder finden den Beitrag gut.
  25. #25
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    So sieht es noch aus

    0 Mitglieder finden den Beitrag gut.
  26. #26
    User Pic
    Baujahr73 Mitglied
    Registriert seit
    05.09.2013
    Beitrge
    206
    Beitragswertungen
    22 Beitragspunkte
    Ich würde erst mal in ic1_user gucken, da bei deinen Namen auf Bearbeiten klicken und Prüfen ob bei recht ganz auf der rechten Seite -9 steht!
    0 Mitglieder finden den Beitrag gut.
  27. #27
    User Pic
    xRebellx Mitglied
    Registriert seit
    07.08.2012
    Beitrge
    168
    Beitragswertungen
    0 Beitragspunkte
    ZitatZitat geschrieben von Baujahr73
    Ich würde erst mal in ic1_user gucken, da bei deinen Namen auf Bearbeiten klicken und Prüfen ob bei recht ganz auf der rechten Seite -9 steht!


    Ja das steht bei ihm auf -9 , habe bei ihm geschaut.

    Aber den Fehler finde ich auch nicht.
    Wer kämpft, kann verlieren. Wer nicht kämpft hat schon verloren .
    0 Mitglieder finden den Beitrag gut.
  28. #28
    User Pic
    Baujahr73 Mitglied
    Registriert seit
    05.09.2013
    Beitrge
    206
    Beitragswertungen
    22 Beitragspunkte
    ich guck mal eben bei mir

    kannst mal bitte in ic1_grundrechte gucken, was ist da bei ihm drin!?


    Zuletzt modifiziert von Baujahr73 am 17.08.2018 - 16:48:21
    0 Mitglieder finden den Beitrag gut.
  29. #29
    User Pic
    leberwurst Mitglied
    Registriert seit
    10.09.2014
    Beitrge
    22
    Beitragswertungen
    0 Beitragspunkte
    0 Mitglieder finden den Beitrag gut.
  30. #30
    User Pic
    Baujahr73 Mitglied
    Registriert seit
    05.09.2013
    Beitrge
    206
    Beitragswertungen
    22 Beitragspunkte
    Nichts anderes als bei mir!

    Sorry, aber kein Plan!
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu HTML, PHP, SQL,...

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten