•   Freitag 18 September 2009

Update N für ilchClan 1.1

Wie angekündigt gibt es nun ein und wohl auch das letzte Update für ilchClan 1.1 das auch Sicherheitslöcher stopft und deswegen natürlich von jedem Benutzer eingespielt werden sollte, wer Angst hat irgendwelche Module zu zerstören und auf andere Funktionen verzichten kann, der kann auch nur die includes/func/statistic.php hochladen.

Wie bei den letzten Updates auch, gebe ich den Hinweis auf folgenden FAQ Eintrag: Wie führe ich ein Update durch?

Hinweis für bplaced.net: www.ilch.de/forum-showposts-38690-p1.html
Ggf. auch von Leuten mit PHP 5.3 ein Statement in diesem Thema erwünscht, Danke.


Die Downloadlinks:
ilchClan 1.1n
Update N für ilchClan 1.1

Und die Changelog:
Version 1.1 N
-------------
* Sicherheitslücke in der include/includes/func/statistic.php behoben (Danke an www.securityplanet.de für den Hinweis)
und weiter einige Formulare im Adminbereich (Userverwaltung) gegen Cross-Site_Request_Forgery -> de.wikipedia.org/wiki/Cross-Site_Request_Forgery geschützt
* SMTP Funktion überarbeitet, damit eine breitere Auswahl an Anbietern genutzt werden kann
* Newsletter etwas überarbeitet, so dass auch Usergruppen gewählt werden können, und HTML Mails möglich sind
* Bei Downloads wird der eigentliche Pfad zur Datei nicht mehr übertragen, und leichter Leecherschutz
* Antispam geändert, so dass Fehler im Gästebuch etc. nicht mehr auftreten sollten
* Charset Encoding in der class/design.php hinzugefügt, um auftretende Fehler mit Umlauten beizukommen,
wer nach dem Update falsche Umlaute hat, sollte einfach die alte class/design.php (von Version M z.B.) nutzen
* Kleinere Fehler behoben bei:
Alterberechnung im Kalender
Löschen in der Shoutbox
Datum bei RSS der News
Gruppen im Adminbereich
* debug(), sendpm() und icmail() etwas verbessert (nur für Entwickler interessant)

« zurück

Kommentare (18)

Qlimax20xx

Also entweder liegt es daran, dass mein mein Ilch schon recht grob umgeschrieben habe, oder ich bin eifnach zu doof das Update einzubinden lachen
Naja, die meisten Fehler bzw Eigenschaften die mir nicht passten hab ich ohnehin schon umgeschrieben bzw neue Scripte eingebunden.
Von daher wohl nicht all zu schlimm lächeln

Oder haben noch mehr User Probleme mit dem neuen Newsletter?

Könnte sein, dass es bei mir nicht geht, weil ich dafür ohnehin schon ein anderes Script nutze.


Ahrta5

23 errors, soviel zu "alles ist valide hier"...


TheRipper

Was ist mit 2.0 :-)


TheRock

selbst ilch.de weißt 23 errors laut w3 validator auf


manuel

alles ist valide hier


Ahrta5

wird 1.2 valide sein?


Flomavali

Nein, nun kommt Ilch 1.2


Druide666

Soll das heisen, dass Ilch aufhört???


Flomavali

Das letzte Update für Ilch 1.1


Peerl

Top!!!weiter gehts nicht *heul* war das das letzte Update wirklich?? sauer


take2

sehr schön macht weiter so leute


sierra

super^^ thx


XxMaTzExX

ToooP danke


OloX

nicht vergessen auf zu spielen... der Sicherheit zu liebe zwinker Klasse Update lächeln


Chewbacca

Offtopic: @ Devil - Ich wollte es nicht sagen, du sprichst mir aus der Seele!
Sehr schönes Update übrigens! Klasse


Devil

Deutsch ?


Cyberwarrior

Module zu zerstören und auf andere Funktionen verzichten kann, welche andre funktionen und welche module?


Devil

Aha aha! :p Na dann mal rauf damit ^^


« zurück