Zum Download
ilch Version 2
  •   Mittwoch 1 Juli 2020

Support fr PHP 5.6 eingestellt

Als eine der letzten offiziell unterstützten Versionen von Linux-Distributionen mit PHP 5.6 hat Debian 8 am 30. Juni 2020 den Support eingestellt.
Mit dem Ende der Unterstützung für Debian 8 am 30. Juni 2020, unterstützt auch Ilch 2 kein PHP 5.6 mehr.
In der aktuell in Entwicklung befindlichen Version 2.1.37 wurden bereits Sprachfeatures genutzt, die es erst ab PHP 7.0 gibt und Code entfernt, der für die Kompatibilität mit PHP 5.6 notwendig ist.

PHP 5.6, 7.0 und sogar 7.1 werden schon offiziell nicht mehr von PHP gepflegt:


Quelle: www.php.net/supported-versions.php

Debian 9 mit PHP 7.0 wird noch bis Juni 2022 unterstützt.

Einer der Vorteile der neueren PHP Versionen ist die deutlich bessere Performance (Stand November 2019) und Sicherheitsverbesserungen:


Quelle: www.phoronix.com/scan.php?page=article&item=php-74-benchmarks

Wir empfehlen daher rechtzeitig auf neuere PHP-Versionen zu wechseln (idealerweise die neueste stabile Version).

« zurück

Kommentare (0)

Keine Kommentare vorhanden

« zurück