ilch Forum » Ilch CMS 2.X » Fehlersuche und Probleme » E mail senden und empfangen

Geschlossen
  1. #1
    User Pic
    Eddie Mitglied
    Registriert seit
    16.09.2017
    Beitrge
    47
    Beitragswertungen
    3 Beitragspunkte
    habe heute festgestellt das es kein versenden von Mails über die neue Ilch Version 2.1.43 gibt, bei mir läuft das freie SSL Zertifikat.

    Es zeigt mir zwar an Mail versendet aber die kommt beim Empfänger nicht an bzw. bei Personen die sich auf der Homepage neu registrieren.

    Bitte dieses mal zu überprüfen


    verwendete ilch Version: 2.1.x

    betroffene Homepage: the-golden-warriors.de/
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    blackcoder Hall Of Fame
    Registriert seit
    22.05.2014
    Beitrge
    1.917
    Beitragswertungen
    303 Beitragspunkte
    Und mit Ilch 2.1.42 und dem Zertifikat lief es noch? Die einzige Änderung mit 2.1.43 in der Hinsicht war, dass PHPMailer auf Version 6.5 aktualisiert wurde, weil Sicherheitslücken behoben wurden. [1]

    Von welchem freien Zertifikat ist die Rede? Das Let's Encrypt Zertifikat was auch im Webbrowser zu sehen ist?

    Wie ist der Mailversand denn konfiguriert? Verschickt dein Server die E-Mails oder reichst du diese weiter an einen anderen Mailserver (SMTP)?

    Bitte mal die Einstellungen in Ilch überprüfen.
    Passt der hier eingetragene Standard E-Mail Absender?
    the-golden-warriors.de/index.php/admin/admin/settings/index

    SMTP-Mode an oder aus?
    An: die E-Mails werden an einen anderen Mailserver zum Versand weitergereicht
    Aus: dein eigener Server übernimmt den Mailversand.
    the-golden-warriors.de/index.php/admin/admin/settings/mail

    Beispiele für klassische Fehler:
    Standard E-Mail Absender: webmaster@deine-domain.tld
    STMP-Mode eingeschaltet und E-Mail wird z.B. an web.de oder gmx.de zum Versand übergeben.
    Problem: Es ist sehr unwahrscheinlich das web.de oder gmx.de E-Mails im Namen von "deine-domain.tld" versendet.

    Standard E-Mail Absender: mustermann@web.de
    STMP-Mode ausgeschaltet.
    Problem: Es ist sehr unwahrscheinlich das dein Mailserver E-Mails im Namen von web.de oder gmx.de versenden darf.

    Wenn SMTP-Mode eingeschaltet ist, kannst du hier die Auskommentierung aufheben und dir die Debug-Meldungen ansehen [2]:
    github.com/IlchCMS/Ilch-2.0/blob/v2.1.43/application/libraries/Ilch/Mail.php#L391

    Ansonsten je nachdem was du für einen Server hast, die Protokolldateien und Konfiguration des Mailservers überprüfen. Das ist natürlich immer sinnvoll, wenn es Probleme mit dem Mailversand mit deinem Server gibt.
    Bei einem Server mit Debian oder einer auf Debian basierenden Distribution sind hier die Protokolldateien:
    /var/log/mail* [3]

    Dies könnte auch noch hilfreich sein:
    www.checktls.com/
    mxtoolbox.com/

    [1] github.com/PHPMailer/PHPMailer/releases
    [2] github.com/PHPMailer/PHPMailer/wiki/SMTP-Debugging
    [3] wiki.ubuntuusers.de/Logdateien/


    Zuletzt modifiziert von blackcoder am 19.09.2021 - 08:02:41
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Fehlersuche und Probleme

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten