ilch Forum » Ilch CMS 2.X » Fehlersuche und Probleme » Forum - Kann keine Beiträge erstellen

Geschlossen
  1. #1
    User Pic
    xSteveUrkelx Mitglied
    Registriert seit
    06.06.2018
    Beiträge
    35
    Beitragswertungen
    0 Beitragspunkte
    Hallo Leute,

    ich kann in meinem Forum keine neuen Beiträge erstellen. Ich habe auch schon geschaut ob ich die Rechte richtig eingestellt habe und ja das habe ich.

    Es kommt folgender Fehler:

    Fatal error: Uncaught Error: Call to undefined method Modules\Forum\Controllers\Newtopic::trigger() in /var/www/vhosts/chillgamerz.net/httpdocs/application/modules/forum/controllers/Newtopic.php:68 Stack trace: #0 /var/www/vhosts/chillgamerz.net/httpdocs/application/libraries/Ilch/Page.php(237): Modules\Forum\Controllers\Newtopic->indexAction() #1 /var/www/vhosts/chillgamerz.net/httpdocs/application/libraries/Ilch/Page.php(130): Ilch\Page->loadController() #2 /var/www/vhosts/chillgamerz.net/httpdocs/index.php(63): Ilch\Page->loadPage() #3 {main} thrown in /var/www/vhosts/chillgamerz.net/httpdocs/application/modules/forum/controllers/Newtopic.php on line 68


    Ich hoffe es kann mir da jemand weiter helfen...

    Gruß Daniel


    verwendete ilch Version: 2.1.x

    betroffene Homepage: chillgamerz.net
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    corian Entwickler
    Registriert seit
    16.06.2011
    Beiträge
    1.069
    Beitragswertungen
    117 Beitragspunkte
    Welche Version hast du aktuell?
    So kann ich den Fehler nicht nachvollziehen.
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    xSteveUrkelx Mitglied
    Registriert seit
    06.06.2018
    Beiträge
    35
    Beitragswertungen
    0 Beitragspunkte
    Na die neuste zwinker
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    corian Entwickler
    Registriert seit
    16.06.2011
    Beiträge
    1.069
    Beitragswertungen
    117 Beitragspunkte
    Dann schau bitte nach was in der Datei, Zeile 68 ist und poste es hier.


    application/modules/forum/controllers/Newtopic.php
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    xSteveUrkelx Mitglied
    Registriert seit
    06.06.2018
    Beiträge
    35
    Beitragswertungen
    0 Beitragspunkte
    $this->trigger(ForumConfig::EVENT_SAVETOPIC_BEFORE, ['model' => $topicModel]);
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    corian Entwickler
    Registriert seit
    16.06.2011
    Beiträge
    1.069
    Beitragswertungen
    117 Beitragspunkte
    Dein Forum Modul schein nicht aktuell zu sein... welche Version hast du hier installiert?
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    blackcoder Hall Of Fame
    Registriert seit
    22.05.2014
    Beiträge
    1.868
    Beitragswertungen
    286 Beitragspunkte
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    xSteveUrkelx Mitglied
    Registriert seit
    06.06.2018
    Beiträge
    35
    Beitragswertungen
    0 Beitragspunkte
    Das bezweifele ich ehrlich gesagt, da ich immer direkt ALLE Updates mache. Von daher... Es ist Ilch 2.1.42 installiert.
    0 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    Nex4T Moderator
    Registriert seit
    28.02.2007
    Beiträge
    3.365
    Beitragswertungen
    202 Beitragspunkte
    Dann muss beim Update ein fehler passiert sein, wie gesagt das Modul ist nicht aktuell.


    Zuletzt modifiziert von Nex4T am 18.03.2021 - 20:05:44
    while(!asleep()) sheep++;
    www.movely.biz
    0 Mitglieder finden den Beitrag gut.
  10. #10
    User Pic
    xSteveUrkelx Mitglied
    Registriert seit
    06.06.2018
    Beiträge
    35
    Beitragswertungen
    0 Beitragspunkte
    Updates Ilch die Module nicht automatisch wenn ich auf ne neue Version Update ?
    0 Mitglieder finden den Beitrag gut.
  11. #11
    User Pic
    BlackRomeo Moderator
    Registriert seit
    31.01.2014
    Beiträge
    83
    Beitragswertungen
    4 Beitragspunkte
    Hallo

    wen du die Ilch Version Updatest, Updatet es nur das Ilch System ohne die Module.
    Die Module musst du Separat im Admincenter>Module>Übersicht und dort dann auf Updates gehen.

    Lg BlackRomeo


    Zuletzt modifiziert von BlackRomeo am 18.03.2021 - 23:13:02
    Frag‘ nicht – Du könntest eine Antwort erhalten

    Suicide-Gaming
    0 Mitglieder finden den Beitrag gut.
  12. #12
    User Pic
    xSteveUrkelx Mitglied
    Registriert seit
    06.06.2018
    Beiträge
    35
    Beitragswertungen
    0 Beitragspunkte
    Okay, das wusste ich noch garnicht. Dankeschön
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurück zu Fehlersuche und Probleme

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten