ilch Forum » Ilch CMS 2.X » Fehlersuche und Probleme » PHP-Erweiterung gd fehlt

Geschlossen
  1. #1
    User Pic
    ladyfunrace Mitglied
    Registriert seit
    24.11.2009
    Beitrge
    23
    Beitragswertungen
    0 Beitragspunkte
    Hallo!

    Unsere alte HP geht nicht mehr und daher wollte ich mit 2.1x eine neue bauen, aber leider kommt bereits bei der Installation, der Systemüberprüfung die Meldung PHP-Erweiterung gd fehlt, die ja erforderlich ist.
    Eigentlich hatte ich bereits aufgegeben, aber vielleicht kann mir jemand die Info geben, wie ich diesen Fehler ausmerzen kann.
    Bin ein Laie und habe diesen Fehler bereits erfolglos in Netz gesucht. Bei der Installation habe ich mich auf die Anweisungen im Video externer Link gehalten.

    LG
    Ladyfunrace


    verwendete ilch Version: 2.1.x
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    BlackRomeo Moderator
    Registriert seit
    31.01.2014
    Beitrge
    240
    Beitragswertungen
    26 Beitragspunkte
    ZitatZitat geschrieben von ladyfunrace
    Hallo!

    Unsere alte HP geht nicht mehr und daher wollte ich mit 2.1x eine neue bauen, aber leider kommt bereits bei der Installation, der Systemüberprüfung die Meldung PHP-Erweiterung gd fehlt, die ja erforderlich ist.
    Eigentlich hatte ich bereits aufgegeben, aber vielleicht kann mir jemand die Info geben, wie ich diesen Fehler ausmerzen kann.
    Bin ein Laie und habe diesen Fehler bereits erfolglos in Netz gesucht. Bei der Installation habe ich mich auf die Anweisungen im Video www.youtube.com/watch?v=W1D1WGp3ilU gehalten.

    LG
    Ladyfunrace


    verwendete ilch Version: 2.1.x



    Servus Ladyfunrace

    Welche PhP Version hat den dein Webspace ?

    und hast du die neueste Ilch Version Installiert.

    Und dein verlinktes Video führt zu einem Video von Slipi worum es geht ein Layout zu Installieren und nicht das Ilch CMS.

    Lg BlackRomeo
    Frag nicht  Du knntest eine Antwort erhalten


    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    ladyfunrace Mitglied
    Registriert seit
    24.11.2009
    Beitrge
    23
    Beitragswertungen
    0 Beitragspunkte
    Hallo Black Romeo,

    vielen Dank für deine sehr rasche Rückmeldung! Ich habe ein Webaccount bei lima-city und dort wird ab php 7.2 bis 8 unterstützt, aber ich befürchte, dass ich mir nun erst einmal persönliche Unterstützung holen muss, denn offensichtlich bin ich nicht korrekt vorgegangen bei der Installation.
    Ich habe mir ilch 2.1.42 heruntergeladen und alle Programme die in dem Video genannt werden. Über den Webspace von lima-city bin ich nicht gegangen, weil ich dachte, dass ich mit den Programmen xampp und Co. erst einmal "offline" die HP basteln könnte und dann diese komplett hochladen bei lima-city.

    Danke dir erst einmal - vielleicht sollte das besser jemand machen, der sich besser als ich auskennt lcheln
    LG
    ladyfunrace
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    Baujahr73 gelschter User
    Mit GD ist GDlib gemeint, das aber in jeder PHP Version vorhanden sein sollte, zumindest ab PHP-5.3

    Du müsstest halt gucken ob das auch Aktiviert ist.

    Erstelle dir eine Datei Namens phpinfo.php mit dem Inhalt...

    <?php
    phpinfo();
    ?>


    diese lädst du dann auf deinen Webspace und rufst die dann mit www.deine-domain.de/phpinfo.php auf, hier solltest du dann sehen ob GDlib Aktiviert ist oder nicht!

    Wenn du Ilch 2 erst einmal nur Lokal auf deinen Rechner installieren möchtest, könnte auch das hier helfen.

    www.codexworld.com/how-to/install-php-gd-library-windows-server/


    Zuletzt modifiziert von Baujahr73 am 13.03.2021 - 13:20:50
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    ladyfunrace Mitglied
    Registriert seit
    24.11.2009
    Beitrge
    23
    Beitragswertungen
    0 Beitragspunkte
    Nachdem BlackRomeo nach der php version gefragt hat, habe ich diese noch einmal überprüft. Bei meinem kostenlosen webserver kann ich leider die php version 5.6 nicht ändern, bzw. kann es nur ändern, wenn ich einen kostenpflichten Server nehmen. Ich werde mir das überlegen....
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    BlackRomeo Moderator
    Registriert seit
    31.01.2014
    Beitrge
    240
    Beitragswertungen
    26 Beitragspunkte
    Ja Ilch Hat keine Unterstützung mehr füt die PHP Version 5.6.

    Wen du es aber über Xampp machen möchtest empfehle ich dir nicht die PHP Version 8 zu nehmen sondern die 7.2 bei der Version 8 von PHP gibt es auch noch Probleme mit Ilch (Corian weiß darüber aber schon bescheid.)

    Lg BlackRomeo
    Frag nicht  Du knntest eine Antwort erhalten


    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    2.063
    Beitragswertungen
    326 Beitragspunkte
    PHP 5.6 wird von den PHP Entwicklern schon seit Januar 2019 nicht mehr unterstützt.
    Die letzte Linux-Distribution (meines Wissens nach), die noch PHP 5.6 unterstützt hat, war Debian 8 und diese ist seit dem 30. Juni 2020 "End of Life".

    Siehe auch das alte Ticket betreffend PHP 5.6:
    github.com/IlchCMS/Ilch-2.0/issues/446

    Ticket betreffend PHP 7.0/7.1:
    github.com/IlchCMS/Ilch-2.0/issues/482

    Eigentlich möchte man daher PHP 5.6 sowieso nicht mehr benutzen, falls möglich.
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Fehlersuche und Probleme

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten