ilch Forum » Ilch CMS 2.X » Fehlersuche und Probleme » Fehler im Forum

Geschlossen
  1. #1
    User Pic
    kleenex Mitglied
    Registriert seit
    21.08.2009
    Beitrge
    12
    Beitragswertungen
    0 Beitragspunkte
    Hast du Module Installiert, Updates eingespielt,

    - Seit wann besteht das Problem: Datum ... seit nachdem ich alle updates gemacht habe
    - Ist das Problem nachvollziehbar ? ---- gute frage
    - Haben andere dasselbe Problem? --- ich habe nichts gefunden
    - besteht das Problem auch mit anderen Browsern - nein
    - werden Fehlercodes ausgeben und wie lauten diese

    Wenn ich einen neue Forumseintrag mache bekomme ich diese Fehlermeldung:

    Schwerwiegender Fehler : Nicht erfasster Fehler: Aufruf der undefinierten Methode Modules \ Forum \ Controllers \ Newtopic :: trigger () in /var/www/vhosts/hauskanal.eu/httpdocs/application/modules/forum/controllers/Newtopic.php:68 Stack Ablaufverfolgung: # 0 /var/www/vhosts/hauskanal.eu/httpdocs/application/libraries/Ilch/Page.php(237): Module \ Forum \ Controller \ Newtopic-> indexAction () # 1 / var / www / vhosts /hauskanal.eu/httpdocs/application/libraries/Ilch/Page.php(130): Ilch \ Page-> loadController () # 2 /var/www/vhosts/hauskanal.eu/httpdocs/index.php(63): Ilch \ Page-> loadPage () # 3 {main} in /var/www/vhosts/hauskanal.eu/httpdocs/application/modules/forum/controllers/Newtopic.php in Zeile 68

    In der Zeile steht folgender Code:

    $this->trigger(ForumConfig::EVENT_SAVETOPIC_BEFORE, ['model' => $topicModel]);




    - wo/wann tritt der Fehler auf (Ortsbeschreibung/evtl. URL)

    Du benutzt ein Modul/Design das Fehler wirft? wo hast du das her, andere möchten den Quelltext davon gerne sehen. Umso mehr Informationen du den Leuten gibst, die helfen wollen, umso schneller kann dein Problem gelöst werden.


    Ich hoffe mir kann wer weiter helfen. Gruß Dirk


    verwendete ilch Version: 2.1.x

    betroffene Homepage: hauskanal.eu
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    blackcoder Hall Of Fame
    Registriert seit
    22.05.2014
    Beitrge
    1.917
    Beitragswertungen
    303 Beitragspunkte
    Das Forum-Modul ist auch auf den neuesten Stand? Sieht aus als wäre das nicht die neueste Version vom Forum.

    github.com/IlchCMS/Ilch-2.0/wiki/Doku-Benutzer-Ilch-aktuell-halten
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    kleenex Mitglied
    Registriert seit
    21.08.2009
    Beitrge
    12
    Beitragswertungen
    0 Beitragspunkte
    Also auf der Startseite im Admin Pannel steht System aktuell (ist grün hinterlegt)


    Version
    Installierte Version 2.1.41
    Server Version 2.1.41
    ilch Neuigkeiten
    Datum Titel
    01.11.2020 Version 2.1.41
    18.09.2020 Version 2.1.40
    05.09.2020 Version 2.1.39
    29.08.2020 Version 2.1.38
    26.07.2020 Version 2.1.37

    muss ich das Forum noch extra updaten ??

    Gruß Dirk
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    SiV-Siggi Mitglied
    Registriert seit
    21.11.2010
    Beitrge
    726
    Beitragswertungen
    39 Beitragspunkte
    bei Jedem Update werden auch Modul mit Änderungen zum Download bereitgestellt.

    einfach mal unter Module schauen welches Module da stehen und updaten.
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    kleenex Mitglied
    Registriert seit
    21.08.2009
    Beitrge
    12
    Beitragswertungen
    0 Beitragspunkte
    ahh OKay

    ich habe jetzt mal ein wenig herumprobiert und habe die original Newtopic.php unbenannt und gegen die aktuelle aus dem Ilch download ersetzt - so wie es bisher ausschaut funktioniert erst mal alles wieder

    Ich danke für eure Hilfe und das mit den Modul Updates werde ich mal suchen und entsprechend einbauen.

    Gruß Dirk
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    217
    Beitragswertungen
    30 Beitragspunkte
    Wie siggi schon erwähnt hatte im admin Bereich unter modulden gucken da werden dir die Updates für die Modulen angezeigt
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    kleenex Mitglied
    Registriert seit
    21.08.2009
    Beitrge
    12
    Beitragswertungen
    0 Beitragspunkte
    Glaube habe es gefunden

    » AdmincenterModuleVerfügbare Updates
    ×Erfolgreich aktualisiert
    Verfügbare Updates
    Zuletzt geprüft am Samstag, 05. Dezember 2020 15:30

    Nach dem Update zum Eintrag springen
    Name Version Beschreibung
    Auszeichnungen
    Autor: Veldscholten, Kevin

    1.7.0 Hier können Auszeichnungen an Benutzer oder Teams verliehen werden.ILCH
    Downloads
    Autor: Stantin, Thomas

    1.7.0 Hier können die Downloads verwaltet werden.


    ein kleiner Ausschnitt von dem was ich da sehe

    Gruß Dirk
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    Baujahr73 gelschter User
    Du müsstest halt im Admincenter auf Module klicken dann auf "Übersicht" und dann links im Menü auf Updates klicken, dort siehst du dann ob es Updates für Module gibt!
    0 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    kleenex Mitglied
    Registriert seit
    21.08.2009
    Beitrge
    12
    Beitragswertungen
    0 Beitragspunkte
    ja habe es herausgefunden - wenn man weiss wie es geht alles ganz einfach -- das Froum funktioniert wieder einwandfrei - und auch der Rest der Seite scheint alles wie gewohnt zu funktionieren.

    An dieser Stelle noch mal Danke an alle dir mir hier weiter geholfen haben.

    Gruß Dirk
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Fehlersuche und Probleme

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten