ilch Forum » Ilch CMS 2.X » Fehlersuche und Probleme » Fehler nach Update

Geschlossen
  1. #1
    User Pic
    Tweety060286 Mitglied
    Registriert seit
    12.02.2018
    Beitrge
    361
    Beitragswertungen
    25 Beitragspunkte
    Hallo leute, hab soeben das Update gemacht und hab nun einen Fehler bei den Artikeln. Im Fontend genauso wie im Backend.
    Wenn ich einen Artikel öffnen will bzw ansehen will kommt folgender fehler.

    Fatal error: Uncaught Error: Call to a member function getCountComments() on null in /.........../application/modules/article/views/index/show.php:154 Stack trace: #0 /.........../application/libraries/Ilch/View.php(22): include() #1 /.........../application/libraries/Ilch/Page.php(154): Ilch\View->loadScript('/var/customers/...') #2 /.........../index.php(63): Ilch\Page->loadPage() #3 {main} thrown in /.........../application/modules/article/views/index/show.php on line 154

    was ist das denn nun ? Oo


    verwendete ilch Version: 2.1.x

    betroffene Homepage: www.death-zone-multigaming.de/
    [Es liegt in deiner Hand ob du der Schlächter bist oder das Vieh]
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    Tweety060286 Mitglied
    Registriert seit
    12.02.2018
    Beitrge
    361
    Beitragswertungen
    25 Beitragspunkte
    Ein weiteres neues Problemchen hat sich ebenso eingegliedert.
    Wenn ich nun im Forum einen neuen Post erstelle, setzt sich automatisch ein <p> </p> mit hinein in jede Zeile.

    Also so siehts dann aus zB

    <p>test</p>
    [Es liegt in deiner Hand ob du der Schlächter bist oder das Vieh]
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    Tweety060286 Mitglied
    Registriert seit
    12.02.2018
    Beitrge
    361
    Beitragswertungen
    25 Beitragspunkte
    ok nocheinmal ich lachen

    hab soeben getestet was passiert wenn ich die datei application/modules/article/views/index/show.php
    manuell ersetze und siehe da plötzlich beide Fehler weg oO.

    hmm dennoch danke
    [Es liegt in deiner Hand ob du der Schlächter bist oder das Vieh]
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    RTX2070 Moderator
    Registriert seit
    14.06.2019
    Beitrge
    144
    Beitragswertungen
    19 Beitragspunkte
    Meinst du jetzt Forum oder Artikel Modul?
    Oder bei beiden Modulen?

    Mfg
    Modul Tutorial auf www.youtube.com
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    xRebellx Mitglied
    Registriert seit
    07.08.2012
    Beitrge
    417
    Beitragswertungen
    16 Beitragspunkte
    Moin,
    Habe beides bei uns getestet und konnte keine Fehler feststellen.
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    Tweety060286 Mitglied
    Registriert seit
    12.02.2018
    Beitrge
    361
    Beitragswertungen
    25 Beitragspunkte
    Im forum wurde das p hinzugefügt und Artikel konnten nicht aufgerufen werden. Aber wie gesagt durch das manuelle ersetzen der Datei war dieser Fehler weg.
    [Es liegt in deiner Hand ob du der Schlächter bist oder das Vieh]
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    RTX2070 Moderator
    Registriert seit
    14.06.2019
    Beitrge
    144
    Beitragswertungen
    19 Beitragspunkte
    Hast du zuvor denn irgendwo was geändert im Quellcode.
    Kann den Fehler auch nicht nachstellen..
    Modul Tutorial auf www.youtube.com
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Fehlersuche und Probleme

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten