ilch Forum » Ilch CMS 2.X » Fehlersuche und Probleme » Nach Update, SQL Fehler Adminbereich

Geschlossen
  1. #1
    User Pic
    DooM Mitglied
    Registriert seit
    20.01.2017
    Beitrge
    17
    Beitragswertungen
    2 Beitragspunkte
    Hallo

    Ich wollte das CMS aktualisieren von einer älteren Version 2.1.13 auf die 2.1.14 wie im System vorgeben. Dies war durch ein abgelaufenes Zertifikat nicht möglich. Daher habe ich die aktuellste version 2.1.21 geladen und händich hochgeladen mit der Einstellung nur aktuellere Dateien ersetzen.
    Die Seite / Inhalte etc sind noch vorhanden aber bei Versuch den Adminbereich zu betreten erhalte ich folgenden Fehler:

    An unexpected error occurred:

    MySQL Error: Unknown column 'type' in 'where clause'
    in Query: SELECT * FROM `ilch_admin_notifications` WHERE `type` = "adminModuleUpdatesAvailable"

    Mehr konnte ich bis jetzt nicht filtern da der Rest zu funktionieren scheint. Mir wäre es auch lieber gewesen das Update normal durchzuführen aber leider laufen die Zertifikate ja scheinbar aus.

    Freue mich über jede Hilfe.

    Danke vorab

    Gruß


    verwendete ilch Version: 2.1.x

    betroffene Homepage: www.37th-division.de
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    1.496
    Beitragswertungen
    230 Beitragspunkte
    ZitatZitat
    Ich wollte das CMS aktualisieren von einer älteren Version 2.1.13 auf die 2.1.14 wie im System vorgeben. Dies war durch ein abgelaufenes Zertifikat nicht möglich. Daher habe ich die aktuellste version 2.1.21 geladen und händich hochgeladen mit der Einstellung nur aktuellere Dateien ersetzen.

    Das war leider das falsche Vorgehen.

    redmine.ilch2.de/projects/dev2/wiki/VerifyingCertificate

    redmine.ilch2.de/projects/dev2/wiki/SignedFiles
    Handhabung von bereits abgelaufenen Zertifikaten

    www.ilch.de/forum-showposts-54904.html

    Das Zertifikat ist aus guten Grund zeitlich begrenzt:
    www.ilch.de/forum-showposts-54904.html#395843

    Das Problem ist jetzt, dass die Änderungen an der Datenbank, die bei vielen Updates gemacht werden, nicht durchgeführt wurden. Die Datenbank passt nicht zur Ilch-Version.

    Wenn du ein Backup hast dann bitte zurück zu Ilch 2.1.13 und entsprechend der Dokumentation das Zertifikat aktualisieren. Anschließend können die Updates normal eingespielt werden.
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    DooM Mitglied
    Registriert seit
    20.01.2017
    Beitrge
    17
    Beitragswertungen
    2 Beitragspunkte
    Hallo

    In welcher Datei/Ordner werden denn die aktuellen Einträge gesichert wenn kein Backup vorhanden ist. Oder legt er alles in der Datenbank ab?
    Userdaten
    Foreneinträge
    News
    etc
    etc
    etc

    Dann spiel ich die Version einfach zurück

    Danke schon einmal bis hierher
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    Nex4T Hall Of Fame
    Registriert seit
    28.02.2007
    Beitrge
    3.208
    Beitragswertungen
    176 Beitragspunkte
    Hast du ein Backup gemacht vor dem Update?
    while(!asleep()) sheep++;
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    1.496
    Beitragswertungen
    230 Beitragspunkte
    Kommst du noch auf diese Seite drauf und wird dort das Update auf 2.1.14 angeboten?
    www.37th-division.de/index.php/admin/admin/settings/update

    Wenn ja könntest du nach einem Backup versuchen normal die Updates zu installieren. Das aktuelle Zertifikat sollte ja jetzt vorliegen.
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    DooM Mitglied
    Registriert seit
    20.01.2017
    Beitrge
    17
    Beitragswertungen
    2 Beitragspunkte
    Nein ein Backup habe ich dieses eine Mal nicht gemacht.
    Auf die Seite komme ich zwar aber nach dem Einloggen o.g. Meldung.

    Gibt es noch eine Möglichkeit der "Rettung"?
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    1.496
    Beitragswertungen
    230 Beitragspunkte
    1. Backup erstellen
    2. Logge dich ein und klicke dann auf den Link.
    www.37th-division.de/index.php/admin/admin/settings/update

    Eventuell kannst du dann die Updates normal installieren.


    Das wäre die einfachere Lösung als sämtliche Änderungen ab 2.1.13 manuell durchzuführen.

    Alternativ könnte man die Galerie usw. sichern und dann Ilch 2.1.13 neu installieren (und aktuelles Zertifikat einfügen).
    Bilder der Galerien usw. wieder einfügen und anschließend bis auf 2.1.21 aktualisieren.
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    DooM Mitglied
    Registriert seit
    20.01.2017
    Beitrge
    17
    Beitragswertungen
    2 Beitragspunkte
    Hallo

    Erst einmal danke für die Hilfe!
    Ich konnte nach dem xten Versuch mich in den Admin Bereich einloggen.
    Habe ab 2.1.14 ein Backup gemacht und konnte bis 2.1.20 updaten.
    Das Update auf 21 verursacht nun leider eine Fehlermeldung die auch auf die Website Einfluß hat und nicht beim Adminbereich bleibt.

    Irgendwas hat er beim Update wohl nicht gemacht.

    Mehr als Update laden / Installieren wurde in dem Fall auch nicht gemacht

    Gruß
    0 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    1.496
    Beitragswertungen
    230 Beitragspunkte
    "vendor"-, "_vendor"- und "__vendor"-Ordner (falls vorhanden) vom Server löschen und den "vendor"-Ordner aus Ilch 2.1.21 hochladen.

    github.com/IlchCMS/Ilch-2.0/releases/download/v2.1.21/Ilch-v2.1.21.zip

    Problem behoben (falls nicht, dann vielleicht mit dem vendor-Ordner aus 2.1.20 probieren)?
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    1 Mitglieder finden den Beitrag gut.
  10. #10
    User Pic
    DooM Mitglied
    Registriert seit
    20.01.2017
    Beitrge
    17
    Beitragswertungen
    2 Beitragspunkte
    Ok hat ein wenig gedauert.

    So durchgeführt wie du schriebst. Seite wieder da. zeigt 2.1.20 an. Update schlägt fehlt mit Fehlermeldung
    Warning: Invalid argument supplied for foreach() in /home/kd38451/public_html/application/modules/admin/views/admin/settings/update.php on line 53

    Immer mal wieder was neues. xD
    0 Mitglieder finden den Beitrag gut.
  11. #11
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    1.496
    Beitragswertungen
    230 Beitragspunkte
    Wird angezeigt, dass das Update bereits heruntergeladen ist?
    Falls du eine Schaltfläche mit "Update löschen" siehst, dann diese mal klicken und dann die Update-Funktion erneut aufrufen.

    Alternativ auf dem Server den Inhalt vom "updates"-Ordner löschen.
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    0 Mitglieder finden den Beitrag gut.
  12. #12
    User Pic
    DooM Mitglied
    Registriert seit
    20.01.2017
    Beitrge
    17
    Beitragswertungen
    2 Beitragspunkte
    Hallo

    Sorry für die späte Antwort.

    Update Ordner ist leer
    Update löschen bereits durchgeführt und neu geladen ohne Erfolg.
    Er bleibt bei der Fehlermeldung:

    Warning: Invalid argument supplied for foreach() in /home/kd38451/public_html/application/modules/admin/views/admin/settings/update.php on line 53

    einen _Vendor Ordner habe ich aber wieder gefunden. Der wurde scheinbar neu erstellt falls das hilfreich sein sollte.

    Gruß und Dank
    0 Mitglieder finden den Beitrag gut.
  13. #13
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    1.496
    Beitragswertungen
    230 Beitragspunkte
    Die Warnung ist mit dieser Änderung hoffentlich behoben:
    github.com/IlchCMS/Ilch-2.0/commit/f99bc4b3253e7cb0962e54ffdb3c5e31cb277410

    www.ilch.de/ilch2/versions/master.zip

    Könntest du testen wenn du diese Datei aus dem aktuellen Entwicklungsstand nimmst:
    application/libraries/Ilch/Transfer.php

    Danach würde das Update aber auch nicht durchlaufen. Da geht mehr schief.
    Schreibrechte usw. richtig?

    "_vendor"-Ordner ist Bestandteil eines der Updates. Der "vendor"-Ordner hätte durch diesen ersetzt werden sollen.

    Ansonsten kann ich dir anbieten, dass ich dir das Update manuell installiere.
    Das heißt Dateien aus dem Update hochladen und Änderungen an der Datenbank mit phpmyadmin oder ähnliches durchführen.

    Nötige Änderungen an der Datenbank:
    github.com/IlchCMS/Ilch-2.0/blob/v2.1.21/application/modules/admin/config/config.php#L491
    github.com/IlchCMS/Ilch-2.0/blob/v2.1.21/application/modules/user/config/config.php#L476


    Zuletzt modifiziert von blackcoder am 27.04.2019 - 04:20:03
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    0 Mitglieder finden den Beitrag gut.
  14. #14
    User Pic
    DooM Mitglied
    Registriert seit
    20.01.2017
    Beitrge
    17
    Beitragswertungen
    2 Beitragspunkte
    Ich würde mich kurz per PN bei dir melden.
    Die restlichen Infos dann wieder öffentlich damit auch anderen geholfen werden kann.

    Sofern ok?
    0 Mitglieder finden den Beitrag gut.
  15. #15
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    1.496
    Beitragswertungen
    230 Beitragspunkte
    Ja, ist natürlich ok.
    Bitte vorher ein Backup der Dateien und der Datenbank erstellen.
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    0 Mitglieder finden den Beitrag gut.
  16. #16
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    1.496
    Beitragswertungen
    230 Beitragspunkte
    Ohne phpMyAdmin ist es natürlich schwer die nötigen Änderungen an der Datenbank vorzunehmen.

    Aber wenn du schon einmal mit phpMyAdmin gearbeitet hast, könntest du das vermutlich auch selber hinkriegen.

    1. Kopie der kompletten Seite erstellen (als Backup) und von der Datenbank (dafür kannst du die Funktion in Ilch nutzen oder phpMyAdmin)
    2. Das Update auf 2.1.21 vom Server herunterladen. Das wäre dann diese Adresse:
    ilch2.de/development/updateserver/stable/updates/Master-2.1.21.zip
    3. Das Update in einem Ordner entpacken und den darin enthaltenen "_vendor"-Ordner umbenennen in "vendor".
    4. Auf deinem Server wieder die "vendor"-Ordner (_vendor, __vendor) löschen.
    5. Alle Dateien aus dem Update hochladen.
    6. phpMyAdmin öffnen und die nötigen Änderungen durchführen:
    github.com/IlchCMS/Ilch-2.0/blob/v2.1.21/application/modules/admin/config/config.php#L491
    (In [prefix]_menu_items die Spalte "target" nach "href" einfügen mit folgenden Eigenschaften: VARCHAR(50) NULL DEFAULT NULL)


    github.com/IlchCMS/Ilch-2.0/blob/v2.1.21/application/modules/user/config/config.php#L476
    Falls die Reihenfolge nicht passt, dann [prefix]_user_menu ausleeren und in der Reihenfolge die Einträge übernehmen:
    ZitatZitat
    id, key, icon, position
    1, "user/panel/index", "fa-home", 1
    2, "user/panel/dialog", "fa-envelope", 2
    3, "user/panel/gallery", "fa-picture-o", 3
    4, "user/panel/friends", "fa-users", 4
    5, "user/panel/settings", "fa-cogs", 5



    In der Tabelle "[prefix]_config" den Wert für "version" auf "2.1.21" setzen.
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    1 Mitglieder finden den Beitrag gut.
  17. #17
    User Pic
    DooM Mitglied
    Registriert seit
    20.01.2017
    Beitrge
    17
    Beitragswertungen
    2 Beitragspunkte
    Der Vollständigkeit halber:

    Problem gelöst!
    Besten Dank an Blackcoder!

    Gruß
    1 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Fehlersuche und Probleme

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten