ilch Forum » Ilch CMS 2.X » Installation und Upgrades » Update 2.1.43 zu ???

Geschlossen
  1. #1
    User Pic
    TeeeJaaay Mitglied
    Registriert seit
    10.04.2024
    Beitrge
    2
    Beitragswertungen
    0 Beitragspunkte
    Hallo liebe Leute,

    ich bin neu hier und habe erst eine Seite mit Ilch zur Pflege übergeben bekommen. Beim Sichten der Seite ist mir aufgefallen, dass das Zertifikat im Ilch abgelaufen war, und das die installierte Version kein Update anbietet.

    Das Zertifikat habe ich aus der aktuellen Version (welche im Web zum Download angeboten wird) extrahiert und in den entsprechenden Pfad eingefügt. Dieses wird mit in Ilch nun als gültiges Zertifikat angezeigt (Gültig ab 03.12.2022 bis 31.01.2025).

    Als Downloadserver ist ilch.de/ilch2_updates/stable/ eingetragen, doch in der Home-Seite des Backend zeigt Ilch mir an die Version (2.1.43) wäre aktuell.

    Bei einer Suche im Forum und per Google habe ich andere Angaben zu Update-Servern gefunden, welche allerdings (eingetragen per MySQL in die Datenbank) alle in einen Time-Out führten (mit dem Schrecken das die Seite nicht läuft, da der Timeout 10s beträgt).

    Kann mir jemand helfen wie ich denn die Seite mal auf einen aktuellen Stand bringen könnte?


    Greets
    TJ


    verwendete ilch Version: 2.1.x
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    2.329
    Beitragswertungen
    363 Beitragspunkte
    Moin,

    in der Tabelle "[prefix]_admin_updateservers" sollte nur noch ein Updateserver eingetragen sein:


    Dieser Updateserver muss dann in der Konfiguration auch ausgewählt sein:


    Die Antwort vom Updateserver wird gecached. Der Cache ist aber nur relativ kurze Zeit gültig.

    Die Updates können auch im Admincenter unter "Einstellungen" und dann "Update" abgerufen werden. Es wird empfohlen eine Sicherheitskopie der Dateien und der Datenbank zu erstellen, damit man falls etwas schief läuft, wieder zurück zum ursprünglichen Stand wechseln kann.

    Sollte auch da nach ein paar Minuten nicht eine neuere Version angezeigt werden, kann man versuchen den Inhalt des "cache"-Ordners im Ilch Hauptverzeichnis zu löschen.

    Die einzelnen Updates werden alle nacheinander aufgespielt. Also nach 2.1.44 werden nach und nach noch Updates bis 2.1.59 angezeigt. Im Anschluss müssen noch die Module (und eventuell Layouts) aktualisiert werden. Dies ist im Admincenter unter "Module", "Übersicht" und dort z.B. "Updates". Sollten Module oder Layouts angepasst worden sein, werden die Änderungen allerdings überschrieben.

    ZitatZitat
    Mit Ilch 2.1.52 wechselten ilch und viele optionale Module und Layouts zur Nutzung des CKEditors 4 im HTML-Modus. Bestehende Inhalte, wie z.B. Beiträge im Forum, müssen einmalig von BBCode in HTML konvertiert werden, damit sie korrekt angezeigt werden. Hierfür steht das BBCode-Konvertierungs-Modul zur Verfügung.

    github.com/IlchCMS/Ilch-2.0/wiki/Doku-Benutzer-BBCode-Konvertierungs-Modul

    github.com/IlchCMS/Ilch-2.0/wiki/Doku-Benutzer-Ilch-aktuell-halten

    Gruß
    blackcoder


    Zuletzt modifiziert von blackcoder am 10.04.2024 - 16:21:25
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    TeeeJaaay Mitglied
    Registriert seit
    10.04.2024
    Beitrge
    2
    Beitragswertungen
    0 Beitragspunkte
    OK, habe den Fehler gefunden .... hatte übersehen das bei dem Update-Server das "www" fehlte. Nachdem ich dies über die Datenbank in die Adresse hinzugefügt habe findet die Installation nun die Updates.

    Zur Info für Andere :
    Ein lustiger (vorheriger) Admin hatte bei dem Server (auf dem Ilch2 in Version 2.1.43 läuft) bereits PHP8.0 aktiviert. Dies führt unter MODULE -> ÜBERSICHT zu einem PHP-Fehler. Musste dann auf PHP7.4 zurück, damit die Seite und das Backend korrekt funktionieren.

    Wenn ich dann jetzt etwas mehr Zeit habe (Backup -> div. Updates -> BB-Code-Konvertierung) führe ich dann die Updates durch.


    Gibt es irgendwo eine Info/Übersicht ab welcher Version vom Ilch2 welche PHP-Version unterstützt wird?


    Greets
    TJ
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    2.329
    Beitragswertungen
    363 Beitragspunkte
    Moin,

    ZitatZitat
    Gibt es irgendwo eine Info/Übersicht ab welcher Version vom Ilch2 welche PHP-Version unterstützt wird?

    Generell ist das Ziel, dass die zu dem Zeitpunkt aktuellste PHP-Version auch unterstützt wird. Eine Übersicht hierfür gibt es aktuell nicht. Ansonsten gibt es nur eine mindestens benötigte PHP-Version.

    Ab Ilch 2.1.44 wird mindestens PHP 7.3 benötigt. Die Versionen ab dem 30. Juni 2024 werden mindestens PHP 7.4 benötigen.

    Zu den einzelnen Versionen gibt es in den entsprechenden Veröffentlichungen auch noch Hinweise, die hilfreich sein könnten. Siehe hier:
    github.com/IlchCMS/Ilch-2.0/releases

    Gruß
    blackcoder
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Installation und Upgrades

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten