ilch Forum » Ilch Clan 1.1 » Fehlersuche und Probleme » Website Error nach PHP 8.0 Update

Geschlossen
  1. #1
    User Pic
    Rey619 Mitglied
    Registriert seit
    22.01.2023
    Beitrge
    2
    Beitragswertungen
    1 Beitragspunkte
    Hi,
    Bräuchte dringend Hilfe,
    Ich habe damals vor ein paar Jahren eine Website übernommen von einen verstorbenen Freund leider weis ich nicht wie genau ich die PHP -Code Sprache ändern kann. Ich habe in den letzten paar Jahren immer auf eine neue PHP 8.0 Version umsteigen müssen bei Strato.de.
    Nur dieses mal ist es noch schlimmer geworden ich habe schon ein paar Zeichen verändert leider bleibe ich jetzt bei den Fehler hängen. Und die Website läd nicht mehr traurig.
    Und ich habe in den Jahren auch Fehler im Forum gehabt.


    Leider weis ich nicht welche Version damals mein Freund bei euch genommen hat aber ich glaube so 2014 war das mit Ilch.

    Falls mir jemand helfen könnte wäre ich sehr dankbar.
    Auch gegen Geld wenn dies gewünscht ist.

    Weitere Details möchte ich per Discord (bin jetzt auch im Discord von Ilch unter verfügbar -> Rey619 )
    oder Teamspeak 3 klären gerne auch mit Teamviewer hilfe.

    Oder kann man auch auf Ilch-v2.1.47 wechseln ?


    best Regards Rey619



    function db_connect () {
    if (defined('CONN')) {
    return;
    }
    define ( 'CONN', @mysql_pconnect(DBHOST, DBUSER, DBPASS));
    $db = @mysql_select_db(DBDATE, CONN);

    if (!CONN) {
    die('Verbindung nicht m&ouml;glich, bitte pr&uuml;fen Sie ihre mySQL Daten wie Passwort, Username und Host<br />');
    }
    if ( !$db ) {
    die ('Kann Datenbank "'.DBDATE.'" nicht benutzen : ' . mysql_error(CONN));
    }
    if (function_exists('mysql_set_charset') and version_compare(mysql_get_server_info(CONN), '5.0.7') !== -1) {
    //Für ältere Installation die init.php nachladen
    if (!defined('ILCH_DB_CHARSET') && file_exists('include/includes/init.php')) {
    require_once 'include/includes/init.php';
    }
    mysql_set_charset(ILCH_DB_CHARSET, CONN);



    verwendete ilch Version: 1.1

    betroffene Homepage: externer Link


    Zuletzt modifiziert von Rey619 am 20.02.2023 - 22:09:16
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    IronMan Mitglied
    Registriert seit
    11.09.2021
    Beitrge
    96
    Beitragswertungen
    30 Beitragspunkte
    Guten Morgen,

    Ilch 1.1 wird nicht mehr Supportet, um Ilch 1.1 PHP8 lauffähig zu machen, müsste so einiges umgeschrieben werden.
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    Rey619 Mitglied
    Registriert seit
    22.01.2023
    Beitrge
    2
    Beitragswertungen
    1 Beitragspunkte
    Also würde man eher zu einen aktuellen Ilch2 CMS zurückgreifen indem man ein altes kaputtes nicht aktuelles system verwendet ;/. lachen
    1 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    IronMan Mitglied
    Registriert seit
    11.09.2021
    Beitrge
    96
    Beitragswertungen
    30 Beitragspunkte
    So sieht es aus! zwinker
    1 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Fehlersuche und Probleme

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten