ilch Forum » Ilch CMS 2.X » Installation und Upgrades » Fehler bei der neuinstallation

Geschlossen
  1. #1
    User Pic
    tank_spider Mitglied
    Registriert seit
    31.10.2020
    Beitrge
    22
    Beitragswertungen
    1 Beitragspunkte
    Hallo zusammen,

    ich wollte das Clan Script lokal mit xampp Instaliern um ein wenig herum zu experimentieren. Aber schon bei der Instalationtritt ein Fehler auf und ich weiß nicht warum.

    Und zwar kommt dieser Fehler :

    Parse error: syntax error, unexpected token "as" in C:\xampp\htdocs\fist\application\modules\teams\config\config.php on line 9

    Ich habe auch ein Bild:

    gesperrtes Bild


    woran kann das liegen ? Habe das schonmal so gemacht ohne jeglichen Fehler.

    Gruß Sascha


    verwendete ilch Version: 2.1.x
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    330
    Beitragswertungen
    57 Beitragspunkte
    Überschreibe ind deiner benannten Datei und Zeile mal mit folgenden Code:

    use \Ilch\Config\Database as IlchDatabase;


    Ist quasi nur ein Leerzeichen nach use ...
    Hat sich deine php Version geändert?


    Zuletzt modifiziert von hhunderter am 28.12.2020 - 23:39:57
    1 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    tank_spider Mitglied
    Registriert seit
    31.10.2020
    Beitrge
    22
    Beitragswertungen
    1 Beitragspunkte
    Vielen dank für die schnelle Hilfe.

    Daran hat es gelegen.
    Könnte sein das durch die neue Xampp Version sich auch die php Version geändert hat.
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Installation und Upgrades

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten