ilch Forum » Ilch CMS 2.X » Installation und Upgrades » Fehlermeldung nach Update vom 16.07.19

Geschlossen
  1. #1
    User Pic
    u2w Mitglied
    Registriert seit
    14.09.2018
    Beitrge
    19
    Beitragswertungen
    0 Beitragspunkte
    Hallo,

    nach dem Versuch, gestern das neueste Update zu installieren,
    funktioniert meine Homepage leider nicht mehr.

    Stattdessen kommt folgende Fehlermeldung:


    Warning: require(/home/vol12_1/epizy.com/epiz_23791122/htdocs/vendor/autoload.php): failed to open stream: No such file or directory in /home/vol12_1/epizy.com/epiz_23791122/htdocs/index.php on line 42

    Fatal error: require(): Failed opening required '/home/vol12_1/epizy.com/epiz_23791122/htdocs/vendor/autoload.php' (include_path='.:/usr/share/pear/') in /home/vol12_1/epizy.com/epiz_23791122/htdocs/index.php on line 42


    Was lief falsch ?

    mfG!


    verwendete ilch Version: 2.1.x

    betroffene Homepage: www.e-werk.epizy.com


    Zuletzt modifiziert von u2w am 17.07.2019 - 12:24:48
    _________________
    u2w
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    90
    Beitragswertungen
    11 Beitragspunkte
    Vermutlich wurde der Vendor-Ordner nicht richtig angelegt.

    ZitatZitat geschrieben von blackcoder
    "vendor"-, "_vendor"- und "__vendor"-Ordner (falls vorhanden) vom Server löschen und den "vendor"-Ordner aus Ilch 2.1.24 hochladen.

    [url]github.com/IlchCMS/Ilch-2.0/releases/download/v2.1.24/Ilch-v2.1.24.zip[/url]
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    u2w Mitglied
    Registriert seit
    14.09.2018
    Beitrge
    19
    Beitragswertungen
    0 Beitragspunkte
    Ok, danke, so funktioniert´s wieder.

    Allerdings ist dann nur v.2.1.23 installiert und beim erneuten Updateversuch kommt übrigens kurz folgende Fehlermeldung:

    Fatal error: Maximum execution time of 20 seconds exceeded in /home/vol12_1/epizy.com/epiz_23791122/htdocs/application/libraries/Ilch/Functions.php on line 102


    Bei Neuanzeige der Seite kommt dann wieder dieselbe Fehlermeldung, wie oben schon gepostet:


    Warning: require(/home/vol12_1/epizy.com/epiz_23791122/htdocs/vendor/autoload.php): failed to open stream: No such file or directory in /home/vol12_1/epizy.com/epiz_23791122/htdocs/index.php on line 42

    Fatal error: require(): Failed opening required '/home/vol12_1/epizy.com/epiz_23791122/htdocs/vendor/autoload.php' (include_path='.:/usr/share/pear/') in /home/vol12_1/epizy.com/epiz_23791122/htdocs/index.php on line 42


    d.h. ich mach das so, wie oben vorgeschlagen:

    Den vendor-Ordner nochmal neu hochladen und auf das Update v.2.1.24 verzichten.
    _________________
    u2w
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    1.410
    Beitragswertungen
    216 Beitragspunkte
    Sieht aus als würde das am gratis Webspace liegen.

    ZitatZitat
    maximum PHP execution time being limited to 20 seconds and its not possible to change it. If you need more please consider premium hosting

    forum.infinityfree.net/t/increase-max-execution-time-php/9655

    ZitatZitat
    The script time limit cannot be increased for fair usage reasons (you cant run big, heavy scripts on free hosting because they would consume an unreasonable amount of server power). Our servers are pretty fast so you can just try to run the installer without setting the time limit and hope it completes in time. However, if that doesnt work (or the theme simply refuses to be installed without the increased time limit), Im afraid youll have to upgrade your account.

    forum.infinityfree.net/t/how-to-modify-the-timelimit/6125
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    u2w Mitglied
    Registriert seit
    14.09.2018
    Beitrge
    19
    Beitragswertungen
    0 Beitragspunkte
    ok, danke.


    Zuletzt modifiziert von u2w am 18.07.2019 - 09:42:23
    _________________
    u2w
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    mmpro20 Mitglied
    Registriert seit
    31.10.2015
    Beitrge
    59
    Beitragswertungen
    2 Beitragspunkte
    Hallo. Habe zur Zeit auch das Problem mit dem Update auf 2.1.24!
    Es kommt die meldung Fatal error: Maximum execution time of 20 seconds.
    Bei der 2.1.23 ging es aber.

    Reicht es aus das Updatepacket zu laden und den Inhalt aus dem _Ventor Ordner und den Rest auf den Webspace zu laden, oder nur den Inhalt aus dem _Ventor Ordner und in der Datenbank unter ilch_config einfach die Versiopnsnummer zu ändern, fals es mit meinem Webspaceanbieter Probleme gibt?

    Danke euch


    Zuletzt modifiziert von mmpro20 am 18.07.2019 - 21:31:03
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beitrge
    1.410
    Beitragswertungen
    216 Beitragspunkte
    Das Update auf 2.1.23 war auch klein.
    Mit 2.1.24 wurde der CKEditor usw aktualisiert, weswegen die Updatedatei größer ist.

    Nur die Dateien aus dem Update zu übernehmen reicht nicht, wenn z.B. noch Änderungen an der Datenbank durchgeführt werden.

    Gruß
    blackcoder


    Zuletzt modifiziert von blackcoder am 18.07.2019 - 21:52:10
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Installation und Upgrades

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten