ilch Forum » Ilch Clan 1.1 » Installation und Upgrades » probleme beim installieren von ilchclan

Geschlossen
  1. #1
    User Pic
    Pase91 Mitglied
    Registriert seit
    12.06.2019
    Beitrge
    3
    Beitragswertungen
    0 Beitragspunkte
    hallo zusammen,
    beim installieren hat alles gut geklappt. die rechte passen alle. aber am ende kommt diese meldung:

    Fatal error: Uncaught Error: Call to undefined function mysql_pconnect() in /users/tsd/www/clan/include/includes/func/db/mysql.php:14 Stack trace: #0 /users/tsd/www/clan/install.php(598): db_connect() #1 {main} thrown in /users/tsd/www/clan/include/includes/func/db/mysql.php on line 14

    was mache ich falsch oderwas muss ich ändern?

    danke schon mal im vorraus


    verwendete ilch Version: 1.1 P

    betroffene Homepage: tsd.bplaced.net
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    62
    Beitragswertungen
    10 Beitragspunkte
    Welche PHP-Version befindet sich auf dein Server?

    Edit: hab mal verschoben nach V1.1
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    Slipi Mitglied
    Registriert seit
    19.01.2018
    Beitrge
    356
    Beitragswertungen
    22 Beitragspunkte
    Die betroffene Homepage hat aber ilch 2.0

    Slipi
    Grafiken | Layouts | OnePage
    www.sd-sdesign.at
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    62
    Beitragswertungen
    10 Beitragspunkte
    laut Fehlercode würde ich aber eher an Ilch1 tippen
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    Pase91 Mitglied
    Registriert seit
    12.06.2019
    Beitrge
    3
    Beitragswertungen
    0 Beitragspunkte
    die php version ist die 7.2
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    hhunderter Entwickler
    Registriert seit
    12.08.2018
    Beitrge
    62
    Beitragswertungen
    10 Beitragspunkte
    Zu dein Fehler :
    Warnung
    
    Diese Erweiterung ist seit PHP 5.5.0 als veraltet markiert und wurde in PHP 7.0.0 entfernt. Verwenden Sie stattdessen die Erweiterungen MySQLi oder PDO_MySQL. Weitere Informationen finden Sie im Ratgeber MySQL: Auswahl einer API und den zugehrigen FAQ. Alternativen zu dieser Funktion umfassen:
    
        mysqli_connect() mit p: Host-Prfix
        PDO::__construct() mit PDO::ATTR_PERSISTENT als Treiberoption
    www.php.net/manual/de/function.mysql-pconnect.php

    und es geht um die Ilch Version 1.1P?
    Wenn ja, ist diese nicht so ohne weiteres mit deiner PHP-Version kompatible. da gab es schon ein paar Themen darüber welche Änderungen daran gemacht werden müssen um es mit PHP 7. zum laufen zu kriegen.
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    Baujahr73 Mitglied
    Registriert seit
    05.09.2013
    Beitrge
    252
    Beitragswertungen
    25 Beitragspunkte
    Trage mal in deiner.htaccess folgendes ein

    AddType application/x-httpd-php56.php



    Zuletzt modifiziert von Baujahr73 am 13.06.2019 - 07:40:32
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    Pase91 Mitglied
    Registriert seit
    12.06.2019
    Beitrge
    3
    Beitragswertungen
    0 Beitragspunkte
    hallo zusammen,
    habe das problem gelöst. ich konnte bei meinem webanbietermein php von7.2 auf 5.6 ändern. scheint jetzt mal zugehen.
    danke für eure hilfe lcheln
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Installation und Upgrades

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten