ilch Forum » Ilch CMS 2.X » Installation und Upgrades » Update war beschädigt oder manipuliert.

Geschlossen
  1. #1
    User Pic
    Maik Mitglied
    Registriert seit
    30.12.2018
    Beiträge
    3
    Beitragswertungen
    0 Beitragspunkte
    Habt ihr da eine Info

    Version 2.1.18 zu .19

    Beim Update bekomme ich die Fehlermeldung

    Update war beschädigt oder manipuliert. Update verworfen.


    verwendete ilch Version: 2.1.x
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beiträge
    1.289
    Beitragswertungen
    197 Beitragspunkte
    Welcher Updateserver ist ausgewählt (Admincenter/Einstellungen)?
    Welcher Fingerabdruck wird für das Zertifikat angezeigt (Admincenter/Informationen/Zertifikat)?

    redmine.ilch2.de/projects/dev2/wiki/Updateserver
    redmine.ilch2.de/projects/dev2/wiki/VerifyingCertificate
    redmine.ilch2.de/projects/dev2/wiki/VerificationFailed


    Zuletzt modifiziert von blackcoder am 08.02.2019 - 11:15:51
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    eisvogel10 Mitglied
    Registriert seit
    06.11.2009
    Beiträge
    104
    Beitragswertungen
    9 Beitragspunkte
    ZitatZitat geschrieben von Maik
    Habt ihr da eine Info

    Version 2.1.18 zu .19

    Beim Update bekomme ich die Fehlermeldung

    Update war beschädigt oder manipuliert. Update verworfen.


    verwendete ilch Version: 2.1.x


    Hatte ich letztens auch grumml

    Fehler war bei einem Webspace Umzug zustande gekommen. War mir sicher das ich Umzugs Ilch zuvor auf 2.1.19 geupdatet hatte, aber auf dem neuen Webspace wollte die Datenbank scheinbar nicht mit dem Backup.
    Zum Schluss habe ich Ilch 2.1.18 neu installiert und das wollte dann mit der Datenbank (Pfade kontrollieren) auch arbeiten und sofort das Update ziehen.

    Gerade umgezogen ? zwinker
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    [GNC]Lord-MDB Mitglied
    Registriert seit
    02.02.2015
    Beiträge
    45
    Beitragswertungen
    1 Beitragspunkte
    ich habe das gleiche Problem

    habe beide update Server ausprobiert

    Neue Version gefunden: 2.1.19

    Update war beschädigt oder manipuliert. Update verworfen.
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beiträge
    1.289
    Beitragswertungen
    197 Beitragspunkte
    Gerade noch einmal getestet. Ilch 2.1.18 installiert und bis auf 2.1.20 aktualisiert. Sollte also noch funktionieren.

    Wird bei dir die Schaltfläche "Update löschen" angezeigt? Vielleicht mal anklicken und dann das Update erneut versuchen. Ansonsten auf dem Server den Inhalt vom "updates"-Ordner löschen und erneut versuchen.

    Welcher Fingerabdruck wird für das Zertifikat angezeigt?
    redmine.ilch2.de/projects/dev2/wiki/VerifyingCertificate

    Hier sollte bei Version 2.1.18 und eher folgendes angezeigt werden:
    Fingerabdruck (SHA-1) 880fb2b7345e04b14877bc02305df097cc08442d
    Fingerabdruck (SHA-256) 38f66b5530941c32fafbd042fec87d3f6e4b27f00c3e81e9e2fe1862dc92f782

    Ab 2.1.19 dann:
    Fingerabdruck (SHA-1) e4d44cb6c89bdb52b8c6465780459e15f0d6fcd5
    Fingerabdruck (SHA-256) f929d1a145ea3d477de1e2604093ebb4023b6e2e1bebaedfe67094d28ff03ebb
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    [GNC]Lord-MDB Mitglied
    Registriert seit
    02.02.2015
    Beiträge
    45
    Beitragswertungen
    1 Beitragspunkte
    ok ich habe noch mal ein Backup geladen und dann ging es.
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    Phoenix1303 Mitglied
    Registriert seit
    04.06.2011
    Beiträge
    137
    Beitragswertungen
    12 Beitragspunkte
    Hallo Leute,

    ich war leider gezwungen ein etwas älteres Backup aufzuspielen, da es im aktuelleren Backup die DB wärend des Updates zerschossen hat.

    Bin nun leider wieder auf Version x.x.14 und bekomme die Meldung: Zertifikat fehlt oder ist abgelaufen.

    Kann ich das irgendwie überbrücken, um upzudaten?

    Die Hinweise und Tipps hier habe ich jetzt durch, aber leider ohne Erfolg...

    Vielen Dank schon mal für eure Hilfe.

    LG Manu
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beiträge
    1.289
    Beitragswertungen
    197 Beitragspunkte
    Kann mir nicht vorstellen, dass es wirklich nötig ist ein so altes Backup zu nehmen.
    Kein Backup von direkt vor dem Update verfügbar?

    Hier ist beschrieben was zu erledigen ist:
    redmine.ilch2.de/projects/dev2/wiki/VerifyingCertificate

    Das aktuelle Zertifikat kannst du z.B. aus 2.1.21 herauskopieren:
    github.com/IlchCMS/Ilch-2.0/releases/tag/v2.1.21

    Ich passe derweil die Updateserver entsprechend an (hätte eigentlich am 10.03. gemacht werden müssen).

    Danach werden auch die alten Updates akzeptiert.

    // Updateserver angepasst.


    Zuletzt modifiziert von blackcoder am 15.03.2019 - 16:47:28
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    0 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    Phoenix1303 Mitglied
    Registriert seit
    04.06.2011
    Beiträge
    137
    Beitragswertungen
    12 Beitragspunkte
    Danke blackcoder,

    das Kopieren der Zertifikate hat gereicht und bin jetzt auf dem aktuellsten Stand.

    Und zu deiner Frage:
    Da ich oft etwas faul bin hatte ich kein Backup gemacht und dann kam der Fehler. Da ich auch da nicht gleich gerafft hatte, was Phase war, hab ich einfach gedacht "Na ja, hat sich halt verschluckt... Schau ich später mal nach...).
    Zu dem Zeitpunkt hatte ich x.x.18 am Laufen, aber durch die Faulheit ist das letzte Update auch schon wieder etwas her gewesen und so war das einzige vollständige Backup (FTP + DB) vom Oktober 2018, also nun fast 6 Monate alt...

    Werde nun also wirklich regelmäßiger und vor Updates ein komplettes Backup ziehen.

    LG Manu
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurück zu Installation und Upgrades

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten