ilch Forum » Ilch Clan 1.1 » Installation und Upgrades » 1.1P für PHP 7 ändern Anleitung

Geschlossen
  1. #1
    User Pic
    mmpro20 Mitglied
    Registriert seit
    31.10.2015
    Beiträge
    59
    Beitragswertungen
    2 Beitragspunkte
    Weil viele fragen, wie man die Version 1.1P unter PHP 7 zum laufen bringt hier meine Anleitung, wie ich es gemacht habe und auch geht. Aber einige Module werden dann nicht mehr gehen!!
    Ich übernehme aber keine Haftung, fals es bei euch nicht so klappt. Daher auf eigene Gefahr. Am besten dieses auf einem Testserver machen um zu schauen ob es bei euch auch so geht.
    Also zum testen bei euch, eure Installation komplett wie ihr sie aktuell habt auf einen Testserver machen!
    Es geht aber nur, wenn ihr bei euerem Anbieter die PHP Versionen umstellen könnt.
    Wichtig ist, wenn man dies machen möchte die PHP version auf 5.x- 5.6 steht!

    Als erstes macht ihr ein Backup der Datenbank.
    Danach ladet ihr eure ganzen Datein von euerem Webspace runter. (aber nicht löschen)!
    Als nächsten Schritt bitte die Version 1.1q, die eine nicht ganz fertige Version ist laden.
    Die bekommt ihr hier! github.com/IlchCMS/Ilch-1.1/tree/1.1q

    Nun entpackt man alle Datein in einem neuen Ordner.
    Jetzt sollte man wissen, welche Module man installiert hatte in der alten Version.
    Nun kopiert man genau diese Datein von den Modulen in den neuen Order, wo ihr die 1.1q entpackt habt und ersetzt diese.

    Wer das Modul Design Greator zum erstellen genommen hat muss nun die logincreator.php mit einem Editor öffnen und da wo Mysql steht in Mysqli ändern.

    Desweiteren, wer den Creator genommen hat bitte auch alle Datein von dem Ordner include/templates/forum die Datein show_cat, showforum, showpost und showtopic in den neuen Ordner an gleicher Stelle kopieren.
    Grund ist, das sonst das Fenster in der mitte verkleinert wird.

    Dies kann auch bei den News passieren. Sollte dies der Fall sein, genau das gleiche wie oben machen, nur mit den News.

    Danach müsst ihr eueren komplett neu erstellten Ordner auf eueren Webspace laden und alles überschreiben.
    Hab ihr alles hochgeladen müsst ihr auf euer Seite die Update.php ausführen die im Packet enthalten ist.
    Es kann sein das kleine Fehler kommen die aber nicht schlimm sind, das es sich um den BBCode handelt der schon in der Datenbank vorhanden ist.

    Habt ihr alles richtig gemacht, geht ihr in den Adminbereich, der dann komplett anders aussieht wie hier bei mir!
    prntscr.com/mdlsvq

    Danach unter Admin den Reiter Server Konfiguration schauen. Da sollte nun links oben noch PHP 5.x stehen.
    Ist dies der Fall geht ihr zu euerem Webspaceanbieter und stellt die PHP Version auf 7.0 oder 7.1 um. Solltet ihr nur auf PHP 7.2 stellen können bitte vorher im Adminbereich euere Seite das Antispam ausschalten, da es ab der 7.2 Fehler macht.

    Habt ihr es umgestell müsst ihr je nach Anbieter warten, bis er es umgestellt hat. Meist innerhalb von 30min. Dann könnt ihr wieder unter Server Konfiguration schauen und da solltenun PHP 7 stehen.

    hier der Beweis von meiner Seite
    prntscr.com/mdlvrq

    Ich hoffe ich konnte helfen.
    Aber wie gesagt so habe ich es zum laufen bekommen und dies sind nur meine Schritte.
    Also das ist keine Anleitung die zu 100% funktionieren wird. Aber wer es richtig macht, kann erst einmal
    weiterhin seine alte Seite nutzen.

    Lg mmpro20


    verwendete ilch Version: 1.1 P
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurück zu Installation und Upgrades

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten