ilch Forum » Ilch Clan 1.1 » Fehlersuche und Probleme » Fehler bei Registrierung

Geschlossen
  1. #1
    User Pic
    mmpro20 Mitglied
    Registriert seit
    31.10.2015
    Beitrge
    85
    Beitragswertungen
    4 Beitragspunkte
    Hi. Wenn sich Leute auf meiner Hp Registrieren wollen geht alles Wunderbar.
    Nur nach dem Absenden erscheint im obern bereich folgende Fehlermeldung!

    Warning: session_name() [function.session-name]: Cannot change session name when session is active in /users/nutzer/www/include/includes/captcha/MemorySession.php on line 25

    Warning: Cannot modify header information - headers already sent by (output started at /users/nutzer/www/include/includes/captcha/MemorySession.php:25) in /users/nutzer/www/include/includes/class/design.php on line 23

    woran könnte dies liegen?
    Danke für die Hilfe
    von der MermorySession.php der Code

    <?php
    /**
     * Captcha fr www.ilch.de
     * @author T0P0LIN0
     * thanks to uwe slick! http://www.deruwe.de/captcha.html - his thoughts
     */
    
    /**
     * MemorySession
     * Speichern der Zahlen fr das Captcha in der Session
     *
     * @author Mairu
     */
    class MemorySession
    {
        /**
         * Initialisiert Session
         * 
         * @param boolean $startSession session_start wird ausgefhrt
         * @param string $sessionId SessionId die dabei verwendet wird
         */
        function MemorySession($startSession = true, $sessionId = 'sid')
        {
            if ($startSession) {
                session_name($sessionId);


    Von der design.php der Code
    <?php
    // Copyright by Manuel
    // Support www.ilch.de
    defined ('main') or die ('no direct access');
    
    if (!isset($ILCH_HEADER_ADDITIONS)) {
        $ILCH_HEADER_ADDITIONS = '';
    }
    if (!isset($ILCH_BODYEND_ADDITIONS)) {
        $ILCH_BODYEND_ADDITIONS = '';
    }
    class design extends tpl {
        var $html;
        var $design;
        var $vars;
        var $was;
        var $file;
    
        function design ($title, $hmenu, $was = 1, $file = null)
        {
            global $allgAr;
    
            header('Content-Type: text/html;charset=' . ILCH_CHARSET);

    verwendete ilch Version: 1.1 P


    Zuletzt modifiziert von mmpro20 am 15.12.2018 - 20:39:44
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    mmpro20 Mitglied
    Registriert seit
    31.10.2015
    Beitrge
    85
    Beitragswertungen
    4 Beitragspunkte
    habe ein wenig getestet. Diese Fehler sin dann weg, wenn ich im Admin Menü Antispam auf Gast mache.
    In welcher Datei muss ich da schauen um den Fehler zu beheben??

    In meinem Auge müsste man ja das Antispam anpassen?
    Oder an der Datenbank?

    Zuletzt modifiziert von mmpro20 am 16.12.2018 - 20:50:25
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    pepe Mitglied
    Registriert seit
    21.02.2010
    Beitrge
    17
    Beitragswertungen
    0 Beitragspunkte
    Ich hab das mal bei mir versucht und ich bekomme diese Fehlermeldungen nicht. Weder bei Gast,User oder Superuser bei Antispam.
    Welche PHP Version verwendet dein Hoster?
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    mmpro20 Mitglied
    Registriert seit
    31.10.2015
    Beitrge
    85
    Beitragswertungen
    4 Beitragspunkte
    Mein Hoster macht PHP 7. Auf PHP 5 geht es. Ich bin halt dabei die 1.1p PHP7 fähig zu machen wo ich auch fast fertig bin. Das ist nur noch nen Fehler den ich beheben möchte
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    Slipi ilch.de Design
    Registriert seit
    19.01.2018
    Beitrge
    851
    Beitragswertungen
    106 Beitragspunkte
    ZitatZitat geschrieben von mmpro20
    Mein Hoster macht PHP 7. Auf PHP 5 geht es. Ich bin halt dabei die 1.1p PHP7 fähig zu machen wo ich auch fast fertig bin. Das ist nur noch nen Fehler den ich beheben möchte


    Vielleicht daran nachgedacht, das dies eine Wichtige Information wäre?

    Versuche 1.1p php7 fähig zu machen?

    Ich selber kann dir leider nicht helfen, aber meine gelesen zu haben das 1 oder 2 User versuchen 1.1 bzw 1.1p php7 fähig zu machen.

    www.ilch.de/forum-showposts-54524.html#393666

    Mehr als diesen Link zu Posten kann ich für dich nicht tun.

    Slipi
    Grafiken | Layouts | OnePage
    www.sd-sdesign.at
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    wiesenflieger Mitglied
    Registriert seit
    03.12.2017
    Beitrge
    184
    Beitragswertungen
    12 Beitragspunkte
    ZitatZitat geschrieben von Slipi


    Versuche 1.1p php7 fähig zu machen?


    Slipi

    Slipi das macht er doch gerade
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    mmpro20 Mitglied
    Registriert seit
    31.10.2015
    Beitrge
    85
    Beitragswertungen
    4 Beitragspunkte
    Sorry mit dem PHP 7 hab ich verbummelt im Kopf.
    Aus meiner sicht ist es ja nur ein Abfrage Problem, da ja die Registrierung ja geht und auch Erfolg hat, nur das halt die Fehlermeldung kommt.

    Ich dächte das in PHP 7 das startSession an den Anfang kommt. Kann mich auch Irren.
    Der Fehler kann auch in der allg.php ist, da dort auch eine Capacha Abfrage ist.
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    Slipi ilch.de Design
    Registriert seit
    19.01.2018
    Beitrge
    851
    Beitragswertungen
    106 Beitragspunkte
    ZitatZitat geschrieben von wiesenflieger
    ZitatZitat geschrieben von Slipi


    Versuche 1.1p php7 fähig zu machen?


    Slipi

    Slipi das macht er doch gerade


    Dies hatte er in der Problem beschreibung nicht angegeben. Mein Kommentar diente nur einen zweck - umso mehr Info umso schneller kann geholfen werden.

    Slipi
    Grafiken | Layouts | OnePage
    www.sd-sdesign.at
    0 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    mmpro20 Mitglied
    Registriert seit
    31.10.2015
    Beitrge
    85
    Beitragswertungen
    4 Beitragspunkte
    So mal ein kurzes Feedback zu der Fehlermeldung!

    Unter PHP5 kein Fehler. Unter PHP 7.0 kein Fehler. Unter PHP 7.1 kein fehler. Aber unter PHP 7.2 kommt der fehler. Nun weiß ich nicht weiter, was sich zwischen der 7.1 und 7.2 geändert hat. Reicht es das ich auf die 7.1 stelle, oder soll und muss man gleich die 7.2 nehmen?

    Vileicht kann einer helfen


    Zuletzt modifiziert von mmpro20 am 19.12.2018 - 13:10:57
    0 Mitglieder finden den Beitrag gut.
  10. #10
    User Pic
    wiesenflieger Mitglied
    Registriert seit
    03.12.2017
    Beitrge
    184
    Beitragswertungen
    12 Beitragspunkte
    7.0 reicht auch schon aus
    0 Mitglieder finden den Beitrag gut.
  11. #11
    User Pic
    mmpro20 Mitglied
    Registriert seit
    31.10.2015
    Beitrge
    85
    Beitragswertungen
    4 Beitragspunkte
    Ja das ist klar. Aber ich gehe nach dem Supportplan. Da endet dieser für die 7.1 am 01.12.19 und für die 7.2 am 30.11.20. Weil es ist ja schn eine 7.3 in Arbeit.

    Daher meine Frage was in der Codezeile falsch ist für die Version 7.2.
    Ich gehe davon mal aus das alle hoster bald die 5.6 nicht mehr anbieten und dann nur noch immer die aktuellen Versionen
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Fehlersuche und Probleme

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten