ilch Forum » Ilch Clan 1.1 » Fehlersuche und Probleme » Php Version bei 1.1P ?

Geschlossen
  1. #1
    User Pic
    marvman Mitglied
    Registriert seit
    22.05.2006
    Beitrge
    575
    Beitragswertungen
    2 Beitragspunkte
    Hallo,

    mein Webhoster stellt demnächst von php 5.6 auf php 7.2 um. Nun hab ich zum Versuch das mal umgestellt, aber dann ist meine Seite nicht mehr erreichbar.

    Läuft Ilch 1.1P mit php 7.2 ?? Kann man da was machen oder muß ich auf Ilch 2 ??

    Gruß Michael


    verwendete ilch Version: 1.1 P

    betroffene Homepage: www.dakfunclan.de
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    Lord|Schirmer Administrator
    Registriert seit
    21.03.2007
    Beitrge
    7.336
    Beitragswertungen
    1132 Beitragspunkte
    Sieht schlecht aus marvman traurig 1.1P funktioniert nur bis PHP 5.6 und wird nicht mehr weiterentwickelt.

    Wir empfehlen den Umstieg auf 2.X. Auch wenn der Anfang etwas schwer ist wird es sich lohnen.
    rules :: doku :: faq :: linkus
    1 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    Slipi Mitglied
    Registriert seit
    19.01.2018
    Beitrge
    168
    Beitragswertungen
    11 Beitragspunkte
    Solltest du Hilfe brauchen (Layout). Einfach melden.

    Slipi
    Header,Banner,Playersheets, Layouts uvm. www.sd-sdesign.at
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    marvman Mitglied
    Registriert seit
    22.05.2006
    Beitrge
    575
    Beitragswertungen
    2 Beitragspunkte
    grrrr ok dann schau ich mir Ilch2.0 mal an zwinker
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    Baujahr73 Mitglied
    Registriert seit
    05.09.2013
    Beitrge
    175
    Beitragswertungen
    19 Beitragspunkte
    Du kannst auch versuchen php5 via htacces zu erzwingen.

    Dies dann in deine htaccess eintragen.

    AddHandler application/x-httpd-php56
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    marvman Mitglied
    Registriert seit
    22.05.2006
    Beitrge
    575
    Beitragswertungen
    2 Beitragspunkte
    Hallo,

    so mal schnell paar Sachen probiert und was gebastelt. Da werde ich mich noch dran verweilen können.

    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    blakedj06 Mitglied
    Registriert seit
    07.08.2008
    Beitrge
    202
    Beitragswertungen
    30 Beitragspunkte
    Ach man Leute.....

    @Marvman melde dich bei mir selbstverständlich funktioniert mit ein paar Anpassungen Ilch 1.1 mit php 7.

    www.comgames.de < Ilch zumindest das was davon übrig ist und php 7.

    Verstehe nicht warum Leuten hier Ilch 2.0 so schöngeredet wird. Die Designs sehen aus wie vor 10 Jahren nur das sie jetzt durch Bootstrap responsive sind. Die teilweise ewig lange URL index/index/index usw ist alles andere als schick.

    Für die Entwickler hier wäre es ein leichtes Ilch 1.1 php7 kompatibel zu machen. Aber man will ja Ilch 2.0 pushen was in meinen Augen niemals in die Fußstapfen von 1.1 treten wird.
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    IceT33 Mitglied
    Registriert seit
    22.10.2005
    Beitrge
    568
    Beitragswertungen
    5 Beitragspunkte
    ZitatZitat geschrieben von blakedj06
    Ach man Leute.....

    @Marvman melde dich bei mir selbstverständlich funktioniert mit ein paar Anpassungen Ilch 1.1 mit php 7.

    www.comgames.de < Ilch zumindest das was davon übrig ist und php 7.

    Verstehe nicht warum Leuten hier Ilch 2.0 so schöngeredet wird. Die Designs sehen aus wie vor 10 Jahren nur das sie jetzt durch Bootstrap responsive sind. Die teilweise ewig lange URL index/index/index usw ist alles andere als schick.

    Für die Entwickler hier wäre es ein leichtes Ilch 1.1 php7 kompatibel zu machen. Aber man will ja Ilch 2.0 pushen was in meinen Augen niemals in die Fußstapfen von 1.1 treten wird.


    Erstmal daumen hoch bin der selben Meinung.
    Aber jetzt sag mal wie ich ilch 1.1 php7 fähig mache wenn es doch nicht so viel ist wie du sagst
    0 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    blakedj06 Mitglied
    Registriert seit
    07.08.2008
    Beitrge
    202
    Beitragswertungen
    30 Beitragspunkte
    Ich meld mich per PN!
    0 Mitglieder finden den Beitrag gut.
  10. #10
    User Pic
    Lord|Schirmer Administrator
    Registriert seit
    21.03.2007
    Beitrge
    7.336
    Beitragswertungen
    1132 Beitragspunkte
    Jetzt muss ich mich doch dazu äußern.

    Ich finde es sehr schade etwas öffentlich zu kritisieren und dann eine geeignete Lösung im privaten Bereich anzubieten. Warum erstellst Du nicht für unsere 1.1 Enthusiasten ein Workaround, dann haben alle etwas davon und Du bringst dich mit ein.

    Mittlerweile sollte es bekannt sein, dass einfach keiner mehr da ist der ehrenamtlich in seiner freien Zeit an 1.1 weiter arbeitet. Die wenigen verbliebenen Teammitglieder & Coder bringen ihr Engagement in 2.X ein, was man auch an den Aktivitäten in den letzten Monaten sieht.

    Auch deine subjektive Kritik an 2.X ist sehr einseitig und nur auf optische Aspekte gelegt.
    rules :: doku :: faq :: linkus
    2 Mitglieder finden den Beitrag gut.
  11. #11
    User Pic
    blakedj06 Mitglied
    Registriert seit
    07.08.2008
    Beitrge
    202
    Beitragswertungen
    30 Beitragspunkte
    Ja ganz einfach weil Ilch 1.1 tot ist. Man liest es in jedem Thread.

    - Update zu Ilch 2.0

    - Ilch 1.1 out of source ....

    - zu alt wird nicht unterstützt usw..

    Ich möchte nicht derjenige sein der Ilch 1.1 hier alleine weiterführt.

    Ihr wollt kein Ilch 1.1 mehr dann wird es auch hier von meiner Seite keinen Workaround geben. Deswegen nur per PN.

    Vielleicht sollte man auch die Downloads,Module sowie Designs von der Seite zu Ilch 1.1 entfernen wenn es doch so unsecure und out of source sein soll.

    Es ist nur schade alte bekannte Ilch-Seiten wie von DAK oder BimmelBommel Clan mit dem Spruch "geht nicht mehr installiere ilch 2.0" im Regen stehen zu lassen.

    Ilch 2.0 ist meilenweit davon entfernt Ilch 1.1 zu sein. Ich empfehle jeden Wordpress oder WBBportal als Ilch 2.0. Und die bieten dann auch wirklich mehr.

    Ich kann halt keine Daseinsberechtigung von Ilch 2.0 finden. Scheint wohl nur nen Hobby zu sein. ^^
    0 Mitglieder finden den Beitrag gut.
  12. #12
    User Pic
    blakedj06 Mitglied
    Registriert seit
    07.08.2008
    Beitrge
    202
    Beitragswertungen
    30 Beitragspunkte
    PS: Es ist eben von mir so gemeint.
    Das es für Euch wohl ein Leichtes wäre offiziell Ilch 1.1 php7 kompatibel zu machen wenn Ihr es schon noch anbietet.

    Aber das wird mit Absicht zu Gunsten Ilch 2.0 nicht gemacht. Und die wenigsten User die sich dann die Frage stellen "Hmm Ilch 1.1 zu alt aber mein Hoster unterstützt kein php 5 mehr dann muss ich wohl zu ilch 2.0" haben keine Ahnung das es da draußen weit aus bessere kostenlose Systeme gibt die den Weg den Ilch 2.0 gerade geht schon lange gegangen sind und somit weitausbessere Alternativen wären als Ilch 2.0 selber.
    0 Mitglieder finden den Beitrag gut.
  13. #13
    User Pic
    Outi77 Mitglied
    Registriert seit
    31.03.2013
    Beitrge
    1.233
    Beitragswertungen
    131 Beitragspunkte
    Man kann das ja sehen, wie man will.
    Für mich als Nutzer der 1.1-Version ist es schade, dass ich irgendwann entweder gezwungen bin,
    die Version selber auf php7 anzupassen oder eben auf ein anderes CMS umzusteigen. Es will halt nicht jedermann das neue ilch2.x, eben weil man sich da in eine völlig andere Art des Programmierens einarbeiten muss. Und ehrlich gesagt, wer tut das gern freiwillig, wenn er in der 1.1-er fast alles selber machen kann? Ist schwierig, wir von LE-Graphics nutzen gern die 1.1 und hoffen, dass unserer Hoster nicht sehr blad nur noch php7 unterstützt.
    Die richtige Formulierung eines Problems ist nicht selten bereits die halbe Lösung.
    »Albert Einstein«
    0 Mitglieder finden den Beitrag gut.
  14. #14
    User Pic
    Lord|Schirmer Administrator
    Registriert seit
    21.03.2007
    Beitrge
    7.336
    Beitragswertungen
    1132 Beitragspunkte
    @blakedj06

    Da wie erwartet keine öffentliche Unterstützung und Hilfestellung von Dir erfolgt, bitte ich zukünftig auf die destruktiven Kommentare und Verweise zu verzichten. Auch die Aufstellung von Thesen, ohne Belege auf Basis von Hintergrundinformationen, helfen hier nicht weiter.

    Übrigens die Aussage Scheint wohl nur nen Hobby zu sein. ist völlig richtig. Bisher wurde noch kein Team-Mitglied für seine Freizeitopferung entlohnt.

    Jeder der nur ein bisschen Ahnung von CMS Programmierung hat weiss die Vor- und Nachteile der beiden Version zu erkennen. Natürlich ist es Schade das 1.1P nicht weiterentwickelt wurde (finde ich auch), aber es fehlte hier an Unterstützung und dein Auftreten ist da ein Beispiel.
    rules :: doku :: faq :: linkus
    4 Mitglieder finden den Beitrag gut.
  15. #15
    User Pic
    blakedj06 Mitglied
    Registriert seit
    07.08.2008
    Beitrge
    202
    Beitragswertungen
    30 Beitragspunkte
    Ach ja da haben wir es mal schnell abgetan.

    Gut macht Ihr mal weiter hier.

    Abschließend bleibt nur zu sagen, schade aber Ilch so wie manche es kennen und schätzen gelernt haben existiert nicht mehr!

    Wer es nicht alleine hinbekommt sein ALTES Ilch für PHP 7 lauffähig zu bekommen kann sich bei mir auf meiner Comseite oder dort per Kontakt an mich wenden. Ich helfe gern.

    Aber eben nicht hier denn das hier ist für mich nicht mehr die offizielle Anlaufstelle für das Ilch so wie wir es kennen!

    In diesem Sinne bye bye
    0 Mitglieder finden den Beitrag gut.
  16. #16
    User Pic
    Siggi Entwickler
    Registriert seit
    08.02.2007
    Beitrge
    6.441
    Beitragswertungen
    308 Beitragspunkte
    1.1q sollte soweit ich weiß PHP7 fähig sein durch mysqli dies wurde aber nie als fertige Version veröffentlicht und wie schon erwähnt gibt es dafür keine Entwickler mehr.
    github.com/IlchCMS/Ilch-1.1/tree/1.1q
    Wie poste ich falsch?
    Fahrschulplaner.info digitialisiert Fahrstunden Ihrer Farhschule
    0 Mitglieder finden den Beitrag gut.
  17. #17
    User Pic
    magicmarkus Mitglied
    Registriert seit
    10.02.2014
    Beitrge
    255
    Beitragswertungen
    9 Beitragspunkte
    ZitatZitat geschrieben von blakedj06
    PS: Es ist eben von mir so gemeint.
    Das es für Euch wohl ein Leichtes wäre offiziell Ilch 1.1 php7 kompatibel zu machen wenn Ihr es schon noch anbietet.

    Aber das wird mit Absicht zu Gunsten Ilch 2.0 nicht gemacht. Und die wenigsten User die sich dann die Frage stellen "Hmm Ilch 1.1 zu alt aber mein Hoster unterstützt kein php 5 mehr dann muss ich wohl zu ilch 2.0" haben keine Ahnung das es da draußen weit aus bessere kostenlose Systeme gibt die den Weg den Ilch 2.0 gerade geht schon lange gegangen sind und somit weitausbessere Alternativen wären als Ilch 2.0 selber.


    Stop?!?! Deine Herangehensweise ist hier mal echt FAIL.

    Alternative zu ILCH 2.x?? Wohl kaum. und das noch als freies CMS, eher unwahrscheinlich!!!!
    Überleg einfach was du von dir gibst.

    Denn alle die mit dem Ilch Projekt zu tun haben, machen dies freiwillig und kostenlos.
    0 Mitglieder finden den Beitrag gut.
  18. #18
    User Pic
    Slipi Mitglied
    Registriert seit
    19.01.2018
    Beitrge
    168
    Beitragswertungen
    11 Beitragspunkte
    ZitatZitat geschrieben von blakedj06


    Wer es nicht alleine hinbekommt sein ALTES Ilch für PHP 7 lauffähig zu bekommen kann sich bei mir auf meiner Comseite oder dort per Kontakt an mich wenden. Ich helfe gern.

    Aber eben nicht hier denn das hier ist für mich nicht mehr die offizielle Anlaufstelle für das Ilch so wie wir es kennen!

    In diesem Sinne bye bye


    Tschüß und wegen deiner angebotene Hilfe, unterstütz doch Ilch mit deinem Vorschlag, damit man es Downloaden kann, oder ist es ein billiger Trick um Geld zu machen? um die likes auf deiner Seite zu erhöhen?

    Sry, für mich bist du durch deine Aktion NICHT Vertrauenswürdig, daher zur deiner Hilfe "No Way".

    ps: Wer Kritik übt, muss Kritik vertragen.

    Slipi
    Header,Banner,Playersheets, Layouts uvm. www.sd-sdesign.at
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Fehlersuche und Probleme

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten