ilch Forum » Ilch Clan 1.1 » Allgemein » Ist ilch 1.1 für PHP 7 rdy?

Geschlossen
  1. #1
    User Pic
    Ahrtas Moderator
    Registriert seit
    17.12.2007
    Beiträge
    2.340
    Beitragswertungen
    209 Beitragspunkte
    Wie der Titel schon fragt.

    Ist die ilch Version 1.1 für PHP7 bereit?

    Mein Anbieter hat mir empfohlen auf PHP 7 umzusteigen, also würde ich gerne wissen was mich erwartet. lächeln

    Ist jemand bereits umgestiegen bzw. hat ilch auf einer höheren PHP Version als 5.x installiert / am laufen?


    Gruß Ahrtas


    verwendete ilch Version: 1.1 P


    Zuletzt modifiziert von Ahrtas am 16.12.2017 - 21:34:47
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    blackcoder Entwickler
    Registriert seit
    22.05.2014
    Beiträge
    1.410
    Beitragswertungen
    216 Beitragspunkte
    Bei 1.1Q wurde anscheinend darauf hingearbeitet, aber ist noch nicht fertig. Jedenfalls hat ihr aktuell jemand Probleme gehabt mit PHP 7 und Ilch 1.1Q.

    www.ilch.de/forum-showposts-53554.html
    Bitte Fragen zu Ilch im Forum stellen. Kein Support per PN.
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    Maretz Hall Of Fame
    Registriert seit
    28.02.2009
    Beiträge
    740
    Beitragswertungen
    73 Beitragspunkte
    Ich habe bereits seit langen auf php7 umgestellt. Allerdings gab es recht viele Fehler mit BBcode 2.0 .
    Ok, bei meinen Demoseiten konnte ich diese entfernen, wobei dabei auch die Nutzung von BBCode hinfällig wurde.
    Genauer habe ich mich allerdings nicht damit befasst.

    Mfg Maretz
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    blakedj06 gelöschter User
    Du bist doch auch Programmierer dann solltest Du das doch eigentlich am besten wissen. Aber im Endeffekt reicht es Mysql mit Mysqli zu ersetzen und ggf. im BBcode Änderungen vorzunehmen.
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    Ahrtas Moderator
    Registriert seit
    17.12.2007
    Beiträge
    2.340
    Beitragswertungen
    209 Beitragspunkte
    Ja "kleinere / einfachere" Module kann ich schreiben - das wars, mein Schwerpunkt liegt im Design. zwinker

    Sonst würde ich es selbst erledigen und mich nicht melden? lächeln
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    blakedj06 gelöschter User
    ZitatZitat geschrieben von Ahrtas
    Sonst würde ich es selbst erledigen und mich nicht melden? lächeln


    Nö wieso vielleicht bist du ein fauler Programmierer lachen

    Spaß nun weißte ja bescheid. ^^
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    dastiii Mitglied
    Registriert seit
    27.12.2005
    Beiträge
    2.351
    Beitragswertungen
    84 Beitragspunkte
    Setz doch am besten mal nen Testserver auf (zur Not als VM) und probiere es aus.

    Wenn dann Fehlermeldungen kommen, wo du z.B. nicht weiter weisst, kannst du sie ja auch posten und man kann dir einfacher helfen.

    Offiziell gibt es jedenfalls auch bei 1.1 Q noch keine garantierte PHP 7 Unterstuetzung.


    siehe www.ilch.de/index.php?forum-showposts-53554-p1#387556

    Zuletzt modifiziert von dastiii am 25.10.2016 - 17:01:58
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    bigsavo Mitglied
    Registriert seit
    30.05.2013
    Beiträge
    26
    Beitragswertungen
    0 Beitragspunkte
    ZitatZitat geschrieben von Ahrtas
    Wie der Titel schon fragt.

    Ist die ilch Version 1.1 für PHP7 bereit?

    Mein Anbieter hat mir empfohlen auf PHP 7 umzusteigen, also würde ich gerne wissen was mich erwartet. lächeln

    Ist jemand bereits umgestiegen bzw. hat ilch auf einer höheren PHP Version als 5.x installiert / am laufen?


    Gruß Ahrtas


    verwendete ilch Version: 1.1 P


    Zuletzt modifiziert von Ahrtas am 16.12.2017 - 21:34:47


    Hi Also bei mir läuft aktuell die version Ilch 1.1Q unter php version 7.3.8.
    Kassen Modul forum erweiterung sowpe Profil erweiterung und ein paar weitere module laufen glanzlos ohne Probleme.

    Was ich gemerkt habe ist das die Install.php von Ilch 1.1q nicht läuft sowie im DOwnload ordner die config.php fehlt. Aber die Update.php datei funktioniert. Also alles Überschreiben update und fielleicht das eine oder andere Modul anpassen.

    Meine Homepage lautet just1life.de

    Darfst dich gerne überzeugen
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurück zu Allgemein

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten