ilch Forum » Ilch CMS 2.X » Installation und Upgrades » Install mit Nginx

Geschlossen
  1. #1
    User Pic
    Dr.Galvany Mitglied
    Registriert seit
    01.01.2004
    Beitrge
    75
    Beitragswertungen
    0 Beitragspunkte
    hallo zusammen, ich wollte mal die version 2 testen und habe einen webserver mit Nginx am laufen.
    bei der installation wird alles sauber aufgerufen, jedoch wenn ich den ersten schritt ausführe wird die zweite seite "Lizenz" nicht geladen.

    habe das ganze mit einen "apache" versucht und da geht es ohne probleme.

    gibt es mit "nginx" schon erfahrungen?

    ich hänge mal meine config mit an, die habe ich auch schon auf ein minimum abgespeckt zum testen.

    /etc/nginx/sites-available/default:
    server {
        listen 80;
        listen [::]:80;
        server_name 192.168.178.201;
    
            root /var/www/master;
            index index.php;
     
    	location / {
    		try_files $uri $uri/ =404;
    	}
     
    	location ~ \.php$ {
    		try_files $uri =404;
    		fastcgi_split_path_info ^(.+\.php)(/.+)$;
    		fastcgi_pass unix:/var/run/php5-fpm.sock;
    		fastcgi_index index.php;
    		include fastcgi_params;
    	}
     
    	location ~ /\.ht {
    		deny all;
    	}
    }



    Danke schon mal Micha


    verwendete ilch Version: 2.0 (alpha)
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    OlivierS Mitglied
    Registriert seit
    08.09.2019
    Beitrge
    2
    Beitragswertungen
    0 Beitragspunkte
    ZitatZitat geschrieben von Dr.Galvany
    hallo zusammen, ich wollte mal die version 2 testen und habe einen webserver mit Nginx am laufen.
    bei der installation wird usps tracking alles sauber aufgerufen, jedoch wenn ich den ersten schritt ausführe wird die zweite seite "Lizenz" nicht geladen.

    habe das ganze mit einen "apache" versucht und da geht es ohne probleme.

    gibt es mit "nginx" schon erfahrungen?

    ich hänge mal meine config mit an, die habe ich auch schon auf ein minimum abgespeckt zum testen.

    /etc/nginx/sites-available/default:
    server {
        listen 80;
        listen [::]:80;
        server_name 192.168.178.201;
    
            root /var/www/master;
            index index.php;
     
    	location / {
    		try_files $uri $uri/ =404;
    	}
     
    	location ~ \.php$ {
    		try_files $uri =404;
    		fastcgi_split_path_info ^(.+\.php)(/.+)$;
    		fastcgi_pass unix:/var/run/php5-fpm.sock;
    		fastcgi_index index.php;
    		include fastcgi_params;
    	}
     
    	location ~ /\.ht {
    		deny all;
    	}
    }



    Danke schon mal Micha


    verwendete ilch Version: 2.0 (alpha)

    Ich suche auch nach einer Lösung. Hilfe wird geschätzt.


    Danke im Voraus
    Grüße
    Oliver


    Zuletzt modifiziert von OlivierS am 15.09.2019 - 21:18:58
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    Mairu Coder
    Registriert seit
    16.06.2006
    Beitrge
    15.292
    Beitragswertungen
    374 Beitragspunkte
    Habe es nicht getestet, aber es muss das URL Umschreibung, die über .htaccess beim Apache mit mod_rewrite durchgeführt wird für ngingx konfiguriert werden.

    winginx.com/en/htaccess hat folgendes Ergebnis für die verwendeten mod_rewrite Regeln hervorgebracht.
    location / {
      if (!-e $request_filename){
        rewrite ^(.*)$ /index.php break;
      }
    }
    Und auch immer mal ein Blick auf die FAQ werfen. | Mairus Ilchseite
    1 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Installation und Upgrades

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten