ilch Forum » Ilch Clan 1.1 » Module und Modifikationen » Sammelthread: ilchBB-Forum

Geschlossen
  1. #241
    User Pic
    opium_nrw Mitglied
    Registriert seit
    16.06.2012
    Beitrge
    7
    Beitragswertungen
    0 Beitragspunkte
    Gott, ich bin echt blind ... sry Vielen Dank!

    EDIT:
    Jetzt funktionierts soweit, css muss ich die Woche noch anpassen.

    Die Userpics (~250x170px) ragen jetzt über den Forenrand hinaus, kann ich diese irgendwie in das Fenster einpassen?

    Oder wie im alten Forum die Details auf der linken Seite anzeigen lassen?


    Zuletzt modifiziert von opium_nrw am 17.06.2012 - 23:35:44
    0 Mitglieder finden den Beitrag gut.
  2. #242
    User Pic
    opium_nrw Mitglied
    Registriert seit
    16.06.2012
    Beitrge
    7
    Beitragswertungen
    0 Beitragspunkte
    Ich push mal, gab ja seit 9 Tagen keine Antwort lcheln

    @Mod/Admin bitte danach mein Post lsöchen Danke!
    0 Mitglieder finden den Beitrag gut.
  3. #243
    User Pic
    Rock@wulf Hall Of Fame
    Registriert seit
    03.06.2004
    Beitrge
    3.282
    Beitragswertungen
    239 Beitragspunkte
    Hm um deine Frage zu beantworten,

    Ja du kannst es bearbeiten

    und

    Ja man kann es auf der linken Seite anzeigen lassen.
    Meine Postings repräsentieren meine Meinung wenn nicht anders gekennzeichnet.
    MFG Rock@wulf
    0 Mitglieder finden den Beitrag gut.
  4. #244
    User Pic
    opium_nrw Mitglied
    Registriert seit
    16.06.2012
    Beitrge
    7
    Beitragswertungen
    0 Beitragspunkte
    erledigt


    Zuletzt modifiziert von opium_nrw am 29.06.2012 - 19:57:21
    0 Mitglieder finden den Beitrag gut.
  5. #245
    User Pic
    ---Doc--- Mitglied
    Registriert seit
    05.08.2011
    Beitrge
    218
    Beitragswertungen
    4 Beitragspunkte
    Wird eigentlich noch eine Version 3.2 mit Dateiupload für ilch 1.1 kommen?
    Ich meine irgendwo eine negative Antwort auf diese Frage gelesen zu haben, finde sie aber nicht mehr.

    Ebenso verhält es sich mit der zweiten Frage:
    Subkategorien sind auch mit ilchbb nicht möglich, ist dies korrekt?
    0 Mitglieder finden den Beitrag gut.
  6. #246
    User Pic
    KoernerWS gelschter User
    1. Nein, wird nicht mehr kommen. Dafür aber in der Version für Ilch 2.0
    2. Nein, diese sind auch dort nicht möglich.
    0 Mitglieder finden den Beitrag gut.
  7. #247
    User Pic
    ---Doc--- Mitglied
    Registriert seit
    05.08.2011
    Beitrge
    218
    Beitragswertungen
    4 Beitragspunkte
    Besten Dank.
    0 Mitglieder finden den Beitrag gut.
  8. #248
    User Pic
    W3hrWolf Mitglied
    Registriert seit
    02.04.2005
    Beitrge
    58
    Beitragswertungen
    0 Beitragspunkte
    Hi,
    gibst irgentwo eine Übersicht welche Farben wo definiert werden im IlchBB? Bekomme das Design nicht an einen dunklen Style angepasst, grad auch die Themenüberschriften in der Foren und Themenübersicht.

    Gruss
    0 Mitglieder finden den Beitrag gut.
  9. #249
    User Pic
    Uni Mitglied
    Registriert seit
    21.12.2011
    Beitrge
    6
    Beitragswertungen
    0 Beitragspunkte
    Hallo Leute!!!!

    Ich habe den neuen Forenmod installiert hat auch alles soweit geklappt.Aber wenn ich eine News schrei bzw eintragen will kommt folgender Fehler:

    ZitatZitat
    MySQL Error:
    1064 : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 2
    in Query:
    INSERT INTO `ic2_news` (news_title,user_id,news_time,news_recht,news_groups,news_kat,news_text,html,`show`,archiv,endtime) VALUES ('q ea4cqv t 4 a43',2,FROM_UNIXTIME(1348424442),1023,0,'Allgemein','q v54qzb64','',1,2,)

    Debug backtrace:
    @ mysql.php:32 -- debug_bt()
    @ mysql.php:50 -- db_check_error(...)
    @ news.php:191 -- db_query(...)
    @ admin.php:36 -- require_once(...)


    Ich habe keinen Plan davon und ich hoffe hier kann mir einer helfen!!!

    Danke im vorraus Uni
    0 Mitglieder finden den Beitrag gut.
  10. #250
    User Pic
    KoernerWS gelschter User
    Das hat reichlich wenig mit dem Foren-Mod zu tun zwinker
    0 Mitglieder finden den Beitrag gut.
  11. #251
    User Pic
    lisa Mitglied
    Registriert seit
    03.10.2012
    Beitrge
    4
    Beitragswertungen
    0 Beitragspunkte
    Hi ihr´s, ich wollte mir ein Kleines Projekt aufbauen mit Ilch...
    Zur Zeit ist alles bei mir auf den PC, da ich erst mal mit Xampp Teste.

    Jetzt habe ich mir den ilchBB-Forum Mod drauf gemacht was auch gut laufen tut...

    Außer eine Sache wo ich vielleicht hier Hilfe bekommen kann/könnte.

    Und zwar geht es um die Unterkategorien des Forums.
    Wenn man eine Unterkategorie erstellt und eine normale Kategorie funktioniert alles Prima.

    Aber sobald man nur Unterkategorien macht werden sie nicht angezeigt genauso wenig wie der Titel der Kategorien.

    1.
    Zb. So wird Front Forum angezeigt, da in WebSite Kategorien drin sind.

    - WebSite Templates (Test1,Test2)
    - Front Forum ( Cat1, Cat2)

    2.
    Aber so wird Front Forum nicht Angezeigt da in WebSite Templates keine Kategorien vorhanden sind.

    - WebSite Templates ()
    - Front Forum ( Cat1, Cat2)

    Und genau das bräuchte ich so das man Unterkategorien machen kann ohne das zb. in WebSite Templates was drin sein muss.

    Wäre dankbar wenn da jemand Helfen könnte.

    Mit Freundlichen Grüßen
    Lisa
    0 Mitglieder finden den Beitrag gut.
  12. #252
    User Pic
    lisa Mitglied
    Registriert seit
    03.10.2012
    Beitrge
    4
    Beitragswertungen
    0 Beitragspunkte
    Sehr schade das man hier keine Antwort bekommt!!!
    0 Mitglieder finden den Beitrag gut.
  13. #253
    User Pic
    CaptainJack Mitglied
    Registriert seit
    11.02.2010
    Beitrge
    519
    Beitragswertungen
    2 Beitragspunkte
    Moin,

    ich bin doch wieder vom ilch foru aufs BB umgestiegen :-)

    Ich würde in der Statistik gerne einen eigene Background geben. Direkt daneben sollen dann die Moderatoren stehen.

    Hier mal mein Background.

    Kann mir einer veraten wie ich das am besten hinbekommen kann?

    whv-kicker.de/include/images/forum/ansicht/statistik_bg.png

    gesperrtes Bild

    Die weissen Felder sind für die jeweiliegn Icons.

    Wo müsste ich in der showforum.html welchen Code einfügen?



    Gruß
    0 Mitglieder finden den Beitrag gut.
  14. #254
    User Pic
    CaptainJack Mitglied
    Registriert seit
    11.02.2010
    Beitrge
    519
    Beitragswertungen
    2 Beitragspunkte
    Hat echt niemand eine Idee wie man das Bild als Background hinter den jeweiligen Infos anzeigen lassen kann?


    Greetz
    0 Mitglieder finden den Beitrag gut.
  15. #255
    User Pic
    CaptainJack Mitglied
    Registriert seit
    11.02.2010
    Beitrge
    519
    Beitragswertungen
    2 Beitragspunkte
    Habs geschafft mit dem BG.

    Mich würde nur noch interessieren wo man die Infos herbekommt die man unten in eine Statistik einbauen kann wie z.B. User geade online usw. bzw. was da alles möglich ist mit einzubauen.

    Gruß
    0 Mitglieder finden den Beitrag gut.
  16. #256
    User Pic
    minimal_warrior Mitglied
    Registriert seit
    08.04.2011
    Beitrge
    146
    Beitragswertungen
    0 Beitragspunkte
    Habe auch den IlchBBForum Mod installiert.
    Funktioniert soweit auch alles zwinker Super Arbeit.


    Jedoch habe ich noch einige Sachen die ich nicht geändert krieg.

    - Forum Background von weiss in Grau wie in Loginbox
    - Sag Danke Modul (verwendet alten bbcode)
    - Merklisten Modul
    - komplettes BBCode in schnellantwort
    cTs Gaming Community
    Interesse an einer Community mitzuwirken?
    Skype: Minimal_Warrior
    0 Mitglieder finden den Beitrag gut.
  17. #257
    User Pic
    Jens238 Mitglied
    Registriert seit
    20.03.2013
    Beitrge
    404
    Beitragswertungen
    44 Beitragspunkte
    Hier mal das Stückchen Code aus der showpost.htm wo der Code von der Merkliste rein kommt. Hoffe das reicht Dir zwinker


    {EXPLODE}
    <div class="forum ui-corner-all ilchbb_{class}">
        <div class="post message">
            <div class="text">
                <a name="{id}"></a>
                <span style="float: left;" class="smallfont">
                    <a href="index.php?forum-showposts-{TID}-p{page}#{id}" title="{STATUS_TITLE}">
                        <img src="include/images/ilchbb_forum/icon_post_target{STATUS_SRC}.png" border="0" />
                    </a>
                    <a href="?merkliste-{tid}-{id}-{page}" id="{id}" title="Merkliste"><img src="include/images/icons/post_remember.png" alt="Merkliste" width="9" height="9" border="0" title="Merkliste"/></a>
                    {date}
                </span>
                <span style="float: right;">
                    {report}
                    {delete}
                    {change}
                    {quote}
                </span>
                <br style="clear: both;" />
                <p>{txt}</p>
                <p>{sig}</p>
            </div>
        </div>
    0 Mitglieder finden den Beitrag gut.
  18. #258
    User Pic
    Angelina Mitglied
    Registriert seit
    06.11.2011
    Beitrge
    127
    Beitragswertungen
    20 Beitragspunkte
    Die Farbe, müßtest du in der Datei
    include/includes/ilchbb_forum/css/ilchbb_forum.standard.css
    ändern können..
    Einfach mal testen.
    Ein Danke Modul, ist doch im Forum Modul dabei??
    In der Datei
    include/templates/ilchbb_forum/showpost.htm
    Nach
    <form id="qpost_forum" action="index.php?forum-newpost-{tid}" method="POST" name="form" style="display:none;">

    Das einfügen
     	<div>
            <!-- BB Code START -->
            {__BBCodeButtons__}
            <!-- BB Code ENDE -->
            </div>
    www,angelina.de
    Ein Kavalier ist ein Mann, der sich den Geburtstag einer Frau merkt und ihr alter vergisst.
    0 Mitglieder finden den Beitrag gut.
  19. #259
    User Pic
    pringelmaus Mitglied
    Registriert seit
    27.04.2013
    Beitrge
    12
    Beitragswertungen
    0 Beitragspunkte
    Hallo,
    klinke mich hier mal mit ein ^^
    ich versuche verzweifelt das Forum Vote (mairu.ilch.de/index.php?downloads-show-35) mit dem ilchBB Forum zum laufen zu bekommen.
    Schalte ich das ilchBB Forum aus dann funzt das voten .
    Ich habe die Änderungen aus der readme html auch auf das ilchbb_forum angewendet , mit dem Ergebnis das ich ein vote anlegen kann , aber wenn ich dann absimmen möchte kommt nur eine weiße Seite und fertigt .Es werden keine Abstimmungen angezeigt.Kann mir jemand helfen und sagen wo der Hund begraben liegt (für Anfänger bitte ^^)
    Vielen dank für eure Hilfe im voraus
    0 Mitglieder finden den Beitrag gut.
  20. #260
    User Pic
    mwbvb09 Mitglied
    Registriert seit
    24.09.2007
    Beitrge
    228
    Beitragswertungen
    0 Beitragspunkte
    Kann mir jemand das Forum auf mein Design Farblich anpassen, habe viel herumprobiert, kriege es aber nicht nach meinen Wünschen hin.
    Wäre sehr nett.

    Gruß

    mwbvb09
    0 Mitglieder finden den Beitrag gut.
  21. #261
    User Pic
    SoX Mitglied
    Registriert seit
    21.03.2012
    Beitrge
    376
    Beitragswertungen
    6 Beitragspunkte
    ZitatZitat geschrieben von mwbvb09

    Kann mir jemand das Forum auf mein Design Farblich anpassen, habe viel herumprobiert, kriege es aber nicht nach meinen Wünschen hin.
    Wäre sehr nett.

    Gruß

    mwbvb09


    Wenn du Grafik wünsche hast frag mal beim CapFX Team nach lcheln.

    www.CapfX.de
    0 Mitglieder finden den Beitrag gut.
  22. #262
    User Pic
    NikonBD Mitglied
    Registriert seit
    27.05.2013
    Beitrge
    2
    Beitragswertungen
    0 Beitragspunkte
    Hallo an alle,

    ich habe gerade auf unserer Neuen Team Seite den BB Foren mod installiert, habe davor auch den BB code mod installiert, das Forum läuft soweit einwand frei.

    Jetzt habe ich aber das Problem das irgendwas mit der user.php anscheinend nicht mehr stimmt, bekomme jetzt diese Fehlermeldung angezeigt:

    externer Link

    hier mal das was mir angezeigt wird:

    MySQL Error:
    1054 : Unknown column 'zeigen' in 'field list'
    in Query:
    SELECT zeigen FROM ic1_grundrechte WHERE id = -9

    Debug backtrace:
    @ mysql.php:46 -- debug_bt()
    @ mysql.php:64 -- db_check_error(...)
    @ memb_list.php:14 -- db_query(...)
    @ user.php:24 -- require_once(...)
    @ index.php:18 -- require_once(...)



    kann mir jemand eine Anleitung geben wie ich das Problem behoben bekommen oder einen Link wo ich soetwas finde, suche jetzt schon ne ganze Weile, danke für eure hilfe.

    MFG

    Nikon


    Zuletzt modifiziert von NikonBD am 04.06.2013 - 14:46:38
    0 Mitglieder finden den Beitrag gut.
  23. #263
    User Pic
    NikonBD Mitglied
    Registriert seit
    27.05.2013
    Beitrge
    2
    Beitragswertungen
    0 Beitragspunkte
    es scheint etwas mit den grundrechten zu tun zu haben, kann es sein das ich da irdenwas ändern muss?
    0 Mitglieder finden den Beitrag gut.
  24. #264
    User Pic
    Pawhi Mitglied
    Registriert seit
    17.06.2013
    Beitrge
    1
    Beitragswertungen
    0 Beitragspunkte
    ZitatZitat geschrieben von NikonBD

    Hallo an alle,

    ich habe gerade auf unserer Neuen Team Seite den BB Foren mod installiert, habe davor auch den BB code mod installiert, das Forum läuft soweit einwand frei.

    Jetzt habe ich aber das Problem das irgendwas mit der user.php anscheinend nicht mehr stimmt, bekomme jetzt diese Fehlermeldung angezeigt:

    externer Link

    hier mal das was mir angezeigt wird:

    MySQL Error:
    1054 : Unknown column 'zeigen' in 'field list'
    in Query:
    SELECT zeigen FROM ic1_grundrechte WHERE id = -9

    Debug backtrace:
    @ mysql.php:46 -- debug_bt()
    @ mysql.php:64 -- db_check_error(...)
    @ memb_list.php:14 -- db_query(...)
    @ user.php:24 -- require_once(...)
    @ index.php:18 -- require_once(...)



    kann mir jemand eine Anleitung geben wie ich das Problem behoben bekommen oder einen Link wo ich soetwas finde, suche jetzt schon ne ganze Weile, danke für eure hilfe.

    MFG

    Nikon


    Zuletzt modifiziert von NikonBD am 04.06.2013 - 14:46:38



    Also bei mir gibts in der Tabelle prefix_grundrechte nur die Felder 'id' und 'name'.
    Also würde ich mal im Query in der user.php das Wort 'zeigen' in 'name' ändern, dann wird auch der Name bei dem die ID -9 ist genommen und es sollte kein Mysqlerror mehr entstehen.
    0 Mitglieder finden den Beitrag gut.
  25. #265
    User Pic
    Purple Mitglied
    Registriert seit
    20.07.2013
    Beitrge
    8
    Beitragswertungen
    0 Beitragspunkte
    Hallo zusammen,

    eventuell kann mir hier jemand helfen ?

    Ich würden gerne auf unserer Clanseite das Forum anpassen.

    die u.a. Sachen würde ich gerne einbauen.

    -Verantwortliche Moderatoren
    -Foren - Legende
    -Forenkategorie-Grafiken
    -Background für das Forum



    Wünschenswert wäre dieses Forum hier : externer Link

    Meine Showforum.htm :

    <!--
      @name    IlchBB Forum
      @version 3.1
      @author  Florian Koerner
      @link    http://www.koerner-ws.de/
    -->
    
    
    <div style="display:none;">
        <table>
            <tr>
                <td></td>
            </tr>
            {EXPLODE}
        </table>
    </div>
    <div class="forum ui-corner-all">
        <table cellpadding="0" cellspacing="0" class="ilchbb_border" border="0">
            <tr>
                <th colspan="2" width="45%">
                    <a href="index.php?forum-showcat-{cid}" style="color: #FFF;">{cname}</a>
                </th>
                <th width="13%">
                    <center>{_lang_topic}</center>
                </th>
                <th width="13%">
                    <center>{_lang_post}</center>
                </th>
                <th width="29%">
                    {_lang_lastpost}
                </th>
            </tr>
            {EXPLODE}
            <tr>
                <td colspan="5" class="{class}" style="font-weight: bold;">
                    &nbsp; &nbsp;  <a href="index.php?forum-showcat-{cid}">{cname}</a>
                </td>
            </tr>
            {EXPLODE}
            <tr class="{class}">
                <td width="6%">
                    <center><img alt="" src="include/images/ilchbb_forum/{ORD}.gif" title="{TORD}" /></center>
                </td>
                <td class="top" width="39%">
                    <a href="index.php?forum-showtopics-{id}" >{name}</a><br />
                    <span class="smallfont">{besch}</span>
                </td>
                <td class="middle xleft">
                    <div class="center">
                        {topics}
                    </div>
                </td>
                <td class="middle xright">
                    <div class="center" style="border-right-width: 1px;">
                        {posts}
                    </div>
                </td>
                <td class="top smallfont">
                    <a title="{topicl}" href="index.php?forum-showposts-{tid}-p{page}#{pid}">
                        {topic}
                        <img src="include/images/ilchbb_forum/icon_topic_latest.gif" title="Letzter Beitrag" border="0" />
                    </a>
                    <br />
                    {_lang_from}: {erst}
                    <br />
                    am: {datum}
                </td>
            </tr>
            {EXPLODE}
        </table>
    </div>
    
    <table cellpadding="0" cellspacing="0" border="0" width="100%">
        <tr>
            <td width="50%" valign="top">
                <a href="index.php?forum-markallasread">{_lang_markallasread}</a>
            </td>
            <td width="50%" style="text-align: right" valign="top">
                <a href="index.php?forum-augt">{_lang_newtopicssincelastvisit}</a><br />
                <a href="index.php?forum-aubt">{_lang_topicwithnoreply}</a><br />
                <a href="index.php?forum-aeit">{_lang_ownposts}</a>
            </td>
        </tr>
    </table>
    
    <br />
    <br />
    
    <div class="forum ui-corner-all">
        <table cellpadding="0" cellspacing="0" class="ilchbb_border" border="0">
            <tr>
                <th>
                    Statistiken
                </th>
            </tr>
            <tr style="background-color: #333333;">
                <td>
                    <b>{users}</b> {_lang_membershaveritten} <b>{posts}</b> {_lang_postsin} <b>{topics}</b> {_lang_topics}<br />
                    <br />
                    {_lang_it} {istsind} {gesonline} {_lang_guestsonline,ofthem} {useronline} {_if_{useronline}=='1'}{_lang_registredand}{/_endif}{_if_{useronline}!='1'}{_lang_registrededand}{/_endif} {gastonline} {_lang_guests}<br />
                    {userliste}
                    {dayonline}
                </td>
            </tr>
        </table>
    </div>
    {privmsgpopup}


    und unsere Show_forum.php

    <?php 
    #   Copyright by: Manuel
    #   Support: www.ilch.de
    
    /**
     * @name    IlchBB Forum
     * @version 3.1
     * @author  Florian Koerner
     * @link    http://www.koerner-ws.de/
     * @license GNU General Public License
     */
    
    
    defined ('main') or die ( 'no direct access' );
    
    // IlchBB Forum 3.1 :: Loader :: Start
    require_once ('include/contents/ilchbb_forum/ilchbb_loader.php');
    // IlchBB Forum 3.1 :: Loader :: Ende
    
    $title = $allgAr['title'].' :: Forum';
    $hmenu = $extented_forum_menu.'Forum'.$extented_forum_menu_sufix;
    $design = new design ( $title , $hmenu, 1);
    $design->header();
    
    // IlchBB Forum 3.1 :: Extensions :: Start
    $ilchbb_tpl = new tpl('ilchbb_forum/load_extensions');
    $ilchbb_tpl->out(0);
    // IlchBB Forum 3.1 :: Extensions :: End
    
    if ($menu->get(1) == 'markallasread') {
        $ilchBB->deleteNewTopics();
    }
    
    
    $tpl = new tpl ( 'ilchbb_forum/showforum' );
    $tpl->out (0);
    
    $category_array = array();
    $forum_array = array();
    
    $q = "SELECT
      a.id, a.cid, a.name, a.besch,
      a.topics, a.posts, b.name as topic,
      c.id as pid, c.tid, b.rep, c.erst, c.time,
      a.cid, k.name as cname
    FROM prefix_forums a
      LEFT JOIN prefix_forumcats k ON k.id = a.cid
      LEFT JOIN prefix_posts c ON a.last_post_id = c.id
      LEFT JOIN prefix_topics b ON c.tid = b.id
    	
      LEFT JOIN prefix_groupusers vg ON vg.uid = ".$_SESSION['authid']." AND vg.gid = a.view
      LEFT JOIN prefix_groupusers rg ON rg.uid = ".$_SESSION['authid']." AND rg.gid = a.reply
      LEFT JOIN prefix_groupusers sg ON sg.uid = ".$_SESSION['authid']." AND sg.gid = a.start
    	
    WHERE ((".$_SESSION['authright']." <= a.view AND a.view < 1) 
       OR (".$_SESSION['authright']." <= a.reply AND a.reply < 1)
       OR (".$_SESSION['authright']." <= a.start AND a.start < 1)
    	 OR vg.fid IS NOT NULL
    	 OR rg.fid IS NOT NULL
    	 OR sg.fid IS NOT NULL
    	 OR -9 = ".$_SESSION['authright'].")
    	 AND k.cid = 0
    ORDER BY k.pos, a.pos";
    $erg1 = db_query($q);
    $xcid = 0;
    
    while ($r = db_fetch_assoc($erg1) ) {
    
        // IlchBB Forum 3.1 :: Get Forum Status :: Start
        $ord = $ilchBB->checkNewTopics($r['id']);
    
        if ($ord === TRUE) {
            $r['ORD'] = 'forum_unread';
            $r['TORD'] = 'Neue Beitr&auml;ge';
        } else {
            $r['ORD'] = 'forum_read';
            $r['TORD'] = 'Keine neuen Beitr&auml;ge';
        }
        // IlchBB Forum 3.1 :: Get Forum Status :: Ende
        
        $r['topicl'] = $r['topic'];
        $r['topic']  = html_enc_substr($r['topic'],0,23);
        $r['mods']   = getmods($r['id']);
        $r['datum']  = date('d.m.y - H:i', $r['time']);
        $r['page']   = ceil ( ($r['rep']+1)  / $allgAr['Fpanz'] );
        $tpl->set_ar($r);
    
        if ($r['cid'] <> $xcid) {
            $tpl->out(1);
    
            // IlchBB Forum 3.1 :: Set CSS Class :: Start
            $class = 'ilchbb_Cmite';
            // IlchBB Forum 3.1 :: Set CSS Class :: End
    
            //Unterkategorien
            $sql = db_query("SELECT DISTINCT a.name as cname, a.id as cid FROM `prefix_forumcats` a LEFT JOIN `prefix_forums` b ON a.id = b.cid WHERE a.cid = {$r['cid']} AND a.id = b.cid ORDER BY a.pos, a.name");
            while ($ucat = db_fetch_assoc($sql)) {
    
                // IlchBB Forum 3.1 :: Change CSS Class :: Start
                $class = ( $class == 'ilchbb_Cmite' ? 'ilchbb_Cnorm' : 'ilchbb_Cmite' );
                $ucat['class'] = $class;
                // IlchBB Forum 3.1 :: Change CSS Class :: Start
    
                $tpl->set_ar_out($ucat,2);
            }
            //Unterkategorien - Ende
            $xcid = $r['cid'];
        }
    
        // IlchBB Forum 3.1 :: Change CSS Class :: Start
        $class = ( $class == 'ilchbb_Cmite' ? 'ilchbb_Cnorm' : 'ilchbb_Cmite' );
        $r['class'] = $class;
        // IlchBB Forum 3.1 :: Change CSS Class :: Start
    
        $tpl->set_ar_out($r,3);
    }
    
    // IlchBB Forum 3.1 :: Online Today :: Start
    if ($allgAr['ilchbb_forum_dayonline'] == 1) {
        $time = mktime (0,0,0,date("n"),date("j"),date("Y"));
    
        $query = 'SELECT `id`,`name` FROM `prefix_user` WHERE llogin > '.$time;
        $query = db_query($query);
    
        $cache = '';
    
        while ($row = db_fetch_assoc($query)) {
            if (!empty($cache)) $cache .= ', ';
            $cache .= '<a href="index.php?user-details-'.$row['id'].'">'.$row['name'].'</a>';
        }
    
        $tpl->set('dayonline','<br /><br />Heute waren bereits online:<br />'.$cache);
    } else {
        $tpl->set('dayonline','');
    }
    // IlchBB Forum 3.1 :: Online Today :: End
    
    # statistic #
    $ges_online_user = ges_online();
    $stats_array = array (
            'privmsgpopup' => check_for_pm_popup (),
            'topics' => db_result(db_query("SELECT COUNT(ID) FROM `prefix_topics`"),0),
            'posts' => db_result(db_query("SELECT COUNT(ID) FROM `prefix_posts`"),0),
            'users' => db_result(db_query("SELECT COUNT(ID) FROM `prefix_user`"),0),
            'istsind' => ( $ges_online_user > 1 ? 'sind' : 'ist' ),
            'gesonline' => $ges_online_user,
            'gastonline' => ges_gast_online(),
            'useronline' => ges_user_online(),
            'userliste' => user_online_liste()
    );
    
    $tpl->set_ar_out($stats_array,4);
    
    // IlchBB Forum 3.1 :: Copyright :: Start
    $ilchbb_tpl->out(1);
    // IlchBB Forum 3.1 :: Copryright :: End
    
    $design->footer();
    ?>


    Danke schön im vorraus.

    Gruß
    Purple


    Zuletzt modifiziert von Purple am 20.07.2013 - 11:19:11
    Trag dich in unsere Top-Liste ein : externer Link
    0 Mitglieder finden den Beitrag gut.
  26. #266
    User Pic
    mabu78 Mitglied
    Registriert seit
    19.07.2013
    Beitrge
    38
    Beitragswertungen
    4 Beitragspunkte
    Es gibt eine Problem mit SAFARI.
    Die dialogboxen für die List funktion z.b. lasen sich in Safari nicht mehr schliessen!
    Somit stürzt er dann letzendlich ab.....

    jemand ne idee ?
    selten diese Leere!
    0 Mitglieder finden den Beitrag gut.
  27. #267
    User Pic
    z3us Mitglied
    Registriert seit
    14.09.2012
    Beitrge
    114
    Beitragswertungen
    10 Beitragspunkte
    Hallo zusammen,

    Wir haben auch das BB 3.1 Forum drauf.
    Was uns aufgefallen ist, das die Schnellantwort mit dem Ilch script 1.1P
    nicht mehr funktioniert.

    Klickt man die Schnellantwort an, lässt diese sich auch öffnen.
    Man kann auch etwas reinschreiben.
    Klickt man auf "Absenden", gelangt man in den Normalen Antworten modus.
    Klickt man dort auf "Absenden", funktioniert dieses.

    Verwendete Ilch version 1.1P

    Weis jemand Rat?

    MFG


    Zuletzt modifiziert von z3us am 12.08.2013 - 09:57:56
    Meine Clanpage: Funny Gamers
    0 Mitglieder finden den Beitrag gut.
  28. #268
    User Pic
    RedSunset Mitglied
    Registriert seit
    29.05.2009
    Beitrge
    173
    Beitragswertungen
    4 Beitragspunkte
    ZitatZitat geschrieben von z3us

    Hallo zusammen,

    Wir haben auch das BB 3.1 Forum drauf.
    Was uns aufgefallen ist, das die Schnellantwort mit dem Ilch script 1.1P
    nicht mehr funktioniert.

    Klickt man die Schnellantwort an, lässt diese sich auch öffnen.
    Man kann auch etwas reinschreiben.
    Klickt man auf "Absenden", gelangt man in den Normalen Antworten modus.
    Klickt man dort auf "Absenden", funktioniert dieses.

    Verwendete Ilch version 1.1P

    Weis jemand Rat?

    MFG


    Zuletzt modifiziert von z3us am 12.08.2013 - 09:57:56


    Schau mal in deine new_post.php

    da findest du folgende Zeile:

    if (($_SESSION['klicktime'] + 15) > $dppk_time OR empty($txt) OR !empty($_POST['priview']) OR (empty($_POST['Gname']) AND !loggedin()) OR !chk_antispam ('newpost')) {

    ersetzte diese mit:
    if (($_SESSION['klicktime'] + 15) > $dppk_time OR empty($txt) OR !empty($_POST['priview']) OR (empty($_POST['Gname']) AND !loggedin())) {

    (also das antispam entfernen)
    1 Mitglieder finden den Beitrag gut.
  29. #269
    User Pic
    Trash Mitglied
    Registriert seit
    14.06.2013
    Beitrge
    15
    Beitragswertungen
    0 Beitragspunkte
    Hallo RedSunset,

    wir hatten das Problem bei uns auch.
    Deine Lösung funktioniert einwandfrei, vielen Dank.

    MfG Trash
    0 Mitglieder finden den Beitrag gut.
  30. #270
    User Pic
    z3us Mitglied
    Registriert seit
    14.09.2012
    Beitrge
    114
    Beitragswertungen
    10 Beitragspunkte
    Heya RedSunset,

    Danke Dir, hat wunderbar geklappt.

    MFG z3us
    Meine Clanpage: Funny Gamers
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Module und Modifikationen

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten