ilch Forum » Ilch Clan 1.1 » Allgemein » index.php

Geschlossen
  1. #1
    User Pic
    thomas gelschter User
    Seit neuesten kann ich nicht mehr auf meine page, da der php-code irgendwie nicht umgesetzt wird. es wird nur der code ab einer bestimmten stelle angezeigt und das sieht dann so aus:

    t1; } $allg = explode ('#',$_SESSION['allg123']); if (!array_key_exists('temp',$_SESSION)) { $_SESSION['temp'] = $allg[2]; } if (!empty($_POST['temp_ch'])) { $_SESSION['temp'] = $_POST['temp_ch']; } $tstyle = $_SESSION['temp']; if(!$m) { $m = news; } if(!$um) { $um = ''; } if (file_exists('include/'.$m.'.php') ) { include ('include/'.$m.'.php'); } else { echo 'Die Angeforderte Datei existiert nicht.'; } ?>
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    manuel ilch-Grnder
    Registriert seit
    22.03.2003
    Beitrge
    4.260
    Beitragswertungen
    4 Beitragspunkte
    sehr merkwürdig liegt aber offenbar an deinem server weil das ja wirklich eher die ausnahem ist *G*

    evtl. hasst du irgendwo irgendwie irgendwas mal mit
    ?>
    geschrieben naja und das bewirkt dann evtl. das es nicht klappt, sprich das es zu so wirrem zeugs kommt *GG*

    also durchsuch deinen code mal nach so merkwürdigen zeichen wie oben und wenn die dir komisch vor kommen einfach mal löschen, wenns dadurch besser wird weg lassen wenn es dadurch schlechter wird pack sie wieder dazu
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    thomas gelschter User
    das einzig komische is der pfeil: -> aber der is in deiner normalen index.php auch drinnen...

    Da ich am code selbst nichts geändert habbe, denk ich eher, dasses an MySQL oder so liegen könnte...

    Ach ja und irgendwie kommt mir auch die Datenbank in MySQl komisch vor, da bei anderen boards (z.B. phpBB)viel mehr tabellen verwendet werden.
    Evtl. benutzt mein server auch eine Version von MySQL, die nicht mit deinen codes funzt oder so...

    mehr kann ich dazu net sagen weil ich net mehr versteh :-)
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    manuel ilch-Grnder
    Registriert seit
    22.03.2003
    Beitrge
    4.260
    Beitragswertungen
    4 Beitragspunkte
    liegt nicht an mysql und das ganze scritp ist absichtlich nur in einer tabelle geschrieben also vollkommen ok.

    schick mir einach mal die index.php datei per email ( manu.st@web.de ) und dann schau ich mal evtl. is doch was verändert oder so...
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    thomas gelschter User
    es ist garantiert nichts verändert, ich habe auch schon die index.php die du mir geschickt hast, und die eigentlich ging ausprobiert und der gleiche fehler ist aufgetaucht.

    aber ich denke es liegt an meinem webspaceprovider, da es so aussieht, dass php oder was weis ich das '>' vom '->' als begrenzung eines tags interpretiert und folglich der ganze darauffolgende code als text abgebildet wird
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    thomas gelschter User
    funzt jetzt wieder, lag am provider (php war deaktiviert)
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurck zu Allgemein

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten