ilch Forum » Ilch Clan 1.1 » Design und Templates » Menü Fehler

Geschlossen
  1. #1
    User Pic
    Cola0501 Mitglied
    Registriert seit
    21.07.2013
    Beiträge
    35
    Beitragswertungen
    0 Beitragspunkte
    Folgendes Problem,

    Beim 1. Menüpunkt tritt der Fehler auf dass es kein Link bzw. Komplett Falscher Link ergibt.





    Code in index.htm
    <div id="navbar" class="navbar-collapse collapse">
              <ul class="nav navbar-nav">{_list_menunr4@
                <li><a target="%1" href="%2">%3</a></li>
                }
              </ul>
            </div><!--/.nav-collapse -->
            </div>


    Code am Ende der Index.htm
    <!-- {_list_DDDmenupoint@<strong><big>&middot;</big></strong><a %1 class="box" href="%2">%3</a><br />}
    {_list_hmenupoint@<li><a target="%1" class="box" href="%2">%3</a>|</li>|<br />|</ul></li>}
    {_list_hmenubegi@<ul>}
    {_list_hmenuende@</ul>}
    {_list_vmenupoint@<a target="%1" class="menu" href="%2">%3</a>}
    {_list_vmenubegi@}
    {_list_vmenuende@}//-->


    Mit freundlichen Grüßen Nico


    verwendete ilch Version: 1.1 P
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    FeTTsack Hall Of Fame
    Registriert seit
    27.06.2012
    Beiträge
    189
    Beitragswertungen
    26 Beitragspunkte
    betroffene homepage ?
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    Lord|Schirmer Administrator
    Registriert seit
    21.03.2007
    Beiträge
    7.260
    Beitragswertungen
    1114 Beitragspunkte
    Lies Dir mal dieses durch:
    www.ilch.de/doku-design11.html#menue

    Dein Menü-Code kann so nicht funktionieren. Hier gibt es nur %1 für Menü-Titel und %2 für Boxeninhalt! Hier können keine Links gesetzt werden, da diese ja schon bei den Zeichenketten für die Menüpunkte am Ende der index.htm definiert werden.
    rules :: doku :: faq :: linkus
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    Cola0501 Mitglied
    Registriert seit
    21.07.2013
    Beiträge
    35
    Beitragswertungen
    0 Beitragspunkte
    Betroffene Homepage ist derzeit eher ein Dev, bzw. Testseite für ein Späteres Projekt -> dev-zone.bplaced.net/ilch

    Jedoch wird dass Menü nun falsch angezeigt sprich code in html so geändert in index.htm :

    <ul class="nav navbar-nav">{_list_menunr4@
    		  <li><a href="%1">%2</a></li>
                
              </ul>}


    Ich will es ja in der "Bootstrap" Design haben und nicht einfach so..
    Rest ist wie im Anfangspost geblieben. Die Menüs sind auf Gleicher Höhe, davor hat es richtig angezeigt aber ebend dieser Fehler dass der 1. Link im Mneü, nicht stimmte.
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    FeTTsack Hall Of Fame
    Registriert seit
    27.06.2012
    Beiträge
    189
    Beitragswertungen
    26 Beitragspunkte
    schau mal hier:

    github.com/IlchCMS/Ilch-1.1/blob/1.1q/include/designs/ilchClan/index.htm

    dort wurde das design von maretz angepasst.

    vielleicht hilft dir das weiter lächeln

    lg fetti
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    Cola0501 Mitglied
    Registriert seit
    21.07.2013
    Beiträge
    35
    Beitragswertungen
    0 Beitragspunkte
    Hatte zwar Kurzes Problem mich einzufinden, aber dann doch geschafft Danke.
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurück zu Design und Templates

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten