ilch Forum » Ilch Clan 1.1 » Fehlersuche und Probleme » Modul im Adminbereich - No permission

Geschlossen
  1. #1
    User Pic
    Outi77 Mitglied
    Registriert seit
    31.03.2013
    Beiträge
    1.208
    Beitragswertungen
    130 Beitragspunkte
    Hallo zusammen,

    wenn ich im Admincenter im Modul Referenzen einen neuen Eintrag zufügen oder einen bestehenden Eintrag bearbeiten möchte, kommt beim Speichern folgende Fehlermeldung:
    ZitatZitat
    You don't have permission to access admin.php on this server.

    Habt ihr eine Idee, was da los sein könnte? Ich habe Adminrechte...
    Die einzige Modifikation ist Maretz's ilch-Admin meets Bootstrap.


    verwendete ilch Version: 1.1 P


    Zuletzt modifiziert von Outi77 am 28.03.2015 - 15:47:29
    Die richtige Formulierung eines Problems ist nicht selten bereits die halbe Lösung.
    »Albert Einstein«
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    Ahrtas Hall Of Fame
    Registriert seit
    17.12.2007
    Beiträge
    2.301
    Beitragswertungen
    202 Beitragspunkte
    Wurde etwas überschrieben bei der Installation?

    Prüfe mal die Verzeichnisse und Dateien, beider Module und schaue ob eins das andere überschreibt.
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    Outi77 Mitglied
    Registriert seit
    31.03.2013
    Beiträge
    1.208
    Beitragswertungen
    130 Beitragspunkte
    Das Modul Referenzen wird beim Installieren des bootstrap-Admin unberührt gelassen. Seltsamerweise hat sich das Problem ohne eigenes Zutun von selbst in Luft aufgelöst. Ich vermute, dass der Wartungs-Modus seine Finger im Spiel hat...
    Nachtrag: könnte doch an etwas anderem liegen, da das Problem andererorts auch auftritt. Wenn ich im AdminCenter einen User bearbeiten möchte, ganz speziell die Homepage des Users, wenn er das "http://" vor seiner HP vergessen hat, tritt das Problem auf. Dann fiel mir der Zusammenhang zum Modul Referenzen ein, da muss man ebenfalls eine Adresse in diesem Format eingeben. Könnte es damit etwas zu tun haben?


    Zuletzt modifiziert von Outi77 am 29.03.2015 - 14:05:19
    Die richtige Formulierung eines Problems ist nicht selten bereits die halbe Lösung.
    »Albert Einstein«
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    Outi77 Mitglied
    Registriert seit
    31.03.2013
    Beiträge
    1.208
    Beitragswertungen
    130 Beitragspunkte
    Sorry für's pushen grumml
    Hat hier eventuell jemand eine Idee?
    Vielleicht kann ich das Problem weiter eingrenzen. Wenn man im Forum php-Code postet, also zb folgende Zeile:
    <a href="javascript:void(0);" onclick="delLogo('.$row['id'].')"><img src="include/images/icons/del.gif" alt="L&ouml;schen" title="L&ouml;schen" border="0"></a>

    kommt ebenfalls eine ähnliche Meldung:
    ZitatZitat
    You do not have permission to access this document.

    Könnte der Hoster irgendein Update gefahren haben, welches dies auslöst?
    Oder kennt jemand das Problem und die Lösung dafür?

    Danke für Eure Hilfe!

    Grüße Outi
    Die richtige Formulierung eines Problems ist nicht selten bereits die halbe Lösung.
    »Albert Einstein«
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    Mairu Coder
    Registriert seit
    16.06.2006
    Beiträge
    15.253
    Beitragswertungen
    366 Beitragspunkte
    Könnte sein, warum fragst du dort nicht einfach nach?
    Und auch immer mal ein Blick auf die FAQ werfen. | Mairus Ilchseite
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    Outi77 Mitglied
    Registriert seit
    31.03.2013
    Beiträge
    1.208
    Beitragswertungen
    130 Beitragspunkte
    Weil dort nur Pappnasen sitzen, die nicht wissen, was sie tun.
    Die richtige Formulierung eines Problems ist nicht selten bereits die halbe Lösung.
    »Albert Einstein«
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    corian Entwickler
    Registriert seit
    16.06.2011
    Beiträge
    844
    Beitragswertungen
    75 Beitragspunkte
    Schau mal nach was die Rechte sagen...
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    Outi77 Mitglied
    Registriert seit
    31.03.2013
    Beiträge
    1.208
    Beitragswertungen
    130 Beitragspunkte
    Die Rechte stimmen allesamt noch, daran wurde ja auch nie etwas geändert.
    Komischerweise kann ich ja den Rang eines jeden Users ändern in der Userübersicht im Admincenter, wenn ich dort dann aber ein Userprofil editieren möchte, kommt immer dann dieser Fehler, wenn irgendwo im Profil dieses "http://" vorhanden ist, andernfalls nicht.
    Das Problem beim Posten von Codeschnipseln tritt übrigens bereits bei der Vorschau auf.
    Die Probleme treten übrigens sowohl bei der Domain, wie auch bei den Subdomains auf, was meine Vermutung untermauert, dass es Folgen einer serverseitigen Änderung sind.

    Nachtrag: ein Verantwortlicher der Seite hat mit dem Hoster gesprochen.
    Dieser sagte, dass es sich um eine Art Spamschutz handelt. Außerdem fragte er, ob das CMS auf dem neuesten Stand sei? Dann hat er irgendwas umgestellt und meinte, dass es jetzt wieder funktionieren sollte...was es aber nur bedingt tut.
    Ich habe nach dem Versuch, im AdminCenter ein Userprofil zu editieren, die Protokoll-Datei angeschaut und folgenden Fehler dazu gefunden:

    ZitatZitat
    ModSecurity: Access denied with code 403 (phase 2). Match of "rx ://%{SERVER_NAME}/" against "ARGS:cseite" required. [file "/etc/httpd/conf/modsecurity.d/rule...sec/50_plesk_basic_asl_rules.conf"] [line "387"] [id "340465"] [rev "56"] [msg "Protected by Atomicorp.com Basic Non-Realtime WAF Rules: Remote File Injection attempt in ARGS (admin.php)"] [severity "CRITICAL"] [hostname "le-graphics.de"] [uri "/admin.php"] [unique_id "VRu-nX8AAAEAACJXgJQAAAAA"]
    [Wed Apr 01 11:55:41 2015] [error] [client 2.242.130.187] Directory index forbidden by Options directive: /var/www/vhosts/le-graphics.de/http...s/include/images/profilmod/posten/, referer

    Vielleicht kann ja jemand von Euch damit was anfangen.

    Kann geschlossen werden, hat sich alles geklärt.

    Zuletzt modifiziert von Outi77 am 02.04.2015 - 20:19:11
    Die richtige Formulierung eines Problems ist nicht selten bereits die halbe Lösung.
    »Albert Einstein«
    0 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    xRebellx Mitglied
    Registriert seit
    07.08.2012
    Beiträge
    138
    Beitragswertungen
    0 Beitragspunkte
    erledigt.


    Zuletzt modifiziert von xRebellx am 25.04.2017 - 23:31:22
    Wer kämpft, kann verlieren. Wer nicht kämpft hat schon verloren .
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurück zu Fehlersuche und Probleme

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten