ilch Forum » Ilch Clan 1.1 » Fehlersuche und Probleme » Profil-Avatar hochladen geht nicht

Geschlossen
  1. #1
    User Pic
    Dmx6 Mitglied
    Registriert seit
    22.02.2007
    Beiträge
    7
    Beitragswertungen
    0 Beitragspunkte
    Hallo ich habe folgendes problem:

    Wenn ich unter -> Profil ein Avatar hochladen will kommt folgende meldung :

    Fatal error: Call to undefined function mime_content_type() in /srv/www/httpd/phost/p/com/pytalhost/XXXX/web/include/contents/user/profil_edit.php on line 73

    Wie kann ich das problem lösen?
    0 Mitglieder finden den Beitrag gut.
  2. #2
    User Pic
    SLJ Hall Of Fame
    Registriert seit
    18.05.2004
    Beiträge
    15.492
    Beitragswertungen
    3 Beitragspunkte
    Soviel ich eiß hat das was mit deiner php version zu tun die auf dem server installiert ist,...
    www.zocker-eppingen.de
    Ilch 1.0.4 PHP 7.0 und PDO Fähig na klar lächeln
    0 Mitglieder finden den Beitrag gut.
  3. #3
    User Pic
    Dmx6 Mitglied
    Registriert seit
    22.02.2007
    Beiträge
    7
    Beitragswertungen
    0 Beitragspunkte
    Ich habe die PHP Version 5.2 aber bei Pytal kann man nichts anderes auswählen! -.- muss ich jetzt auf einen anderen Hoster umsteigen?
    0 Mitglieder finden den Beitrag gut.
  4. #4
    User Pic
    assault Hall Of Fame
    Registriert seit
    03.11.2006
    Beiträge
    2.926
    Beitragswertungen
    1 Beitragspunkte
    ne, das is gut

    vll mal das aktuelle script von hier laden und include/includes/loader.php mit der von deinem webserver überschreiben
    0 Mitglieder finden den Beitrag gut.
  5. #5
    User Pic
    Dmx6 Mitglied
    Registriert seit
    22.02.2007
    Beiträge
    7
    Beitragswertungen
    0 Beitragspunkte
    Habe ich gemacht !:'( Jetzt kommt diese meldung wenn ich die Homapage aufmache:


    Warning: require_once(include/includes/func/ic_mime_type.php) [function.require-once]: failed to open stream: No such file or directory in /srv/www/httpd/phost/p/com/pytalhost/p-g-clan/web/include/includes/loader.php on line 29

    Fatal error: require_once() [function.require]: Failed opening required 'include/includes/func/ic_mime_type.php' (include_path='.:/srv/www/httpd/phost/p/com/pytalhost/p-g-clan/web/') in /srv/www/httpd/phost/p/com/pytalhost/p-g-clan/web/include/includes/loader.php on line 29


    Zuletzt modifiziert von Dmx6 am 22.02.2007 - 19:37:11
    0 Mitglieder finden den Beitrag gut.
  6. #6
    User Pic
    assault Hall Of Fame
    Registriert seit
    03.11.2006
    Beiträge
    2.926
    Beitragswertungen
    1 Beitragspunkte
    verdammt, hast du irgentwelche module installiert???
    vll punktesystem von silent-forces?
    bzw. haste ne ältere Script-version?
    z.B. 1.1c oder davor?


    Zuletzt modifiziert von assault am 22.02.2007 - 19:50:52
    0 Mitglieder finden den Beitrag gut.
  7. #7
    User Pic
    Dmx6 Mitglied
    Registriert seit
    22.02.2007
    Beiträge
    7
    Beitragswertungen
    0 Beitragspunkte
    Habe 1.1E das aktuelle und das BBcode Modul installiert!

    EDIT: Habe noch 1.1 C rumliegen auf meiner Festplatte!


    Zuletzt modifiziert von Dmx6 am 22.02.2007 - 19:52:47
    0 Mitglieder finden den Beitrag gut.
  8. #8
    User Pic
    assault Hall Of Fame
    Registriert seit
    03.11.2006
    Beiträge
    2.926
    Beitragswertungen
    1 Beitragspunkte
    welches bbcode-modul, es gibt mehrere?

    (was auf deiner festplatte ist, will ich garnicht wissen^^)
    0 Mitglieder finden den Beitrag gut.
  9. #9
    User Pic
    Dmx6 Mitglied
    Registriert seit
    22.02.2007
    Beiträge
    7
    Beitragswertungen
    0 Beitragspunkte
    Das hier habe ich Installiert:

    www.ilch.de/downloads-show-700.html
    0 Mitglieder finden den Beitrag gut.
  10. #10
    User Pic
    assault Hall Of Fame
    Registriert seit
    03.11.2006
    Beiträge
    2.926
    Beitragswertungen
    1 Beitragspunkte
    da is ne loader drin, ersetzte die mal mit der aufem server.
    so wies aussieht, ist das modul nicht für e gedacht, und du hast die "veraltete" version von e ~nur so nebenbei~

    öffne die loader.php(vom bbcode) mal mit dem editor und füge -in einer neuen zeile- unter
    require_once('include/includes/func/warsys.php');

    das
    require_once('include/includes/func/ic_mime_type.php');
    ein

    /edit: nochmal das update 'e' ausführen, bevor du das uploadest


    Zuletzt modifiziert von assault am 22.02.2007 - 20:12:22
    0 Mitglieder finden den Beitrag gut.
  11. #11
    User Pic
    Dmx6 Mitglied
    Registriert seit
    22.02.2007
    Beiträge
    7
    Beitragswertungen
    0 Beitragspunkte
    Hab ich gemacht und nun sieht man was vom design aber da wo die News stehen sollten steht:


    Fatal error: Class 'bbcode' not found in /srv/www/httpd/phost/p/com/pytalhost/p-g-clan/web/include/includes/func/bbcode.php on line 18

    Auch das Forumund das Gästebuch sind davo betroffen!


    Zuletzt modifiziert von Dmx6 am 22.02.2007 - 21:03:24
    0 Mitglieder finden den Beitrag gut.
  12. #12
    User Pic
    assault Hall Of Fame
    Registriert seit
    03.11.2006
    Beiträge
    2.926
    Beitragswertungen
    1 Beitragspunkte
    also wohl überall wo der bbcode genutz wird-.-, das teil is nicht für 1.1e so wie mir scheint

    wie sieht denn bei dir die 18. zeile von include/includes/func/bbcode.php aus
    steht da
    	$bbcode = new bbcode();
    ?

    bzw. was war zuerst: das bbcode-modul oder das update auf e(nicht das von heute)
    0 Mitglieder finden den Beitrag gut.
  13. #13
    User Pic
    Dmx6 Mitglied
    Registriert seit
    22.02.2007
    Beiträge
    7
    Beitragswertungen
    0 Beitragspunkte
    Das Update auf E war zuerst.

    Ja in der 18 Zeile steht :
    $bbcode = new bbcode();
    0 Mitglieder finden den Beitrag gut.
  14. #14
    User Pic
    Syncronix Mitglied
    Registriert seit
    21.10.2006
    Beiträge
    1.937
    Beitragswertungen
    0 Beitragspunkte
    ZitatZitat geschrieben von Dmx6

    Ich habe die PHP Version 5.2 aber bei Pytal kann man nichts anderes auswählen! -.- muss ich jetzt auf einen anderen Hoster umsteigen?



    Man kann doch in phpmyadmin so eine codierung auswählen! Vllt. solltest du da mal rumspielen.
    0 Mitglieder finden den Beitrag gut.
  15. #15
    User Pic
    assault Hall Of Fame
    Registriert seit
    03.11.2006
    Beiträge
    2.926
    Beitragswertungen
    1 Beitragspunkte
    hm, dann musst du wohl nochmal das bbcodemodul draufmachen (diesmal ists nicht nötig die install auszuführen), oder mal versuchen das ganze abzugleichen aber das könnte zu schwer werden(ich hab die mod ja nicht drauf), wiederrum könnts ein sicherheitsrisiko sein wenn du die mod draufmachst.

    ich glaub ich kläre dich am besten mal über den Stand der Dinge auf, profiledit.php fragt die loader.php nach mime_type die wurde aber durch den bbcode weggemacht, soweit ich weiß ist mime für den upload zuständig und wird desshalb von profiledit für den avatar grbraucht. die loader sagt aber "gibbet nich" dann muckt die profiledit


    /edit:
    alles falsch, alles falsch, in der loader.php(vom modul) noch unter -neue zeile-
    require_once ('include/includes/lang/de.php');
    das einfügen
    require_once ('include/includes/bbcode_config.php');

    natürlich auch noch das was ich in meinem 4ten post geschrieben hab beherzigen(is ungefähr das gleiche wie hier)


    mann, mann, mann bin ich heute durch'en Wind, bin auch schon seit 6uhr auf achse:'(


    Zuletzt modifiziert von assault am 22.02.2007 - 22:13:22
    0 Mitglieder finden den Beitrag gut.
  16. #16
    User Pic
    FrEEd Mitglied
    Registriert seit
    11.02.2007
    Beiträge
    64
    Beitragswertungen
    0 Beitragspunkte
    ojeee ojeeee

    bei mir gehts sehr änlich ab, bei mir lautet die fehlermeldung:

    Fatal error: Cannot instantiate non-existent class: bbcode in /homepages/38/d99542936/htdocs/alte-zocker/include/includes/func/bbcode.php on line 18

    hab das Punktesystemv1.1fürilch1.1b drauf gemacht, und seit dem siehts aus wie kraut und rübe. wenn ich auf die user namen klicke kommt eine weisse seite mit fehlertext,
    in meinem admin menü siehts auch net so doll aus beben fehlt die leiste und unten habe ich bbcode 3 mal drinn stehn.

    jetzt brauch ich ernsthaft hilfe.

    mfg

    ok geht wieder

    Zuletzt modifiziert von FrEEd am 10.03.2007 - 11:58:00
    www.Alte-Zocker.de Script Version: 1.1 E
    0 Mitglieder finden den Beitrag gut.
  17. #17
    User Pic
    assault Hall Of Fame
    Registriert seit
    03.11.2006
    Beiträge
    2.926
    Beitragswertungen
    1 Beitragspunkte
    okay, no panic

    daste 3mal das bbcodeteil drin hast liegt an der mysql,

    versuchst mal mit dem punktesys für e(link?-> siehe moniwolls sig xD)

    und poste auch mal den inhalt der include/includes/loader.php
    0 Mitglieder finden den Beitrag gut.
  18. #18
    User Pic
    FrEEd Mitglied
    Registriert seit
    11.02.2007
    Beiträge
    64
    Beitragswertungen
    0 Beitragspunkte
    ihr seit einfach super!
    der tip mit der loader.php wargenau richtig da hatte ich den eintrag 3 mal drinen.

    mfg
    www.Alte-Zocker.de Script Version: 1.1 E
    0 Mitglieder finden den Beitrag gut.
  19. #19
    User Pic
    Eomer Mitglied
    Registriert seit
    12.02.2007
    Beiträge
    21
    Beitragswertungen
    0 Beitragspunkte
    Fatal error: Call to undefined function: ic_mime_type() in /usr/export/www/vhosts/funnetwork/hosting/rohirrimclan/include/contents/user/profil_edit.php on line 73

    hab auch diesen Fehler kannst du mir nochmal sagen was ich machen muss?? Bin auf Funpic.de

    gruß Eomer
    Auf Eorlingas
    0 Mitglieder finden den Beitrag gut.
  20. #20
    User Pic
    assault Hall Of Fame
    Registriert seit
    03.11.2006
    Beiträge
    2.926
    Beitragswertungen
    1 Beitragspunkte
    poste auch mal deinen inhalt von include/includes/loader.php, erklärungsbedarf?:
    ZitatZitat geschrieben von "Assault"
    ich glaub ich kläre dich am besten mal über den Stand der Dinge auf, profiledit.php fragt die loader.php nach mime_type die wurde aber durch den mod weggemacht, soweit ich weiß ist mime für den sciheren upload zuständig und wird desshalb von profiledit für den avatar grbraucht. die loader sagt aber "gibbet nich" dann muckt die profiledit

    und ich will der loader die variable hinzufügen, die gebraucht wird


    Zuletzt modifiziert von assault am 27.02.2007 - 20:13:15
    0 Mitglieder finden den Beitrag gut.
  21. #21
    User Pic
    Eomer Mitglied
    Registriert seit
    12.02.2007
    Beiträge
    21
    Beitragswertungen
    0 Beitragspunkte
    Wollte auch nochmal sagen dass ich BB-Code von hier habe also den 1.2.

    <?php
    # Copyright by Manuel
    # Support www.ilch.de

    defined ('main') or die ( 'no direct access' );

    # load all needed classes
    require_once('include/includes/class/tpl.php');
    require_once('include/includes/class/design.php');
    require_once('include/includes/class/menu.php');

    # fremde classes laden
    require_once('include/includes/class/xajax.inc.php');
    require_once('include/includes/class/bbcode.php');

    # load all needed func
    require_once('include/includes/func/db/mysql.php');

    require_once('include/includes/func/calender.php');
    require_once('include/includes/func/user.php');
    require_once('include/includes/func/escape.php');
    require_once('include/includes/func/allg.php');
    require_once('include/includes/func/debug.php');
    require_once('include/includes/func/bbcode.php');
    require_once('include/includes/func/profilefields.php');
    require_once('include/includes/func/statistic.php');
    require_once('include/includes/func/listen.php');
    require_once('include/includes/func/forum.php');
    require_once('include/includes/func/warsys.php');

    # load something else
    require_once ('include/includes/lang/de.php');
    require_once ('include/includes/bbcode_config.php');

    ?>

    edit: hab das oben mal reinkopiert jetzt klappts danke


    Zuletzt modifiziert von Eomer am 28.02.2007 - 15:14:49
    Auf Eorlingas
    0 Mitglieder finden den Beitrag gut.
  22. #22
    User Pic
    SolidTC Mitglied
    Registriert seit
    18.01.2007
    Beiträge
    32
    Beitragswertungen
    0 Beitragspunkte
    Ich hatte das gleiche Problem.

    Avatarupload und Bilderupload in der Usergallery waren nicht möglich.
    Habe soeben nur
    require_once ('include/includes/bbcode_config.php');

    eingefügt und beides funktioniert wieder einwandfrei.
    0 Mitglieder finden den Beitrag gut.
  23. #23
    User Pic
    Dupatch Mitglied
    Registriert seit
    15.01.2007
    Beiträge
    24
    Beitragswertungen
    0 Beitragspunkte
    Ich habs so gemacht:

    <?php
    # Copyright by Manuel
    # Support www.ilch.de

    defined ('main') or die ( 'no direct access' );

    # load all needed classes
    require_once('include/includes/class/tpl.php');
    require_once('include/includes/class/design.php');
    require_once('include/includes/class/menu.php');

    # fremde classes laden
    require_once('include/includes/class/xajax.inc.php');

    # load all needed func
    require_once('include/includes/func/db/mysql.php');

    require_once('include/includes/func/calender.php');
    require_once('include/includes/func/user.php');
    require_once('include/includes/func/escape.php');
    require_once('include/includes/func/allg.php');
    require_once('include/includes/func/debug.php');
    require_once('include/includes/func/bbcode.php');
    require_once('include/includes/func/profilefields.php');
    require_once('include/includes/func/statistic.php');
    require_once('include/includes/func/listen.php');
    require_once('include/includes/func/forum.php');
    require_once('include/includes/func/warsys.php');
    require_once('include/includes/func/ic_mime_type.php');

    # load something else
    require_once ('include/includes/lang/de.php');
    require_once ('include/includes/bbcode_config.php');
    ?>


    Doch dann kommt der fehler:

    Warning: require_once(include/includes/func/ic_mime_type.php) [function.require-once]: failed to open stream: No such file or directory in /home/www/sp01_55/html/include/includes/loader.php on line 29

    Fatal error: require_once() [function.require]: Failed opening required 'include/includes/func/ic_mime_type.php' (include_path='.') in /home/www/sp01_55/html/include/includes/loader.php on line 29
    0 Mitglieder finden den Beitrag gut.
  24. #24
    User Pic
    assault Hall Of Fame
    Registriert seit
    03.11.2006
    Beiträge
    2.926
    Beitragswertungen
    1 Beitragspunkte
    exitstiert überhaupt: include/includes/func/ic_mime_type.php
    0 Mitglieder finden den Beitrag gut.
  25. #25
    User Pic
    Dupatch Mitglied
    Registriert seit
    15.01.2007
    Beiträge
    24
    Beitragswertungen
    0 Beitragspunkte
    lol neee !

    Danke hat geklappt THX !
    0 Mitglieder finden den Beitrag gut.
  26. #26
    User Pic
    NickName gelöschter User
    ZitatZitat geschrieben von Dupatch
    ... No such file or directory ...

    Fatal error: require_once() [function.require]: Failed opening required 'include/includes/func/ic_mime_type.php' ...


    eigentlich sagen die fehlermeldungen schon was los ist zwinker

    desweiteren sieht man mal wieder, wie die leute die readmes lesen und beachten - einfach mal nen mod rüberbügeln funzt in den seltensten fällen, am besten die originaldateien mit den moduldateien vergleichen (bsp. WINMERGE)


    und da drängt sich doch wieder meine bitte in den vordergrund:

    schreibt (wie mairu) eine changes.doc oder .htm(l) in der die änderungen genau aufgeführt werden, so das JEDER user mit hilfe dieser datei SEINE originaldateien anpassen kann - sollte doch kein prob sein, schnell noch solch eine datei neben der readme zu erstellen oder die daten gleich in die readme mit einzutragen?!
    0 Mitglieder finden den Beitrag gut.
  27. #27
    User Pic
    Mairu Coder
    Registriert seit
    16.06.2006
    Beiträge
    15.253
    Beitragswertungen
    366 Beitragspunkte
    Es macht schon etwas unliebsame Arbeit zwinker
    Und auch immer mal ein Blick auf die FAQ werfen. | Mairus Ilchseite
    0 Mitglieder finden den Beitrag gut.
  28. #28
    User Pic
    NickName gelöschter User
    ZitatZitat geschrieben von Mairu

    Es macht schon etwas unliebsame Arbeit zwinker



    aber es erspart den codern doch widerum eine menge an supportarbeit - wenn ich dich nach jedem ilch-update gefragt hätte: was muss ich nochmal ändern oder ähnliches, wärst du nur noch mit mir bechäftigt, da ich mehrere module und sonstige codes von dir nutze zwinker ^^
    0 Mitglieder finden den Beitrag gut.
  29. #29
    User Pic
    assault Hall Of Fame
    Registriert seit
    03.11.2006
    Beiträge
    2.926
    Beitragswertungen
    1 Beitragspunkte
    man könnte jetzt auch sagen, dass jeder eine readme.htm machen soll, indem man schreibt:

    ordner/blah/datei.php
    suche nach:
    $blubber
    füge darunter/daneben/darüber ein:
    oder
    ersetzte durch:
    oder
    löschen

    $noch == "mehr $code %s"

    dann sind wir wbb schon sehr nahe:
    voll noobs, die zuviel angst haben etwas falsch zu machen, lassen es; die "mid-skilled" fragen vll kurz nach, weil auf einmal ne funktion weniger ist, checken dann aber was sie machen müssen; und die high....tja, wisst ihr ja^^
    0 Mitglieder finden den Beitrag gut.
  30. #30
    User Pic
    Mairu Coder
    Registriert seit
    16.06.2006
    Beiträge
    15.253
    Beitragswertungen
    366 Beitragspunkte
    Hier mal als Beispiel von meinem letzten Modul, ist mit einem Hilfsprogramm und Handarbeit entstanden:
    www.dynamicgamerz.de/download/Mairu/Changes.html
    Und auch immer mal ein Blick auf die FAQ werfen. | Mairus Ilchseite
    0 Mitglieder finden den Beitrag gut.
Geschlossen

Zurück zu Fehlersuche und Probleme

Optionen: Bei einer Antwort zu diesem Thema eine eMail erhalten